1. earful_'s Avatar
    Following Saurik's new tutorial, appended to the hosts file so it's passing the verify (where it failed before), it's running the update, and then giving me a 1604 error.

    Sucks

    Tried with iTunes 9 and 8.2.1 on Windows and a Mac.

    Any hints?
    2009-09-15 02:13 PM
  2. misa_reg's Avatar
    [QUOTE=earful_;4951726]giving me a 1604 error.

    Hello

    I have the same error message, with 3GS device.
    I would like to downgrade my 3.1 phone.
    Do you solved the problem or found what is the problem?

    MiSA
    2009-09-21 12:05 PM
  3. Viperous's Avatar
    Would also like to know this >.>
    2009-10-02 12:47 AM
  4. Madman604x's Avatar
    what ECID hashes do you have stored with Cydia/Saurik?

    if you only have one for 3.1, you can't restore to 3.0 or 3.0.1

    if you didnt get your ECID info stored before 3.1 was released, you NEVER will.

    its 3.1 for all 3 of you judging by the # of posts you have.
    2009-10-02 01:02 AM
  5. teme's Avatar
    ^lol @ judging by the number of posts, but very true
    2009-10-02 03:08 AM
  6. Viperous's Avatar
    My ECID was stored on Cydia when I was running 3.0.1. I saved it with Cydia the day that it first started prompting for it.
    2009-10-02 03:14 AM
  7. teme's Avatar
    which one was saved? 3.0 or 3.1?
    i'm running 3.0.1, but when it saved the file it saved it for 3.1
    2009-10-02 03:17 AM
  8. Viperous's Avatar
    I am not sure, anyway to find out? I assumed since I updated Cydia the day the update was released I was good?
    2009-10-02 03:26 AM
  9. teme's Avatar
    open cydia, it should be on the top part, see attachment where it says this device...
    Attached Thumbnails So, error 1604 when downgrading 3GS from 3.1 to 3.0..-img_0019.png  
    2009-10-02 03:33 AM
  10. Viperous's Avatar
    Don't remember since I am not jailbroke atm (had to restore to 3.1).

    However, I believe I found the problem. I was trying to restore to iPhone2,1_3.0.1_7A400_Restore (which was giving me the 1604 error). I am currently restoring to iPhone2,1_3.0_7A341_Restore...and it seems to be working with no issues.
    2009-10-02 04:21 AM
LINK TO POST COPIED TO CLIPBOARD