1. bondkt's Avatar
    The new and improved guide can be found at:


    http://modmyi.com/forums/3g-s-downgr...-tutorial.html


    Works in windows xp, vista or 7 with itunes 9+.

    Enjoy!
    Last edited by bondkt; 2010-06-21 at 03:53 AM. Reason: Added 2 pics. color coded sections, added toc, sections, downloads, Q&A, intro etc. Also added where to download locations.
    2009-09-17 06:03 AM
  2. krascal2323's Avatar
    does this quickpwn work for windows i cant unzip the file
    2009-09-17 08:04 AM
  3. bondkt's Avatar
    Yes it does, you just need a better unzipped, go HERE.

    download the 32 or 64 bit (whichever you have) and try again, should work =)

    if not post again and I'll send it one unzipped.
    Last edited by bondkt; 2009-09-19 at 06:12 PM.
    2009-09-17 08:23 AM
  4. titeo's Avatar
    nice....i ran into this error.

    they say 2G and 3G is safe to restore back to 3.0 or 3.0.1 but its not the case. restoration will finish half way but with an error. but i believe it is fully restored...but not verified through itunes.
    1st Gen iPhone 2.0 - Jailbroken and Unlocked on T-Mobile
    2009-09-17 08:45 AM
  5. bondkt's Avatar
    It is (you don't To edit the host file). Bit if you downgrade from 3.1 to 3.0 on any phone you will get error 1015, and this will fix it, no matter if your a 2g, 3g or 3g[s].
    2009-09-17 08:49 AM
  6. l33b3z's Avatar
    Hi bondkt, I've followed your instructions, but when I browse for the IPSW file and click on it, it says it doesn't recognise it?!? I've downloaded 3.0 & 3.1 IPSW file and it won't open any of them. Any advice or pointers?

    Thanks in advance
    2009-09-17 10:38 AM
  7. zguy916's Avatar
    Hey guys ,,, I managed to downgrade my AT&T 3gs 3.1 to 3.0 using sauriks's ecid shsh ........my question is ,,,did I do something wrong if I can't get AT&T cell service after downgrading ?!? Please help out thanks in advance guys !!!!
    2009-09-17 10:49 AM
  8. bondkt's Avatar
    no not at all ( I have seen it happen to somone else) simply reatore again to 3.0 then yes my method above, should solve the problem.
    Last edited by bondkt; 2009-09-19 at 05:50 PM.
    2009-09-17 03:25 PM
  9. zguy916's Avatar
    So is anyone else that is on AT&T that did a downgrade and now having no cell signal ?!?can someone please help me out ,,,let me know if I did something wrong or forgot something ......thanks in adavance
    2009-09-17 05:35 PM
  10. bondkt's Avatar
    Just restore in DFU mode, get error 1015, then use the method above =P
    2009-09-17 06:39 PM
  11. titeo's Avatar
    It is (you don't To edit the host file). Bit if you downgrade from 3.1 to 3.0 on any phone you will get error 1015, and this will fix it, no matter if your a 2g, 3g or 3g[s].
    i'm not downgrading...i am simply restoring to 3.0.1. my 3g came with 3.0 so i'm restoring to 3.0.1 and jailbreaking it. but it doesn't finish restoring. it gets half way on my phone then error. then my phone is stuck in DFU mode. so i use quickpwn to get it out of it.

    so i end up with the "slide for emergency" screen. i'm guessing its back to the fresh restore...so i jailbreak it with redsn0w.

    is this similar to your problem?
    1st Gen iPhone 2.0 - Jailbroken and Unlocked on T-Mobile
    2009-09-17 06:42 PM
  12. bondkt's Avatar
    Hi bondkt, I've followed your instructions, but when I browse for the IPSW file and click on it, it says it doesn't recognise it?!? I've downloaded 3.0 & 3.1 IPSW file and it won't open any of them. Any advice or pointers?

    Thanks in advance
    Ello! Are you meaning in itunes or quickpwn?

    If your meaning itunes: try uninstalling then re-installing, and re-downloading 3.0 FW again.

    Quickpwn: after you phone boots to the lock screen, you don't need quickpwn (it wont jailbreak your phone).

    To jailbreak it, download redsn0w 0.8 from the dev-team here:

    Dev-Team Blog - redsn0w in june

    i'm not downgrading...i am simply restoring to 3.0.1. my 3g came with 3.0 so i'm restoring to 3.0.1 and jailbreaking it. but it doesn't finish restoring. it gets half way on my phone then error. then my phone is stuck in DFU mode. so i use quickpwn to get it out of it.

    so i end up with the "slide for emergency" screen. i'm guessing its back to the fresh restore...so i jailbreak it with redsn0w.

    is this similar to your problem?
    Ah i gotcha. Saurik saved 3.0, not 3.0.1. So if you have your ECID on file with Saurik, it'll restore to 3.0, not 3.0.1.

    I also tried to restore to 3.0.1 but it failed. Did 3.0 and worked fine, try 3.0. If you you didn't upgrade to 3.1, you shouldn't even get an error message =P
    Last edited by bondkt; 2009-09-17 at 06:56 PM. Reason: Automerged Doublepost
    2009-09-17 06:56 PM
  13. krascal2323's Avatar
    After the second restore do not USE red snów , use purple rain. Purple rain will roboot your phone without using irecover or quickpwn. after jailbreak is complete youll be stuck in recovery modę simply disconnect open iTunes and reconnect. iTunes should rocognize your device and activate your service with atnt.
    2009-09-17 07:28 PM
  14. bondkt's Avatar
    This method is a lot simpler, and gives you the opition if you wan to jailbreak or not ( most do though ).
    2009-09-17 08:42 PM
  15. greaseball75's Avatar
    I finally jailbroke my iPhone 3GS and restored it to 3.0, but now I have no service, can someone tell how to get my service back? Please help!!!!

    Finally got my serice back and successfully downgraded from 3.1 to 3.0 on Iphone 3GS!!!!! Thanks a million, this is the easist way to get it to work!!!!!!!! You rock!!! Cydia, welcome back baby!!!!!
    Last edited by greaseball75; 2009-09-17 at 10:17 PM. Reason: Automerged Doublepost
    2009-09-17 10:17 PM
  16. zguy916's Avatar
    Ok guys sorry to be a newbie bug ....lol Soooo after I get the second error code 1015 just close out iTunes and open purplera1n.exe and do a normal jailbreak ........once jailbreak completes open iTunes and it should activate my AT&T to work after the 3.1 downgrade and purplera1n jailbreak ?!? Thanks a lots guys
    2009-09-17 10:53 PM
  17. bondkt's Avatar
    or a lot simpler way is to do what i first posted, then use redsn0w to jailbreak =p
    2009-09-17 11:33 PM
  18. joshzdad's Avatar
    HOLY #@&^$&^%$*&%$%^$ it frickin worked!!!!!!!!!!!!! been trying to fix this issue for ^%$&^%#^%$# weeks!!!!!!!!!

    Thanks Thanks Thanks!!!!!!!!!!!!!!!!!
    2009-09-18 04:27 AM
  19. cricketlang's Avatar
    just so you guys know what the error is it occurs when the baseband you are installing is older than the one currently on the phone. the phone completes its OS installation first and THEN proceeds to the baseband. so quickpwn is simply forcing the phone out of recovery mode. thats all. just forces it to boot with what it has. then you see the initial springboard status loader which then makes everything better for the next boot. then just jailbreak as usual
    The beatings will continue until morale improves.
    2009-09-18 05:13 AM
  20. bondkt's Avatar
    just so you guys know what the error is it occurs when the baseband you are installing is older than the one currently on the phone. the phone completes its OS installation first and THEN proceeds to the baseband. so quickpwn is simply forcing the phone out of recovery mode. thats all. just forces it to boot with what it has. then you see the initial springboard status loader which then makes everything better for the next boot. then just jailbreak as usual
    Yup sets the auto-boot is all, very true. =P

    HOLY #@&^$&^%$*&%$%^$ it frickin worked!!!!!!!!!!!!! been trying to fix this issue for ^%$&^%#^%$# weeks!!!!!!!!!

    Thanks Thanks Thanks!!!!!!!!!!!!!!!!!
    Woot awesome =P
    Last edited by bondkt; 2009-09-18 at 05:34 AM. Reason: Automerged Doublepost
    2009-09-18 05:34 AM
142 123 ...
LINK TO POST COPIED TO CLIPBOARD