1. hkesunny's Avatar
    Everything is going smoothly. When I use the iTune (8.2) to restore the the firmware 3.0.1. It display a error 3100! What's it means and how to fix it. My iPhone is now stuck at recovery mode (itune with usb plug)! I need your help!
    2009-09-22 08:20 AM
  2. Pabs2000's Avatar
    hello, I did all the configuration an got the tinytss server runnign, i did also the netstat -o -n -a | findstr 0.0:80 to check that only the server was running and all ok.
    The hosts has only the 127.0.0.1 pointig to the gs.apple.com, but when i ping the name it doesn't reply.
    When i ping to 127.0.0.1 all is ok.
    What could be happening???

    Thanks
    2009-09-22 08:44 AM
  3. Ed Hardy's Avatar
    Ok, after I "Restore" the 3.0 FW I get the 1015 error from iTunes, My phone reboots into restore mode, I then started up RedSn0w 0.8 and did everything I needed there, after RedSn0w was completed the phone is stuck in a "waiting for NAND to appear..." loop.

    I noticed something about NAND couldn't be found due to format mismatch.
    Last edited by Ed Hardy; 2009-09-22 at 09:01 AM.
    2009-09-22 08:55 AM
  4. dtkool's Avatar
    I have a 3Gs Iphone v3.0.1 stuck in Apple Logo Bootup Mode.
    - Never backed up or hashed the ECID or SHSH on Cydia

    However, I did used Umbrella & TinyTSS to obtain my ECID & SHSH for both v3.0 & v.3.0.1. Redirected the Hosts to 127.0.0.1 gs.apple.com (Ping normal & working)

    When I restore in iTunes 9.0, the process started but Error with (1600, 1601, & 3300.)

    Will Umbrella & TinyTSS allow 3Gs iPhone with v3.0 or v3.0.1 to be able to restore back to Fresh & Virgin state of v3.0 or v3.0.1? (By using Umbrella & TinyTSS to backup ECID & SHSH)
    2009-09-22 09:03 AM
  5. Pabs2000's Avatar
    When the itunes is checking the server, i get the error 1600.

    What could be going on??
    2009-09-22 09:15 AM
  6. Ed Hardy's Avatar
    When the itunes is checking the server, i get the error 1600.

    What could be going on??
    Are you using DFU mode or normal restore mode (with iTunes logo)?
    which ever you are using try out the other mode and see if that works.

    as for myself
    I got past the NAND loop problem and I now am here
    Code:
    Waiting for NAND to appear...
    [FTL:MSG] FTL_Open		[OK]
    Mounting rootfs as read-only...
    fscking rootfs...
    dyld: Library not loaded: /usr/lib/libgcc_s.1.dylib
     Referenced from: /mnt/sbin/fsck_hfs
     Reason: image not found
    fscking disk0s2s1...
    dyld: Library not loaded: /usr/lib/libgcc_s.1.dylib
     Referenced from: /mnt/sbin/fsck_hfs
     Reason: image not found
    Mounting rootfs as read-write...
    	0 [Level 3] [ReadUID 0] [Facility com.apple.system.fs] [ErrType FS] [MountPt /mnt]
    	0 [Level 3] [ReadUID 0] [Facility com.apple.system.fs] [ErrType FS] [MountPt /mnt]
    mounting devfs...
    mounting disk0s2s1...
    ERROR!
    2009-09-22 10:55 AM
  7. ApFinder's Avatar
    I gathered the information from Saurik server and went well, I think, got a file with -+64kb.

    Since I have "this iphone 3g[s] has an ecid shsh on file" on Cydia I tried get information for all firmware versions, here is the result:

    For 3.0 I get 00.shsh with +-64kb - I believe this is ok! Right???
    For 3.01 I get 00.shsh with +-1kb - I believe is fake.
    For 3.1 I get 00.shsh with +-64kb - This mean that I also have ECID SHSH for version 3.1 ????

    tks.
    2009-09-22 10:55 AM
  8. Ed Hardy's Avatar
    I gathered the information from Saurik server and went well, I think, got a file with -+64kb.

    Since I have "this iphone 3g[s] has an ecid shsh on file" on Cydia I tried get information for all firmware versions, here is the result:

    For 3.0 I get 00.shsh with +-64kb - I believe this is ok! Right???
    For 3.01 I get 00.shsh with +-1kb - I believe is fake.
    For 3.1 I get 00.shsh with +-64kb - This mean that I also have ECID SHSH for version 3.1 ????

    tks.
    The 3.0.1 file doesn't seem to work, I also only get a 4 kb file.
    2009-09-22 11:37 AM
  9. bnacht's Avatar
    I know I have my ECID on his server and I added 74.208.105.171 gs.apple.com to my hosts. I also tried to run tinytts and it got stuck about to run. Even with Sauriks server added with my file on his server itunes still wont restore (Firmware is not compatible) I have the 3gs and dont want to upgrade. Any ideas?
    Please help
    2009-09-22 11:50 AM
  10. xsemaphorex's Avatar
    bnacht: you need to obtain the shsh file from cydia. To do this you will need to -

    Windows:

    umbrella -c (your-ecid) -v 3.0
    or
    umbrella -c (your ecid) -v 3.0.1

    (depending on which ecid shsh saurik has for you)

    Mac:
    java -jar umbrella.jar -c (your-ecid) -v 3.0
    or
    java -jar umbrella.jar -c (your ecid) -v 3.0.1


    Everyone else should note that although cydia will respond for a 3.0.1 request, if the file you receive is small-ish (~4k) take a look in it. It is likely it has <plist version="1.0"></plist> and this means that you do not have ecid shsh on file for 3.0.1 on cydia and you should NOT try restoring to 3.0.1 it just won't work. Check 3.0. If he has that for you, you can restore to 3.0

    If this is the case this is because cydia always returns a successful message whether or not you have data on its server. THIS IS DIFFERENT FROM HOW APPLE RESPONDS. This is not a glitch in umbrella.
    2009-09-22 12:25 PM
  11. jmaddox's Avatar
    Thanks for the tutorial! Now if I just had something to downgrade from I would be happy lol!!!
    2009-09-22 01:04 PM
  12. iGuru's Avatar
    I've now added iTunes restore instructions (see Pt. 4)

    ---

    The hosts has only the 127.0.0.1 pointig to the gs.apple.com, but when i ping the name it doesn't reply.
    That means you didn't set your hosts file correctly.

    Everything is going smoothly. When I use the iTune (8.2) to restore the the firmware 3.0.1. It display a error 3100! What's it means and how to fix it. My iPhone is now stuck at recovery mode (itune with usb plug)! I need your help!
    Update to iTunes 9, then try reading part 4 of the howto.

    for myself
    I got past the NAND loop problem and I now am here
    Try restoring again, and then using RedSn0w.

    For 3.0 I get 00.shsh with +-64kb - I believe this is ok! Right???
    For 3.01 I get 00.shsh with +-1kb - I believe is fake.
    For 3.1 I get 00.shsh with +-64kb - This mean that I also have ECID SHSH for version 3.1 ????
    Correct.

    I know I have my ECID on his server and I added 74.208.105.171 gs.apple.com to my hosts. I also tried to run tinytts and it got stuck about to run. Even with Sauriks server added with my file on his server itunes still wont restore (Firmware is not compatible) I have the 3gs and dont want to upgrade. Any ideas?
    Please help
    Check you downloaded the correct Firmware. It should start iPhone2,1.

    Thanks for the tutorial! Now if I just had something to downgrade from I would be happy lol!!!
    No problem
    iGuru, aka macdotnub/mac.nub - Twitter: http://www.twitter.com/macdotnub
    Get your ECID SHSH file! (For 3GS Restore verification) http://bit.ly/JnDw2 (Thanks to semaphore!)
    2009-09-22 01:21 PM
  13. Ed Hardy's Avatar
    Try restoring again, and then using RedSn0w.
    Redsn0w is what I'm using, I posted the error that I am getting now.
    2009-09-22 01:52 PM
  14. iGuru's Avatar
    Redsn0w is what I'm using, I posted the error that I am getting now.
    Try restoring back up to 3.1, then restore down to 3.0 twice again, then use RedSn0w.
    Last edited by iGuru; 2009-09-22 at 02:07 PM.
    iGuru, aka macdotnub/mac.nub - Twitter: http://www.twitter.com/macdotnub
    Get your ECID SHSH file! (For 3GS Restore verification) http://bit.ly/JnDw2 (Thanks to semaphore!)
    2009-09-22 02:02 PM
  15. MagmaWork's Avatar
    Hey guys,

    I've done all the steps perfectly up until the Tinytss.exe which keeps giving me "ur not admin or something running on port 80"

    how can i detect what process is hogging port 80? i right click on tinytss and run as admin, still same error.

    Sorry if its a repeated question but i searched with no luck
    2009-09-22 03:03 PM
  16. xsemaphorex's Avatar
    Magma - open a command window or terminal (depending on your OS)

    If you are on a

    MAC:
    netstat -an | grep -i listen | grep ":80"

    PC:
    netstat -an | find "LISTEN" | find ":80"


    if the commands run and you dont see any results then you are not running the app as administrator or dont have the required privileges to start a listener on port 80.

    if you see an item listed ie:

    TCP 127.0.0.1:80 0.0.0.0:0 LISTENING

    Then this means you have a webserver or IIS or something running that is already listening on port 80.

    As iTunes connects to that port there is no simple way to run TinyTSS on another port and have iTunes connect to it without doing some moderate to serious ssh port forwarding.
    2009-09-22 03:10 PM
  17. Ed Hardy's Avatar
    The problem I was having had something to do with the setup of my laptop, I switched over to an old server I had laying around that had Win xp on it and retried, everything worked fine.

    However my carrier logo is missing, I can't connect to AT&T's network now and my wifi will not connect.

    Edit: After I did a reset from the settings app, I got the WiFi to work.
    Last edited by Ed Hardy; 2009-09-22 at 03:35 PM.
    2009-09-22 03:18 PM
  18. iGuru's Avatar
    The problem I was having had something to do with the setup of my laptop, I switched over to an old server I had laying around that had Win xp on it and retried, everything worked fine.

    However my carrier logo is missing, I can't connect to AT&T's network now and my wifi will not connect.
    Carrier logo missing is a known issue with 3.1, as you were downgrading, i'm guessing it got carried over to 3.0 - I beleive it's a baseband issue. Not being able to connect to AT&T sounds like RedSn0w hacktivated your device, if this happened it won't work on the official carrier.

    Make sure to upgrade/downgrade/etc. with the AT&T sim in the phone.

    Try restoring to 3.0 twice again, then, instead of Jailbreaking, use these instructions to get it out of Recovery mode.

    Assuming everything works after that then try re-jailbreaking.
    Last edited by iGuru; 2009-09-22 at 03:47 PM.
    iGuru, aka macdotnub/mac.nub - Twitter: http://www.twitter.com/macdotnub
    Get your ECID SHSH file! (For 3GS Restore verification) http://bit.ly/JnDw2 (Thanks to semaphore!)
    2009-09-22 03:44 PM
  19. Rvman's Avatar
    Can you please tell me how to turn off web servers? I have googled subject but am unable to find answer.
    TIA
    2009-09-22 03:58 PM
  20. iGuru's Avatar
    Can you please tell me how to turn off web servers? I have googled subject but am unable to find answer.
    TIA
    I'm afraid there's no easy answer to this question, it varies from server to server. There's no way for me to possibly know which one you happen to have.

    Sorry, this is something you'll have to figure out yourself.
    iGuru, aka macdotnub/mac.nub - Twitter: http://www.twitter.com/macdotnub
    Get your ECID SHSH file! (For 3GS Restore verification) http://bit.ly/JnDw2 (Thanks to semaphore!)
    2009-09-22 04:04 PM
678 1234513 ...
LINK TO POST COPIED TO CLIPBOARD