1. Staj's Avatar
    Doesn't dfu mode allow you to accept Older firmware as opposed to using recovery?

    Also what happened to once jailbroken, always jailbroken? If your allready jailbroken shouldnt you be able to accept unsigned code?

    Can't someone make a program other than iTunes that allows you to flash your iphone?

    Now that I'm 3.0.1 jailbroken can I get a 3.1 custom ipsw ( with old baseband) and upload it while also getting signed by apple

    Also I requested cydia to make my life easier but it says pending, so when does it actually happen?
    2009-09-28 11:32 PM
  2. Madman604x's Avatar
    Doesn't dfu mode allow you to accept Older firmware as opposed to using recovery?
    neither do now. if you dont have your ECID info for older firmwares stored on Cydia before 3.1 was released, you cannot flash back to them.

    Also what happened to once jailbroken, always jailbroken? If your allready jailbroken shouldnt you be able to accept unsigned code?
    only until you do a firmware update.

    Can't someone make a program other than iTunes that allows you to flash your iphone?
    i don't have an answer for that.

    Now that I'm 3.0.1 jailbroken can I get a 3.1 custom ipsw ( with old baseband) and upload it while also getting signed by apple
    not until a 3.1 Jailbreak is released. hopefully it will be soon.

    Also I requested cydia to make my life easier but it says pending, so when does it actually happen?
    you will recieve a ECID hash for 3.1 if you didnt request it BEFORE 3.1 was released. your request may be pending as everyone and their brother is pounding the server with requests too. it takes a little time. conversely you could try the firmware umbrella mentioned in the first thread in this forum to get your ECID hash for 3.1 stored on your own PC
    2009-09-29 12:15 AM
  3. iGuru's Avatar
    Doesn't dfu mode allow you to accept Older firmware as opposed to using recovery?
    No.

    Also what happened to once jailbroken, always jailbroken? If your allready jailbroken shouldnt you be able to accept unsigned code?
    You can. But only Jailbroken 3.0 -> 3.0.1 -> 3.1 (when released) with the 3GS there is no going back, unless your ECID SHSH is on file for that version. However as long as you stay on one of the versions that is jailbroken... you are always jailbroken. Therefore, the statement still stands.

    Can't someone make a program other than iTunes that allows you to flash your iphone?
    If you want make one, be my guest.

    Now that I'm 3.0.1 jailbroken can I get a 3.1 custom ipsw ( with old baseband) and upload it while also getting signed by apple
    You will be able to just as soon as PwnageTool is released for the 3GS.

    Also I requested cydia to make my life easier but it says pending, so when does it actually happen?
    Whenever Saurik's server gets round to it.
    iGuru, aka macdotnub/mac.nub - Twitter: http://www.twitter.com/macdotnub
    Get your ECID SHSH file! (For 3GS Restore verification) http://bit.ly/JnDw2 (Thanks to semaphore!)
    2009-09-29 12:17 AM
  4. Staj's Avatar
    so your saying that if i have a jailbroken iphone 3gs 3.01 now and if it dies i can still put a fresh 3.0 or 3.01 on it as i am currently jailbroken?
    2009-09-29 12:19 AM
  5. iGuru's Avatar
    so your saying that if i have a jailbroken iphone 3gs 3.01 now and if it dies i can still put a fresh 3.0 or 3.01 on it as i am currently jailbroken?
    No. I am saying unless you have your ECID SHSH file for that particular version, you can not downgrade at all. When yours is generated it will be for 3.1, so that is going to be the version you can downgrade to if you need to in the future.
    iGuru, aka macdotnub/mac.nub - Twitter: http://www.twitter.com/macdotnub
    Get your ECID SHSH file! (For 3GS Restore verification) http://bit.ly/JnDw2 (Thanks to semaphore!)
    2009-09-29 12:20 AM
  6. Buddha321's Avatar
    If you have a jailbroken iphone that's functioning properly, you should be able to upgrade to a newer jailbreak version(e.g when the jailbroken FW 3.1 comes out). But the problem is if you messed up something on your phone and you need to restore, then you can't. Cause now you are not doing an upgrade, you're doing a restore. Then if you don't have the 3.0 ECID hashed by Cydia, then you can't.

    Or another scenario is, you upgraded to the official 3.1 by mistake, since your phone are no longer jailbroken, then you can only wait till the release of the jailbreak 3.1
    2009-09-29 09:35 AM
  7. Madman604x's Avatar
    DFU = Don't ****ing upgrade
    2009-09-29 09:33 PM
LINK TO POST COPIED TO CLIPBOARD