1. jasonlucky2's Avatar
    Hello modmyi, I really need help donwgrading. Let me tell you everything.

    I forget which firmware i was on, it was either 3.0 or 3.0.1, and I got the mesage in cydia to save my hashes on sauriks server. So i selected ok, and I did see in a couple days that it said it has like a 3.0 or 3.0.1 shsh on file or whatever. So THEN the 3gs 3.1 jailbreak came out with pwnagetool. I sucessfully jbed my phone in 3.1, but then when i looked in cydia, it said it has a 3.1 hash on file. So I restored my phone for no apparent reason with the OFFICIAL 3.1 firmware by accident, so my baseband was upgraded and i lost my jb(even though im using official AT&T, so i dont need an unlock. SO I edited the host file and all that crap, but now whenever i try to put it in dfu mode and restore with 3.0 or 3.0.1 firmware, it says "The device isnt eligible for the requested build". PLEASE HELP!!!! IF you need more info just ask.

    Thanks
    2009-10-10 09:59 PM
  2. L00i3's Avatar
    The key is where Cydia reports that your 3G[S] has a 3.1 ECID SHSH on file. Cydia reports the lowest version it has info for you for. So since yours says 3.1, that is the lowest you will ever be able to get your phone down to. Unfortunately, since you went to Official 3.1 (and can't downgrade) you broke the broken chain of trust. In order for you to get your jailbreak back, you will have to wait for a tool that will jailbreak official 3.1 Apparently geohot is real close to getting blackra1n fully functional. I'll believe it when I see it though.
    Last edited by L00i3; 2009-10-11 at 12:17 AM.
    2009-10-11 12:14 AM
  3. jasonlucky2's Avatar
    Ok, thanks for your response, I guess ill just have to wait -.-
    2009-10-11 04:22 AM
LINK TO POST COPIED TO CLIPBOARD