1. shane1900's Avatar
    Hi,

    I believe I had 3.0 on my 3gs - used Cydia and uploaded the SHSH as it said they were on file for my phone.

    I switched SIMS to give my phone to someone and restored in iTunes forcing it to upgrade to 3.1.3.

    I followed downgrade instructions, host file etc. and iTunes give me the version error. I tried to install 3.1.2, 3.1, 3.0.1. and 3.0. Same error.

    Downgrade iPhone 3GS OS 3.1.3 to 3.1.2 With Cydia SHSH | jailbreak


    I then downloaded firmware umbrella to see what SHSH Cydia has on file and it's 3.1.3. Maybe that's why it doesn't work? I don't see how that's possible, I was jailbroken when uploading SHSH. Any advice please?
    The Firmware Umbrella
    2010-03-25 08:30 AM
  2. dhamien's Avatar
    When did you ask Cydia to store the files? Cydia can only store the version that is currently being signed meaning you'd have to have clicked the button in Cydia before February the 3rd to have any files that will allow you to downgrade.
    2010-03-25 04:38 PM
  3. shane1900's Avatar
    I asked Cydia to store the file last night. If it's because I'm to late in doing that I guess that answers it.

    Thanks for your help!
    2010-03-25 05:49 PM
  4. Cer0's Avatar
    Yep, Cydia can only store the SHSH keys for the current firmware. So it will only have 3.1.3 on file for you if you did it last night.
    [CENTER][SIGPIC][/SIGPIC][/CENTER]
    2010-03-26 01:02 AM
LINK TO POST COPIED TO CLIPBOARD