1. dhamien's Avatar
    Ok i went to the mentioned folder as provided in the link you last listed
    (C:WindowsSystem32driversetchosts (Windows) )

    The "host" file cannot be opened and windows asks what program do i want to use to open it with? I have "umbrella" which enabled me to get my ECID, which looks like i dont need now by the tutorial in sauriks link, and "tinytss".

    Funny thing is, when i tried opening tinytss before it displayed the window but closed immediately? So now im not sure that i need the ECID or SHSH 3.1.2 file i recovered from my file on cydia, after reading the tutorial by saurik?

    If i am confused please explain.Basically where im stuck at now is, i can not still enter " gs.apple.com " in the "host" folder because windows is asking what i want to use to open "host" with? So im not exactly sure what i need to use in order to open it to place the " gs.apple.com" so that i can attempt the restore with itunes.

    Any idea?

    I actually just read that i am to open the "host" file with notepad and then insert the " gs.apple.com" at the bottom. How its suppose to be inserted and placed properly im not sure. There was no screen shot for an example to verify i have placed it correctly.

    I read the post someone titled

    "Downgrade Iphone 3gs Baseband 05.12.01 from 3.1.3 to 3.1.2 and jailbreak without SHSH"

    and JakkOne on the last page posted this info. Only problem is there isnt a screen shot for a newbie like me to reference to assure i have placed it correctly
    As mj just said, use notepad to edit the file. When doing it this way, you don't have to bother with Umbrella and TinyTSS. TinyTSS simply does locally, what Saurik does for you. You should just re-direct iTunes to Saurik's server. That's all.

    Don't bother too much with that thread you read, there's a lot of misinformation in that one. However, it's correct that you just need to insert that line. Again, a part of the file should look similar to what mj just posted.

    Here's what the last lines of my hosts file looks like: localhost gs.apple.com
    # gs.apple.com
    2010-04-03 01:44 PM
  2. mj0528's Avatar
    change your hosts file to this: localhost
    ::1 localhost gs.apple.com

    your last line is redirecting any requests of gs.apple.com to your local computer (
    2010-04-03 05:11 PM
  3. -dos-'s Avatar
    so once i input this into the "host" file i save the changes. Then go to itunes and hold shift+ left click on restore and select the 3.1.2 while phone is in DFU mode. Then it will restore to 3.1.2 leaving my firmware as 05.12.01!

    Then i should be able to jailbrake with purplera1n, and then can jailbrake with sn0wbreeze!

    Man thank you guys so much for all your time in helping me! i will try this as soon as i get home!
    2010-04-03 05:42 PM
  4. mj0528's Avatar
    just use blackra1n to JB it. Don't bother with sn0wbreeze! A lot of folks here talk badly about sn0wbreeze. Blackra1n is the easiest to JB with.
    2010-04-03 06:26 PM
  5. Count Tracula's Avatar
    for future reference, if you see the apple sad face again, simply hard reboot your device(hold power and home until it flashes, then power back on). that fixes the sad face almost 100% of the time.

    that being said, if you can get it back to 3.1.2, I would recommend installing custom firmware over blackra!n. I've read that it is slightly more stable.
    2010-04-03 06:39 PM
  6. mj0528's Avatar
    I agree, I had blackra1n at first and my wireless wouldn't work. The custom firmware from pwnage tool has been rock solid, but installing it is just a bit more involved than blackra1n. Blackra1n is leaps and bounds super easy to do. It's literally download, plug phone in and press "make it ra1n".
    2010-04-03 06:43 PM
  7. -dos-'s Avatar
    Well my phone was jailbroken with blackra1n originally. When i got the sad iphone i did as you stated. I did a hard reboot except i didnt get the
    reactions i read alot about other people were getting.

    Instead when i rebooted my phone it turned off, and turned back on , on its own! It would take forever for the apple symbol to display, then forever more for it to load my lockscreen.

    When the lockscreen finally appeared, the background was frozen but the apple load wheel would spin, stop.... spin, stop. There would be a 1-2 second split to where if i kept sliding my finger across the bottom sometime the arrow would make it over to the right.

    Then when it unlocked and was suppose to display the springboard, the display would go black then freeze and then re-display the lockscreen.

    This process continued for hours!!! I almost threw the phone against the wall lol! Glad i didnt!

    Since my phone was jailbroken and experiencing this, i thought i would try to jailbrake it with the new sn0wbreeze jailbrake to see if it would over ride the sad iphone once i attempted to restore the phone to the customized 3.1.3 upgrade...WRONG! LOL!

    After googling for 3 hours all i found were "ipod" solutions,and the final step was a
    full update to the most current apple software. Of course that fixed it and i had my phone
    functionable,but no longer on the 5.11.07 firmware

    So thankfully with everyones help i am going to try the "host" file editing and cross my fingers it works!

    I could care less about an unlock right now, i just want my jailbrake back

    Ok i input the commands as told and received the following message:

    "The iphone "iphone" could not be restored.An unknown error occured (1601).

    What now?

    So the next thing i just did was put my phone into recovery mode, and restored the 3.1.2 again.It completed but then gave me code "1015".

    I am attempting to get it out of recovery mode and cannot now?

    Did i miss something or need to do something?

    I do now have 3.1.2 on my phone except i have no service. My phone is currently syncing.Im hoping after sync it activates my phone?
    Last edited by -dos-; 2010-04-03 at 11:57 PM. Reason: Automerged Doublepost
    2010-04-03 11:57 PM
  8. dhamien's Avatar
    The 1015 error is expected behavior. I believe it's because the firmware is trying to install baseband 05.11.07 but isn't allowed because the baseband isn't downgradable at all. Saurik also talks about this in his writeup about SHSH.

    I'm guessing you got out of recovery mode by using blackra1n to boot? The problem with that is that it hactivates the phone. A hactivated phone must be unlocked, but you can't unlock yours as you have baseband 05.12.01

    I haven't read of a surefire way to boot up after a downgrade. Supposedly it's easy, but I don't know what people do or which tool they use. What I know will work for you is using a custom firmware. You just need to make sure it's unactivated to get service.

    By the way, 05.11.07 and 05.12.01 are baseband versions, while 3.0.x and 3.1.x are firmware versions, just to clear that up.
    2010-04-04 01:14 AM
  9. -dos-'s Avatar
    dhamien thanks for all your help!

    You are correct i did use blackra1n to get out of recovery mode becuase i could not get out.I attempted about 4 times and no luck.I guess im stuck on the new version til another jailbrake comes out or a new solution is brought up and confirmed.Using sn0wbreeze is out of the question,because in order to use it the phone has to have been previously jailbroken.

    Unless maybe i can do a restore and use the custom firmware of 3.1.3 ipsw i have which i made with sn0wbreeze. I havent herd of anyone doing a restore with the custom firmware but i guess i can give it a shot.

    If anyone knows of how i can jailbrake my 3gs without hacktivating it please let me know how and with what program!

    Thank you everyone so far that has helped me! I appreciate all of your efforts and repeated replies!
    2010-04-04 01:44 PM
  10. dhamien's Avatar
    You downgraded successfully, right? To 3.1.2 and booted with blackra1n? I know that you don't have service, but your phone is in fact jailbroken at that point meaning you can just load a custom firmware onto the phone from there.
    2010-04-04 02:05 PM
  11. -dos-'s Avatar
    Yes blackra1n did work. It was on the springboardn afterwards. When i saw i had no servie i then uninstalled blackra1n to see if service would re-appear. It did not so i re-restored my phone to the apple 3.1.3. I did build a custom firmware with sn0wbreeze when my phone had the "sad iphone". When creating it also, i did not select "hacktivate" because i have a att sim.

    So if i restore again today to 3.1.2, you say reboot with quickpwn 2.2 and it will not hacktivate my phone? Then i will have it jailbroken with service?

    Heres a question for you. What if i restore again today to 3.1.2 and reboot with blackra1n, obviously losing my service. Then restore again with the sn0wbreeze custom firmware 3.1.3 i made. Do you think it will over ride blackra1n and restore servie but with sn0wbreeze on ?

    If quickpen 2.2 is teh best option let me know, and what steps i should take. I have never used quickpwn 2.2. The only jailbake ive done was balckra1n because it was the most simple.
    2010-04-04 04:12 PM
  12. dhamien's Avatar
    I've never used quickpwn myself but I've seen a lot of references to it from users using it to boot after a downgrade without getting the phone hactivated.

    But to answer your question, if you restore to 3.1.2 and boot with blackra1n then yes, you can restore to a custom firmware and your phone will have service. The hactivation that blackra1n does will be overwritten by the restore, so as long as you've made an unactivated firmware, you will get service when inserting your ATT sim.
    2010-04-04 08:47 PM
  13. iYeow's Avatar
    Dos, I am not an expert, since you have an untethered jailbreak and you are on Stock 3.1.3, you can downgrade to a stock 3.1.2 if you have shsh on file with cydia. You will encounter 1015 error, use winpwn22 to get out of recovery mode and then use Redsn0w to jailbreak. Once you have done that you can restore to a custom 3.1.3 FW.

    Dos, Redsn0w doesn't work on 3GS, sorry giving you false info
    Last edited by iYeow; 2010-04-05 at 02:16 AM. Reason: Automerged Doublepost
    2010-04-05 02:16 AM
  14. j3st3r's Avatar

    redsn0w 0.9.2 works just fine on the 3gs
    2010-04-05 07:52 AM
  15. -dos-'s Avatar
    Which jailbrake would be best between redsnow 0.9.2, winpwn22, or

    I just want to use the best functioning one. Also include trusted links for them if possible please!
    2010-04-07 01:44 PM
  16. dhamien's Avatar
    I don't think quickpwn/winpwn works on a 3GS. Personally I wouldn't use sn0wbreeze as there have been problems with it in the past, but if you want to try it, it's an option.

    The most clean jailbreaks are usually the iphone dev team's tools. Their jailbreak tools include pwnagetool and redsn0w. You can always find official links to their tools on their blog: http://blog.iphone-dev.org/ - the links are on the left.
    2010-04-07 05:55 PM
  17. -dos-'s Avatar
    Hey dhamien one more thing!

    If i use redsnow to boot out of recovery will it hactivate my phone? Just wanted to know if i needed to use blackra1n first to jailbrake then redsnow. Another thing is, ive never used redsnow before.Does it make custom firmwares, that way i can get my service back after using it?
    2010-04-09 05:04 PM
  18. dhamien's Avatar
    I think redsn0w actually does hactivate the phone so I don't think it can be used to boot up the phone.

    You never have to use several jailbreak tools. Each one does the job. I'm not sure, but I think it can actually hurt the phone (software wise of course) if you run multiple tools. So stick with whichever one you choose, blackra1n or redsn0w or pwnagetool or sn0wbreeze.

    redsn0w and blackra1n don't make custom firmwares, they just change some files on the phone. pwnagetool and sn0wbreeze both make CFWs and you restore to those, wiping the phone completely leaving a fresh OS install, with Cydia/Rock on it.
    2010-04-09 06:06 PM
38 12
We have updated our Privacy Policy and Terms & Conditions. Please check them out.