1. samaral's Avatar
    Hi Everyone,

    I saw that most of the people here are using 3Gs, i'm currently using an Iphone 3G with 5.12, I am able to downgrade my firmware but not my baseband. So it means it isnt possible to downgrade baseband unless you're sitting on a 5.08 bootloader?
    2010-04-21 11:28 AM
  2. iYeow's Avatar
    That is correct..you can jailbreak but no unlock unless you have the option to use Fuzzyland.
    2010-04-22 06:06 AM
LINK TO POST COPIED TO CLIPBOARD