1. mickyd67's Avatar
    Hi all - first post, so please be kind

    I have an iPhone 3GS - it was on:

    firmware 3.1.2
    modem firmware 05.11.07


    However, this morning, the phone signal changed to "No Service" and the device basically locked up; I tried rebooting several times but the phone wouldn't start.

    I then plugged it into iTunes and did a restore. However this restore means my phone now has:

    firmware 3.1.3
    modem firmware 05.12.01


    This is an O2 PAYG mobile which is unlocked & jailbroken, which lets me use my T-Mobile contract sim.

    I have SHSH's on Cydia - so I have tried restoring back to my 'old' settings all day. I have been at this for several hours and I cannot get anything to work. I have downloaded the 'Umbrella' software and I can see my details on the Cydia repository and it saves a copy of that file onto my laptop as an .shsh file.

    Is it possible for me to get back to the settings I had previously?

    I am hoping I am doing something wrong and it's fixable - I've tried changing the 'hosts' file etc by adding the line of code to redirect iTunes etc.

    So far

    Anyone help please?

    Thanks
    2010-04-24 06:45 PM
  2. z3r01's Avatar
    You can go back to 3.1.2 but your baseband is gonna stay at 5.12.01 unfortunately...make sure that you are pointing iTunes to sauriks server
    2010-04-24 06:49 PM
  3. mickyd67's Avatar
    You can go back to 3.1.2 but your baseband is gonna stay at 5.12.01 unfortunately...make sure that you are pointing iTunes to sauriks server
    Thanks for the reply.

    I am trying to point to that server, but no matter what I do I cannot get it to work.

    Also - what is the downside of staying at this new baseband?
    2010-04-24 06:53 PM
  4. iYeow's Avatar
    Your iPhone has just turned into an Expensive Ipod Touch , no unlock solution at this baseband
    2010-04-24 08:01 PM
  5. mickyd67's Avatar
    I can get an unlock from O2 in the UK for 15

    Which I will do - the downside is that it'll take several days.

    I thought I'd be covered by having SHSH's on file with Cydia - is that not the case then?
    2010-04-24 08:08 PM
  6. dhamien's Avatar
    Open a command prompt and type in:

    ping gs.apple.com

    The response should come from the IP you typed into the hosts file. If it's not that IP, you haven't done it right.
    2010-04-24 08:24 PM
  7. iYeow's Avatar
    Wow, 15 to have official unlocked, be careful , not to be scamed . There are alot of scams out there. If a thousand people falls for it, they could make 15,000 ( a profitable scam)
    2010-04-24 09:04 PM
  8. mickyd67's Avatar
    Wow, 15 to have official unlocked, be careful , not to be scamed . There are alot of scams out there. If a thousand people falls for it, they could make 15,000 ( a profitable scam)
    It's from the first official UK carrier you get it:

    Unlock my iPhone - iPhone

    No risk.

    Open a command prompt and type in:

    ping gs.apple.com

    The response should come from the IP you typed into the hosts file. If it's not that IP, you haven't done it right.
    I have put that in and the ping appears to come back correctly.

    I am going back to square 1 here to try again.

    Cydia has the SHSH's on file for me for 3.1.2 - so I am ever hopeful this is my get-out.

    I've been at this now for 9 hours
    Last edited by mickyd67; 2010-04-24 at 09:44 PM. Reason: Automerged Doublepost
    2010-04-24 09:44 PM
  9. dhamien's Avatar
    It's from the first official UK carrier you get it:

    Unlock my iPhone - iPhone

    No risk.



    I have put that in and the ping appears to come back correctly.

    I am going back to square 1 here to try again.

    Cydia has the SHSH's on file for me for 3.1.2 - so I am ever hopeful this is my get-out.

    I've been at this now for 9 hours
    If you get a response from the IP you put into the hosts file (74.208.10.249), it's set up properly.

    I assume you've downloaded the 3.1.2 ipsw and have it on the desktop. Now just shift-restore in iTunes.

    What's not working for you? What errors are you getting?
    2010-04-24 10:55 PM
  10. mickyd67's Avatar
    If you get a response from the IP you put into the hosts file (74.208.10.249), it's set up properly.

    I assume you've downloaded the 3.1.2 ipsw and have it on the desktop. Now just shift-restore in iTunes.

    What's not working for you? What errors are you getting?
    I think this might be the issue - any time I download a copy of the 3.1.2 ipsw firmware it downloads as a WinRAR file, and I need to unzip it.

    However when I do that I cannot see any ipsw file within the unzipped folder.

    Any idea how to fix that - I cannot find a suitable download, every one I get seems to point to the same type of download (i.e. a zip / WinRAR file)

    This is
    2010-04-24 10:58 PM
  11. dhamien's Avatar
    Use Firefox to download it. It's supposed to be an ipsw file. IE changes it to zip. I actually think you can just change the extension from zip to ipsw.
    2010-04-24 10:59 PM
  12. mickyd67's Avatar
    Thanks dhamien, I'll give that a try - I appreciate your help here
    2010-04-24 11:04 PM
  13. sharp2G's Avatar
    QUESTION!

    does cydia automatically SHSH for you? is there a way you can find out? (im already on 3.1.3)
    2010-04-24 11:12 PM
  14. mickyd67's Avatar
    QUESTION!

    does cydia automatically SHSH for you? is there a way you can find out? (im already on 3.1.3)
    I think it does - if you go onto Cydia (presuming you still have it on your iPhone) at the top of the page it should say "SHSH's are on file for this iPhone, 3.1.2, 3.1.3" etc

    If you use that Umbrella software which is on here you can get a copy of the SHSH from Cydia.
    2010-04-24 11:21 PM
  15. dhamien's Avatar
    QUESTION!

    does cydia automatically SHSH for you? is there a way you can find out? (im already on 3.1.3)
    You need to have pressed the 'Make my life easier' button in Cydia. You can find out if it's there by using the Firmware Umbrella tool.
    2010-04-24 11:21 PM
  16. mickyd67's Avatar
    Tried 3 attempts to restore - keep almost getting there but it fails with a 1015 error each time

    Any ideas?

    I've given up for the day - I've spent my entire Saturday trying to sort this to no avail.

    If anyone can help overnight with some ideas that would be great - no doubt I'll continue this quest tomorrow.

    Thanks to everyone so far for their help.
    Last edited by mickyd67; 2010-04-25 at 12:50 AM. Reason: Automerged Doublepost
    2010-04-25 12:50 AM
  17. iYeow's Avatar
    Don't panic, error 1015 is normal, you are already jailbroken but just stucked ( you are in recovery loop ) Go download quickpwn 22.5 and run it, follow the message and you will get out of the loop ). Then you can use your preferred tools to jailbreak, ( Blackrain I guess ).
    2010-04-25 04:26 AM
  18. dhamien's Avatar
    Tried 3 attempts to restore - keep almost getting there but it fails with a 1015 error each time

    Any ideas?

    I've given up for the day - I've spent my entire Saturday trying to sort this to no avail.

    If anyone can help overnight with some ideas that would be great - no doubt I'll continue this quest tomorrow.

    Thanks to everyone so far for their help.
    I guess you didn't read Caching Apple's Signature Server - Jay Freeman (saurik) error 1015 is expected behavior. It's because the phone is trying to install the 05.11.07 baseband but fails because the baseband isn't downgradable. Don't worry though, if you run the restore twice, the firmware is actually fully downgraded.

    Now you just need the phone booted. Use quickpwn 2.2 for this. You could also use blackra1n to boot (in case you just wanted to see that it's actually downgraded), but it also hactivates your device leaving you without service. That's why you use quickpwn instead.
    2010-04-25 11:08 AM
  19. mickyd67's Avatar
    Thanks again D.

    I've tried that - but when I use that programme it starts to work then says the ispw file is invalid. I've DL'd a 3.1.2 ipsw file.

    Any ideas where I can download the correct ipsw file?

    Or any idea how to avoid that error message?

    Cheers

    OK - a bit of progress. (I can't believe a phone not working can make me feel so )

    Anyway...

    I am now on:

    Version: 3.1.2 (7D11)

    Modem Firmware: 05.12.01

    If I put an O2 Pay As You Go sim card into the phone I can get a signal and can dial - if I change that sim to my T-mobile one (which I need to use) I can't get a signal.

    I've tried to use pwnage 2.2 but I keep getting an error message when I use the ipsw file.

    So... what next? Will pwnage let me use my T-mobile sim if I can get it to work, or is that just to let me use jailbroken apps?

    Sorry if these questions seem simple - but there's an avalanche of information out there so from time to time it's easier just to start your own thread.

    Cheers.
    Last edited by mickyd67; 2010-04-25 at 04:14 PM. Reason: Automerged Doublepost
    2010-04-25 04:14 PM
  20. Amadomon's Avatar
    The crucial step you missed was pointing iTunes to Saurik's server BEFORE restoring through iTunes. Now it's too late to unlock. Welcome to Club 5.12.01!
    2010-04-25 04:27 PM
23 12
LINK TO POST COPIED TO CLIPBOARD