1. Dough Boy's Avatar
    I got a 3GS with 4.0 on it. It's never been jb'd at all. I bought it off a girl who had it legit and she just upgraded to the 4 and sold me this one. Here are some specs.


    serial ***25
    modem fw: 05.13.04
    model MB718LL
    version 4.0 (8A293)

    I'm trying to jb and unlock to use on T-Mobile.

    From what I have read I need to downgrade to 3.1.2 or 3.1.3? Will I run into any problems when I do it on iTunes and which one should I download to?

    Thanks for any help, I've been a long time lurker and have always found great info on this site.
    2010-06-26 08:47 AM
  2. j3st3r's Avatar
    since it has never been jailbroken then you are stuck on 4.0, no way around it, sorry
    2010-06-26 12:22 PM
  3. Dough Boy's Avatar
    Til a jb for 4.0 correct?
    2010-06-26 04:21 PM
  4. StealthBravo's Avatar
    Til redsnow is released
    2010-06-26 04:26 PM
  5. Dough Boy's Avatar
    So there is no way to unlock it either just so I can use tmobile on it correct?
    2010-06-26 05:58 PM
  6. jbou91's Avatar
    So there is no way to unlock it either just so I can use tmobile on it correct?
    For the time being we cannot use it for t-mobile. The dev team should come out with a fix pretty soon
    2010-06-26 06:04 PM
  7. Dough Boy's Avatar
    For the time being we cannot use it for t-mobile. The dev team should come out with a fix pretty soon
    I shall patiently wait then
    2010-06-26 09:42 PM
  8. jbou91's Avatar
    I've been waiting impatiently as I really want it. I bought it from a friend who used it for a few months and now I just stare at it
    2010-06-26 10:41 PM
LINK TO POST COPIED TO CLIPBOARD