1. sam2k01's Avatar
    hi i have a new bootrom 3gs, and was wondering if I could save the 4.0 SHSH blobs while still on 3.1.3. I dont want to go through the lengths of upgrading and downgrading back again to be jailbroken!

    Thanks in advance!
    2010-07-13 12:41 AM
  2. Captinsmooth's Avatar
    Your question doesn't make much sense? If your on 3.1.2 right now then you want to save your shsh blobs from that firmware. You have no need for your 4.0 shsh blobs as of right now. Once you have your 3.1.2 shsh blobs saved then you would want to use 3.1.2 blobs to help you create a custom IPSW for 4.0 to upgrade and jailbreak at the same time.

    http://modmyi.com/guides/?p=3299
    Last edited by Captinsmooth; 2010-07-13 at 12:51 AM.
    This post infers no rights and is provided as is.

    Click here to follow me on twitter
    2010-07-13 12:47 AM
  3. silkshocker's Avatar
    you have to be on IOS4 in order to save it. So the answer is no.
    2010-07-13 04:34 AM
  4. Simtech's Avatar
    No, you can be on any firmware version. The only thing is you can only save the firmware that Apple is signing (4.0)
    The Firmware Umbrella: TinyUmbrella - 4.00.54

    I was on 3.0 for a long time and saved 3.0, 3.1, 3.1.2 and 3.1.3 while still on 3.0
    2010-07-13 05:06 AM
  5. douflag's Avatar
    I can see why saving iOS 4.0.0 SHSHs are important. The thing is if the OP didn't save 3.1.3 or 4.0.0 SHSHs, then the OP is pretty much screwed if accidentally upgraded to 4.0.1. That's assuming there are software issues with JB or unlock or whatever (i.e. 4.0.1 sucks).

    The fact is that you can't save the 3.1.3 SHSHs anymore, and if 4.0.1 comes out, you won't be able to do that for 4.0.0 either. Therefore, the possibility of downgrading is impossible!
    2010-07-13 09:37 PM
  6. jkmonkey's Avatar
    There is a point to saving shsh blobs even if you are not currently jailbroken, and even if you never plan on jailbreaking at all. The fact of the matter is that Apple can add or remove features as they see fit with future firmwares. By saving shsh files it gives you the option to use older firmwares as you choose. Saving blobs gives you a choice that Apple says you can't have.
    2010-07-14 12:02 AM
  7. sam2k01's Avatar
    sorry if i didnt word the question properly guys, I think simtech knows what i mean. I am currently on 3.1.3-jailbroken, I have that SHSH saved. I dont want to upgrade to 4.0 until I can jailbreak it, so I wondering if I could save my 4.0 SHSH whilst still being on 3.1.3 so I can safeguard the jailbreak that is soon to be released by comex and the rest of the dev team? Or do I have to upgrade to 4.0, save SHSH and then go back down to 3.1.3?

    Thanks for your replys though!
    2010-07-15 12:48 AM
  8. Simtech's Avatar
    I answered you question above and gave you a link.... yes.
    2010-07-15 12:50 AM
  9. jkmonkey's Avatar
    Tiny umbrella will save the shsh's for the current firmware no matter what you have installed at the time.
    2010-07-15 04:59 AM
  10. dmbrown81's Avatar
    I just want to make sure I'm good so i'm asking...I ran TinyUmbrella and clicked where it says, "display shshs" and it confirmed that I had a 3gs 3.13 and a 3gs 4.0. So I'm good on the saved 4.0 Blob then because I'm still on 3.1.3?
    "There's A Party In My Tummy"
    2010-07-15 04:26 PM
  11. LrdBane's Avatar
    Yes as long as you change it to Apple under advanced, check to make sure your model is the correct one and that you pick software 4.0. What it will do is ask apple for the 4.0 and apple should send it to you. Its like if it was requesting it through iTunes. Apple sends it back and the program takes it and says "Thank you" Then you can check which ones you have backed up. Untill apple signs a different one you can still do it. Some people are still able to save a 4.0 as of today with the "small" 4.01 update that came out
    2010-07-15 11:16 PM
LINK TO POST COPIED TO CLIPBOARD