1. mpaynejr's Avatar
    Long story short, my phone went belly up yesterday running on 4.0(3GS, jailbroken and unlocked). After a simple unlock, I was left with no standard apps (mail, safari, app store etc) and no cydia apps. All I had remaining was app store apps.

    I tried running Safe mode, deleting potentially offensive apps...no dice.

    After continously putting the phone into DFU mode and attempting to restore to 4.0 (I have SHSH on file) I gave up and restored to 4.0.2 as I needed e-mail today. Even restoring to 4.0.2 was a hassle as i had to delete itunes and mobile app support and eventually it went through.

    Now I'm stuck on 4.0.2 and am trying to restore to 4.0. I've edited the hosts file, put the phone in DFU, and have tried to restore to the correct 3GS 4.0 firmware found here on MMI.

    I'm met with 1601 errors each time. I've tried multiple fresh uninstalls, switched USB ports and anything else you can imagine. Can I not do this downgrade even if I have the SHSH files saved out? Thanks in advance....I literally feel like Apple dropped this timebomb on me with timing this like an hour before 4.0.2 was released....
    2010-08-13 02:25 AM
  2. iYeow's Avatar
    Why don't you try downgrading to 4.0.1 without editing the hosts file and putting your iphone in DFU mode.
    If you can't , then edit the hosts file to point to Cydia, put your Iphone in DFU mode and shift + restore to 4.0.1.
    You should have 4.0.1 shsh saved with Cydia since you were jailbroken at 4.0
    2010-08-13 04:21 AM
  3. artbatista's Avatar
    Follow the instructions here:

    http://modmyi.com/forums/3g-s-downgr...ml#post5397116

    As a side note, if you restore and get a 1xxx error at the end,the restore is probably good and all you usually need to do is get the phone out of recovery mode. Umbrella has a button for that or you can use RECBOOT.

    Cheers

    Art
    2010-08-14 01:16 AM
  4. Poseidon79's Avatar
    Errors in the 1600's usually mean you're not in DFU.
    2010-08-14 01:23 AM
LINK TO POST COPIED TO CLIPBOARD