1. silverranger's Avatar
    Hello Modders,

    please help me finding a fix for error 1002, I was previously on 3.1.2 Blackrained vth no wi-fi nothing seem to work on tht even I was not allowed to downgrade or even update 3.1.3 coz of Apple not signing.. I finally decided to move on stock iOS 4.0.2 and stuck at last n reponds me to 1002 error.. I used recboot to get out of recovery but iPhone doesnt detect my Sim to activate.. more over after a few while iPhone says Restore needed n repeats... plz Help me out
    2010-08-16 08:49 PM
  2. iYeow's Avatar
    Why are you restoring to 4.0.2, there is no jailbreak at 4.0.2 for 3GS and Iphone 4. Hopefully , Apple is still signing 4.0.1, go donwload the 4.0.1 ipsw from iClarified - Apple News and Tutorials, put your iphone into DFU mode and do the Shift + Restore to the 4.0.1 ipsw. You will encounter error 1015, use recboot/tiny umbrella to boot it up from recovery mode. Put your official sim to activate and then use jailbreakme.com ( I think the jailbreakme.com wehsite is still down ).
    Use tiny umbrella version 4.01.08 to backup your 4.0.1 shsh blogs if you have not done so.
    2010-08-16 11:08 PM
  3. silverranger's Avatar
    Thanq for responding Buddy... I Restored to iOS 4.0 vch any how seemed to Inject into it but same result restoring stops at the end and itunes give me 1002 error I will any how try ur thing pushing iOS 4.0.1 into it... and get bak to u but Ill b Grateful if some 1 can find fix for Error 1002
    2010-08-17 08:30 PM
  4. iYeow's Avatar
    You could be having a hardware issue, try changing your usb cable if you have another one, do the restore on a different machine. What was your problem on your iphone before you decided to restore?
    2010-08-18 03:08 AM
  5. silverranger's Avatar
    Hey yeow202.. wat Kinda Hardware buddy.. now im Tensed.. I tried 2 diff sys to restore 1 vth Win XP n other Win 7 but same thing. I even Tried as u said moving on to iOS 4.0.1 but same thing restoring freezes at the end on iPhone n after few moments itunes give up saying 1002 Error...

    Welll before restoring Iphone was on 3.1.2 blackrained vth no wi-fi no Bluetooth... coz it didnt hav ne SHSH it didnt accept to go on any firmware 3.1.3 or 3.1.2 n it used to boot tethered... I used Pwnage Windows tool to boot up.. last time(usually) Pwanage asked weather its an MC model usually yes was the answer n I tether it to boot for that instance i clicked no it started Jailbreaking n all (I thought it wud boot up vth Wi-Fi atleast) but it didnt it was rather in recovery mode but nothing showed on screen... iTunes detected it.. so thought of movin on Stock iOS 4.0.2 n since then "1002" plz plz help me finding its fix....
    2010-08-18 08:39 AM
  6. iYeow's Avatar
    It is quite possible that you have a Hardware problem, your wifi and bluetooth were not working and if it was the hardware issue, restoring will not solve the problem and that is why it throws out error 1002. I may be wrong but that is what i think.
    2010-08-19 09:27 AM
LINK TO POST COPIED TO CLIPBOARD