1. trellaine's Avatar
    I enter DFU mode, select a firmware, then I keep getting an error that its not compatible?

    I want to go from 4.0.1 back to 3.1.3, anything to get my phone to work properly.

    Apple and their firmware's suck.

    Thanks
    2010-08-18 06:48 AM
  2. jkmonkey's Avatar
    The message the the firmware is not "compatible with your device" means that you have the wrong type of firmware ex:trying to install 3gs fw on a 3g. Try redownloding the fw you want to install and ensure you get the correct one for your device.
    2010-08-18 03:48 PM
LINK TO POST COPIED TO CLIPBOARD