1. bl4334's Avatar
    Hey guys,

    I've pretty much admitted defeat alerady, but I thought i'd ask and see if anyone knows something more I havn't found.

    The story is, I accidently updated to 4.0.2, i thought i'd clicked on the 4.0.1 IPSW but apparently not, so now i have a 3GS on 4.0.2.

    I've tried everything to downgrade, and to no success. I've tried tiny umbrella, changing the host file etc.

    I get an error in iTunes when shift restoring that is 3194, which happens just after it says "verifying with restore with itunes" or something like that.

    Is there anything else I can try to fix this issue and downgrade so i can jailbreak and unlock my phone?

    The main thing i need is to unlock it as i'm in a different country and need this country's SIM to work.

    Thanks in advance (:
    2010-08-25 08:14 PM
  2. iYeow's Avatar
    If you are getting error 3194 means that you don't have the required shsh blogs to downgrade.
    2010-08-25 08:35 PM
  3. bl4334's Avatar
    Which is strange because I was so sure I pressed the 'make my life easier' option in Cydia when i was running 3.1...

    Well if i dont have the blogs, is there anything else I can do to downgrade??

    is there anything i can do to unlock it? (99% sure there isn't lol)
    2010-08-25 08:44 PM
  4. Simtech's Avatar
    Try Umbrella to see if your SHSH files are stored.
    2010-08-25 08:48 PM
  5. bl4334's Avatar
    Yeah i tried Umbrella but not a thing it also won't even start the TSS server sooo yeah. Is there anything at all I can do?
    2010-08-25 08:54 PM
  6. ocojaa's Avatar
    If you think you have your blobs saved, I would try Umbrella on a different computer. I know Ive had issues before where my Windows 7 machine would throw 3194 errors but then my WinXP would work flawlessly.
    Last edited by ocojaa; 2010-08-25 at 09:40 PM.
    2010-08-25 09:34 PM
  7. iYeow's Avatar
    Which is strange because I was so sure I pressed the 'make my life easier' option in Cydia when i was running 3.1...

    Well if i dont have the blogs, is there anything else I can do to downgrade??

    is there anything i can do to unlock it? (99% sure there isn't lol)
    Try this out, you have nothing to lose.
    Download the latest tiny umbrellla.
    Grab the 4.0.2 shsh file from Apple
    Click Display shsh to see if it is there.
    It will be stored in : Desktop > Your computer name > .shsh
    This folder is hidden, go to control panel > folder option and uncheck the protect windows file.
    Rename the 4.0.2 shsh blogs to 4.0.1 shsh blogs
    Start your tiny server, make sure you highlight the 4.0.1 shsh blogs
    You can also edit the hosts file to point to Cydia by adding
    this : 74.208.105.171 gs.apple.com under the local host, save it.
    Put your Iphone into DFU mode
    Do the shift + restore to 4.0.1 ipsw
    Get back to us if this works.
    Last edited by iYeow; 2010-08-26 at 05:44 AM.
    2010-08-26 05:40 AM
  8. bl4334's Avatar
    Okay so I have done the above except, the option to start the TSS Server is blanked out even after I've saved my current SHSH blogs and all that. My device is showing up in Tiny Umbrella and everything is fine except for the TSS Server.

    Any ideas to get the TSS Server running properly???
    2010-08-26 05:16 PM
  9. ricardoacev's Avatar
    Try this out, you have nothing to lose.
    Download the latest tiny umbrellla.
    Grab the 4.0.2 shsh file from Apple
    Click Display shsh to see if it is there.
    It will be stored in : Desktop > Your computer name > .shsh
    This folder is hidden, go to control panel > folder option and uncheck the protect windows file.
    Rename the 4.0.2 shsh blogs to 4.0.1 shsh blogs
    Start your tiny server, make sure you highlight the 4.0.1 shsh blogs
    You can also edit the hosts file to point to Cydia by adding
    this : 74.208.105.171 gs.apple.com under the local host, save it.
    Put your Iphone into DFU mode
    Do the shift + restore to 4.0.1 ipsw
    Get back to us if this works.
    hey I followed all the steps, and in the verification process i got an error 3002, can you help me with extra steps to fix this error?
    2010-08-26 07:02 PM
  10. iYeow's Avatar
    Okay so I have done the above except, the option to start the TSS Server is blanked out even after I've saved my current SHSH blogs and all that. My device is showing up in Tiny Umbrella and everything is fine except for the TSS Server.

    Any ideas to get the TSS Server running properly???
    I think you have a firewall or is being used by another program that is blocking your port 80.

    hey I followed all the steps, and in the verification process i got an error 3002, can you help me with extra steps to fix this error?
    I was comparing my 4.0.1 and 4.0.2 shsh blogs, they look the same, since you are getting error 3002, I guess I was wrong, they do have a slight difference then...Cheers ...
    Last edited by iYeow; 2010-08-26 at 09:27 PM. Reason: Automerged Doublepost
    2010-08-26 09:15 PM
  11. ricardoacev's Avatar
    hi Thanks for your reply, so is there any other way to downgrade my firmware? or i just have to wait until the next Jailbreake?
    2010-08-26 09:19 PM
  12. iYeow's Avatar
    hi Thanks for your reply, so is there any other way to downgrade my firmware? or i just have to wait until the next Jailbreake?
    Do you have any shsh blogs at all ? If you don't have then you can now save your 4.0.2 shsh blogs onto your pc.
    Have you tried this thread, most of them have been claiming success which i don't believe without the proper shsh blogs :

    http://modmyi.com/forums/3g-s-downgr...-no-shshs.html
    Last edited by iYeow; 2010-08-26 at 09:33 PM.
    2010-08-26 09:30 PM
  13. bl4334's Avatar
    My firewall is turned off and i disabled my antivirus but it's still blanked out :S any suggestions?
    2010-08-26 09:36 PM
  14. ricardoacev's Avatar
    Yesterfay I saved my shsh using tinyUmbrella this was the first time I did that. So the only blog I have is for my current version. But I don't know if I can restore to the previous firmware just with the blog I have. Anyway I will try the other threath
    2010-08-26 09:37 PM
  15. iYeow's Avatar
    Yesterfay I saved my shsh using tinyUmbrella this was the first time I did that. So the only blog I have is for my current version. But I don't know if I can restore to the previous firmware just with the blog I have. Anyway I will try the other threath
    Let me know how it goes on the other thread, Goodluck.

    My firewall is turned off and i disabled my antivirus but it's still blanked out :S any suggestions?
    So you have Vista/32, mine is Win7/32, can't really figure out why you can't start your tiny server. Did you donnload the latest tiny umbrella 4.02.04?
    Last edited by iYeow; 2010-08-26 at 09:58 PM. Reason: Automerged Doublepost
    2010-08-26 09:58 PM
  16. azraeil's Avatar
    I'm not sure if this will help but try this (if possible try on an XP Machine)

    If you remember saving the blobs on 3.1, then I'm sure Cydia will have your blobs. This has worked for me Everytime (I have had to downgrade 4 iPhone 3Gs)

    1.Download the latest TinyUmbrella (or the version 4.0.54 should be okay as well) Google for it or better yet, go to the TinyUmbrella blog (google for it)
    2. Download also TinyUmbrella version 222 (yes, it's an old version). It should be in the TinyUmbrella blogs as well. If you cannot find the old version from the blogs, googled for it.
    3. You will need both version of TinyUmbrella
    4. Once you have downloaded both of them, run the latest version (or 4.00.54) and click on the advance tab, get your ECID for this version. Write it down and copy it somewhere. Cydia will have stored the same ECID in its system.
    5. Exit that version and now run TinyUmbrella 222 (the old version). Key in the ECID that you wrote down. DO NOT MESS with the host file at this time. Point the software to Cydia-Saudrik repository. Make sure also you select the SHSHs blob version that you believed Cydia saved for you (i.e. 3.1.2, 3.1.3 etc etc.)
    6. IF your SHSHs were saved by Cydia, it will download the SHSH blobs to your local machine (most likely in the same directory as where you ran TinyUmbrella 222, otherwise search your computer for file with the *.shsh extension.)

    You now have your ECID in your local machine and you should rejoice since now you can downgrade your Firmware using the local host anytime you want.

    To downgrade using a local host, follow the steps below

    1. Edit your host file (in XP, it should be in c:/windows/system32/drivers/etc/hosts)

    2. Add at the bottom of the line 127.0.0.1 gs.appple.com

    3. Saved the hosts file

    4. Now run the latest version of TinyUmbrella and DRAG the SHSHs file that was saved on your local machine into the application window. It will give you some messages saying that a certain version of the firmware is accepted etc etc

    5. Click on Start TSS Server. (It will then say that it's waiting for request or something of that sort)

    6. Run iTunes. Put your iPhone in DFU mode and press Shift+Restore and select the 3.1.2/3.1/3.1.3 etc etc firmware (ohh you need to download the OFFICIAL 3.1.2/x firmware, look either in iClarified or Modmyi for the firmware)

    7. This should work. If you have upgraded to 4.0.2, the iPhone's baseband probably would have been upgraded and you will get the 1015 error. This is normal, do not worry.

    8. You need to use Quickpwan to kick the iPhone out of the 1015 error (search this forum on 1015 error and you will find the solution)

    9. You will have successfully downgraded to 3.1.2/x

    10. Use Blacrain to jailbreak/hacktivate the iPhone

    11. Use Pwnagetool 4.0.1 to create a custom firmware of the 4.0 firmware (this is another guide altogether, but it's not that difficult to follow. Just follow the tutorial from iClarified)

    It's a bit long but I hope it helps. The key thing is getting the SHSH blobs from Cydia so that you can save it locally. As I mentioned before, I have done these type of downgrades several times and this method works everytime.
    2010-08-26 09:58 PM
  17. bl4334's Avatar
    So i tried what you said but didn't work it says that it doesn't have the 3.1 blobs so I guess I must not of saved them. But something strange is happening, in the current version of Tiny Umbrella it says that it has blobs for my 3gs on version 4.0, which I never updated to? :s but when I try shift + restore to 4.0 it comes up with that pesky 3194 error.

    Another thing is I still can't get the TSS Server option in the current version of Umbrella to run properly even with firewall and all virus protection off.

    Thanks for trying to help though guys I appreciate it heaps! lets hope we can crack this aye
    2010-08-27 01:53 PM
LINK TO POST COPIED TO CLIPBOARD