User Tag List

  1. im2nice's Avatar
    Hey guys, gf recently bought a 3gs and wanted my help to unlock it. So I built a custom 4.1 IPSW via Pwnagetool with the ipad BB. Anyways got around to putting it in DFU mode and started the restore. I guess apple stopped signing 4.1 IPSW because the verifing software failed and cant seem to kick it out of recovery? Any help would be great.. Thanks!!
    2010-12-06 05:04 AM
  2. iYeow's Avatar
    Try pointing your hosts file towards Cydia and restore to stock 4.1. If you still fail with error 3194, then you have to restore to custom fw of 4.2.1. Use redsn0w to tether boot if it ends up in recovery at 4.2.1
    2010-12-06 07:12 PM
  3. im2nice's Avatar
    Can you elaborate on the "pointing your hosts file towards Cydia and restore to stock 4.1" I already tried restoring to a stock 4.1 but no dice, same verification error. I was thinking about doing the custom 4.2.1 with redsn0w but isn't that a tethered jailbreak? Im not sure what tethered really is, can you shed some light like what are its disadvantages?. Thanks for the reply!!
    2010-12-07 05:26 AM
  4. iYeow's Avatar
    Easier way, use tiny umbrella , plug your bootable iphone in and click save shsh.
    If you have 4.1 shsh blobs , then you can restore to stock 4.1 or cfw of 4.1.
    2010-12-07 05:59 AM
  5. im2nice's Avatar
    Thats the thing, when I plug in the iphone, only itunes recognizes it in DFU mode. Tiny Umbrella doesnt. So I have no way to check if the SHSH was ever saved.
    2010-12-07 06:02 AM
  6. iYeow's Avatar
    Yes, you can : Do this :
    Click Start > Highlight Computer > right click > Properties > Device manager > USB universal Controller > Apple Device > Right Click > Properties > Details > Device Instance Path > slider your bottom slider to the right > Write down your 16 digits ECID number and input into Tiny umbrella to retrieve all your shsh blobs.
    You have to click save shsh.
    2010-12-07 06:08 AM
  7. im2nice's Avatar
    I'm using a mac. Dont have access to a PC at the moment
    2010-12-07 06:10 AM
  8. iYeow's Avatar
    Isn't Tiny umbrella works for Mac. I only know PC, there must be a way to find out your ECID and is always the same. If your iphone is bootable, TU will recognize it right away.

    Can you not do a hard reset to get it out.

    Hold both the buttons until it reboots.
    Last edited by iYeow; 2010-12-07 at 06:17 AM. Reason: Automerged Doublepost
    2010-12-07 06:17 AM
  9. im2nice's Avatar
    I found a way to find out so I will try it now but thats what really is confusing me, how itunes recognizes it but TU cannot. Pwnagetool does too.
    2010-12-07 06:20 AM
  10. iYeow's Avatar
    Itunes will recognize when you iphone is in DFU or Recovery mode.
    TU will only reccgnize if your iphone is bootable. If it is in recovery mode or loop, it will kick it out for fw under 4.2.1.
    If you manually trigger it into DFu mode, you can restart by doing the Hard Reset.
    2010-12-07 06:24 AM
  11. im2nice's Avatar
    yea I manually triggered it. A hard reset is just holding the power and home button correct until it comes back on?
    2010-12-07 06:27 AM
  12. iYeow's Avatar
    2010-12-07 06:29 AM
  13. im2nice's Avatar
    ok successfully got out of DFU mode. Here is my plan, save SHSH of the 4.1 then run restore to custom 4.1 IPSW, would this be possible?
    2010-12-07 06:44 AM
  14. iYeow's Avatar
    Yes, it is possible. The trick is you use Redsn0w to put you into DFU mode , do not manually trigger it or it will not accept custom firmware.
    You can even restore to stock 4.1 .
    When you open up timy umbrella with your booted iphone, click save shsh .
    You can use tss server to help you restore or you can just exit tu because when you exit TU, by default it set your hosts file to Cydia allowing you to verify with Cydia not apple.
    2010-12-07 07:03 AM
  15. im2nice's Avatar
    I am running 4.1 when I tried to save the SHSH it says only 4.2.1 is available and the 4.1 SHSH is too late to save. So am SOL? I also had another question, that has nothing to do with the iphone Ive been dealing with. Is it possible to downgrade the baseband of an Iphone that has been upgraded to the Ipad bb, with the SHSH saved since 3.1.3 til now.
    2010-12-07 07:12 AM
  16. iYeow's Avatar
    No, your ipad baseband will be there forever. Iphone 3g or 3gs has baseband of 05.14...0.15 and 05.16. and is not going to go above 06.15 which is for ipad. However, you could in the near future, you could update your bb to 6.16. or 6.17.
    BB has nothing to do with shsh blobs. Shsh blobs is used in conjunction with your fw to be verified for restore.
    2010-12-07 07:21 AM
  17. shitake83's Avatar
    iYeow is right. youre not going to be able to downgrade your baseband again, but anyway the 4.2.1 now works for you. why go back ??
    2010-12-08 01:15 PM
  18. im2nice's Avatar
    The iphone is actually still running on 4.1. Is it still possible to jailbreak and unlock it with this OS? I really dont want my gf's iphone to be tethered. I took a couple of screenshots of the tinyumbrella, I cant seem to save SHSH for 4.1 even tho its still running it. So Basically is there a way for me to keep OS4.1 or do I have to do the tethered 4.2.1??
    Here is some screen shots.

    2010-12-08 07:23 PM
  19. gurdok's Avatar
    i have the exact same problem... exept that i couldn get it out of DFU... it has black screen or gray screen (with redsn0w i get that... it has an "unexpected error"
    2010-12-11 01:00 AM
  20. iYeow's Avatar
    From the thumbnail, I don't see any 4.1 shsh blobs and the only one you have is the 4.2.1b3 and 4.2.1. There is no way you can go to 4.1 if you don't have it.
    Last edited by iYeow; 2010-12-11 at 02:27 AM.
    2010-12-11 01:19 AM
25 12