1. Qopzeep's Avatar
    Hi guys,

    Since this morning my iPhone is stuck in recovery mode, unable to boot and unable to restore.

    I've had trouble syncing my iPhone for quite a while (since june last year). Every time I synced, it would halt somewhere half-way with an error, leaving me with a corrupt iPhone. Every time I had to do a restore and after that I could sync for a while, but after about 2-3 weeks the same thing would happen. The curious thing is that it moved all my songs and movies to my iPhone, but I couldn't read them. It just said "No content", while at the same time iTunes told me approximately 10GB of space was used for songs and movies. All other features (including jailbreak) were left untouched. I don't sync my apps.

    Until today, a restore always fixed this problem.

    I've traced the above issue to either
    1) A faulty cable (most likely) - I ditched the cable, started using another one.
    2) Not enough power to the USB port - I only use back ports now.
    3) Not enough space on the iPhone (?) - I had a lot of movies checked, and halfway through syncing my iPhone prompted me with a message that I should free up some space. This crashed iTunes and voila, a corrupt music library.
    4) Not having the 64bit version installed even though I have a 64bit machine.

    Device & OS
    My device is an iPhone 3GS 16GB new bootrom, and was jailbroken with limera1n. Where I live the whole baseband stuff is not relevant.

    My SHSH blobs have been backed up since iOS 4.0.

    OS: Windows Vista SP2 64bit
    Anti-virus: Kaspersky Anti-virus
    Firewall: ZoneAlarm

    So a couple of days ago, I wanted to sync my iPhone and itunes gave me an error half-way. Normally I would restore, but the situation is different now. If I try to restore, I have to update to 4.2.1. Since this version isn't jailbrakeable (untethered at least), I decided to use TinyUmbrella and the 4.1 ispw from Apple to restore to.

    The error I'm getting is:
    "The iPhone "iPhone" could not be restored. An unknown error occurred (6)."

    These are the steps I follow.
    1. I plug in device. I close iTunes when it recognizes it.
    2. I run TinyUmbrella. I click "Start TSS Server".
    3. I run iTunes.
    4. When it recognizes the iPhone it says "iTunes must check the iPhone software update server to identify this device." I click 'check'.
    5. iTunes tells me "iTunes has detected an iPhone in recovery mode. You must restore this iPhone before it can be used with iTunes." I press OK.
    6. I hold shift + click on restore, browse to 'iPhone2,1_4.1_8B117_Restore.ipsw", downloaded from Apple. iTunes asks me to confirm, I click OK.
    7. iTunes performs the following steps:
    - extracting software
    - waiting for iphone
    - preparing iphone software for restore
    - restoring iphone software (load bar)
    - verifying iphone software (load bar)
    - verifying iphone restore (the stripy bar that 'goes on forever') --> error!

    When it's verifying, the load bar on my iPhone is on approximately 2/3, then I see the Apple loading animation for a fraction of a second, then iTunes gives me the error and the iPhone goes into recovery mode.

    Things I've tried
    - Checked port 80, only TinyUmbrella is using it.
    - Used 3 different cables. Normally this would solve error (6), but not today.
    - Tried different USB ports (front & back).
    - Tried DFU mode & Jailbroken DFU mode.
    - TinyUmbrella can't kick it out of recovery, it just loops. Same for iReb.
    - Apple software update, Bonjour, iPodService Module (64-bit), iTunes, iTunesHelper are all configured in ZoneAlarm to have access to the internet. TinyUmbrella has access and is a trusted server as well.
    - I looked in my registry, I don't have the TCPMaxPacketSize (or whatever it's called) in there.
    - I've 'completely' reinstalled iTunes as per Apple's instructions in one of their KB's. I say 'completely' because the KB doesn't make you delete your libraries & backups, so AFAIC that's far from complete.
    - Installed the 64bit version of iTunes.

    This is a desperate plea. I am at my wit's end, even considering giving up my possibility to jailbreak and just update and do a normal update & restore (no, really). I'm really hoping I just have tunnel vision here and that you guys spot the obvious thing I'm doing wrong :P

    Thanks in advance!

    Ps - I just realised while typing this that maybe I could update and restore, then downgrade to 4.1 and restore. Is this possible?
    Ps 2 - I suppose I should try another PC, but my laptop runs Linux and there is no other laptop/PC around.
    Last edited by Qopzeep; 2011-02-07 at 02:35 AM. Reason: The problem is solved :]
    2011-01-28 03:53 AM
  2. katok's Avatar
    i have the same prob and tried everything too =( PLS HELP US
    2011-01-28 09:50 AM
  3. iYeow's Avatar
    If you have wifi sync installed on your computer, remove by uninstalling wifi sync , you should be able to restore successfully.
    2011-01-28 04:27 PM
  4. Qopzeep's Avatar
    Thanks for your reply. I don't have wifi sync installed on my computer (we're talking about the JB app, right?), so that isn't the problem. =/
    2011-01-28 07:51 PM
  5. Qopzeep's Avatar
    I've solved it :D!

    Before I start: these are all the steps I followed from broken iPhone to working iPhone, which I post to be complete. To solve the syncing problem, please check step 7 first. Also, please just read this guide through once before you crack on with the steps, because you may be able to skip some!

    Here's how I did it.

    1. First I took my phone to another computer (used my brother's laptop). He reset it for me, and downgraded it at the same time. Ask a friend if you can borrow his laptop for 20 minutes and fix it through his or her machine. Alternatively, let the staff at an iCentre reset it for you, and you can downgrade later.

    2. Then I backed up my iTunes library to an external hdd. I also copied my iPhone backups to that hdd. On Vista (and I think Windows 7 as well), these can be found at:
    C:\Users\[username]\Appdata\Roaming\Apple Computer\MobileSync\Backup
    • Replace [username] with your username.
    • The Appdata folder is hidden, to show it go to Organize -> Folder and search options -> View -> Click the radio button "Show hidden files and folders".
    • Back up all the folders in the "Backup" folder.
    • On Windows XP, the backup folder can be found at C:\Documents and Settings\USERNAME\Application Data\Apple Computer\MobileSync\Backup

    3. Then I proceeded to completely deinstall iTunes, iTuneshelper, Quicktime, Bonjour, Mobilesync and all the other riff-raff that Apple installed on my computer following this guide: Completely Remove iTunes and Other Apple Software from a Windows Computer - How-To Geek.
    • At the "Manually Search for and Remove More Leftovers" step, be careful not to delete the backups you made in step 2!
    • At this step I also used the search terms 'iphone' and 'QT'. Also, when you search for ‘apple’ you get a lot of returns containing the word ‘applet’ which have nothing to do with your search. If you click ’search’ in the menu, then click ‘match whole word’ you’ll circumvent this.
    • At the "Clean registry" step I used CCleaner's cleaner to clean my computer, instead of Window's built in cleaner. CCleaner is better. Don't skip the %temp% bit though.

    4. I then reset my hosts file (you know, the one you manipulate to downgrade). This KB from Microsoft describes how to do it. I did it manually: How do I reset the hosts file back to the default.
    • I have a 64-bit system, which means there are two locations available for a hosts file. These are (in Vista, without quotes) 'C:\Windows\system32\drivers\etc' and 'C:\Windows\SysWOW64\drivers\etc'. I just created a new one in both directories, just in case. If there is no 'etc' folder in SysWOW64\drivers, create one.

    5. I installed iTunes again.
    • Pay attention that you get the right version. I had iTunes 32-bit installed while I should have installed the 64-bit version.
    • If you have a 64-bit system, make sure that iTunes is installed in 'C:\Program files' and not in 'C:\Program file(x86)'.

    6. I placed the backups back where they belonged (where we copied them from in step 2). Then I imported my music back into iTunes with the library. Then I connected my iPhone.

    At this stage I was able to restore my iPhone to the earlier backup. However, syncing still gave me errors. I discovered that ZoneAlarm was the culprit, even though it shouldn't have been because ZoneAlarm says it fixed the error.

    7. I quit ZoneAlarm and could sync ok again.
    • Even if you give every one of Apple's programs full control in ZoneAlarm, the error will still occur. Shutting down is the only option.
    • For reference, the source I used for this was [ame]http://forums.zonealarm.com/showthread.php?t=75280[/ame] (vBulletin isn't parsing this URL correctly, so I have to post it like this).
    • Before someone can comment this: I am ditching ZA, probably going for Comodo. It's just that I was so fond of it under XP :(

    8. (Optional) If you hadn't done so yet, you can downgrade and jailbreak now and should be a happy camper again :)!

    I hope that this post can help someone else. If you have trouble syncing give it a try! Let me know if it helped, or if you run into trouble.


    PS - If any mod can put [SOLVED] in the title that would be awesome :)
    Last edited by Qopzeep; 2011-02-07 at 02:38 AM.
    2011-02-07 02:31 AM