User Tag List

  1. shyking_82's Avatar
    Hi guys!

    Let me give a little intro to what my pb is. I have an iPhone 3GS 16GB officially unlocked and jailbroken. Last night I wanted to upgrade its firmware from 3.1.3 to 4.3.3.

    The first problem was when I was trying to update it by pressing SHIFT + RESTORE button in iTunes and selecting Stock 4.3.3 ipsw problem number 3194 showed up. I searched internet and came across TinyUmbrella and hit the "Run TSS Server" button and restarted iTunes and this problem solved.

    Then the second problem appeared. In the phase of "Preparing iPhone for restore" in iTunes, problem number 1604 poped up. I searched internet again and found its solution by using iREB-rc4. I ran iREB-rc4 then restart the procedure and finally it got updated to 4.3.3 with some problems.
    When the bar on iPhone came to its end indicating the completion of updating procedure, suddenly iPhone's screen turned black. In my opinion it wanted to reboot but it couldn't and it remained in DFU mode. Plus iTunes detected the device in "Recovery Mode". Anyway, I played a trick then I jailbroke it with redsn0w_win_0.9.6rc15 and jailbreak files were downloaded and process was completed. The iPhone's screen turned black again when the process of jailbreaking completed. I ran "redsnow" again and select "boot tethered" and finally the device came to its normal mode and jailbroken with iOS 4.3.3. After that I wanted to finish the process of jailbreaking by opening Cydia but after a few seconds a system message turned up on Cydia saying that "Your phone cache is almost full. Try to free some space" with “Dismiss” button (actually I can't remember the exact phrase but the idea is the same.) Suddenly the phone wanted to restart but since then the screen of device has remained black and its status has been in DFU mode and iTunes detects it in “Recovery Mode” as well.
    I tried everything on internet as following to get the phone back to normal mode:
    1- I held Home + Power button together to let Apple icon comes up but after a few minutes of trying nothing happened.
    2- I tried to restore again with aforementioned procedure but problem numbers 1600, 1601 were thrown by iTunes. Needful to say that I prepared the phone in DFU mode with iREB-rc2, iREB-rc3 and iREB-rc4 but the result has been the same and 16XX problem number cannot be bypassed by iREB-rc4.
    3- I tried to both jailbreak and “boot tether it” with redsnow again but both tasks stopped at the point saying “Waiting for reboot” and nothing happened. It seems that my iPhone can’t restart at all.
    4- I tried Snowbreeze 2.7.3 to create a custom iOS but the result was the same as well.
    Tinyumbrella, iREB-rc4, iTunes, redsnow all of them recognize my iPhone but in DFU Mode and to me there is no way to get it restarted or back to normal mode.

    At last, I am a man badly in need of any help!!!!!!!!
    Thank u in advance…
    2011-05-18 01:42 PM
  2. Littlejd123's Avatar
    I think iTunes is having a problem contacting apple... Go into tiny umbrella then click settings then UNcheck set hosts file ti Cydia on exit close tiny umbrella and try again. If that doesn't work try going into DFU mode again (hold both for ten sec then home for 7)
    2011-05-18 02:12 PM
  3. shyking_82's Avatar
    Thx Little...
    I did what u said. I opened TinyUmbrella and UNchecked that option, closed it, opened iTunes and tried to restore it with Stock 4.3.3 ipsw but iTunes threw 1601 problem number and with Custom-made 4.3.3 ipsw by snowbreeze it threw 1600. My firewall is turned off and my VPN to a US server is on.

    What should I do?????????????
    2011-05-18 02:44 PM
  4. goofball2k's Avatar
    check your hosts file for any reference to and delete the line.
    2011-05-18 09:48 PM
  5. shyking_82's Avatar
    Thanks for ur reply goofball
    I checked my host file and there was no line pertaining to “”. iTunes always throws the exception when restoring iphone with Stock 4.3.3 ipsw. I even looked up wiki iPhone and it referred me to an old KB apple tutorial on reinstalling iTunes. I tried to reinstall iTunes on another PC with new cable but the result is the same! 
    I believe that my iPhone has entered into DFU mode from which it cannot go out because the last line of log list in TinyUmbrella says “DFU device DISconnected” when iTunes throws exception 1601 after 4 minutes.

    Any suggestions, plz????????
    2011-05-19 10:10 AM
  6. A3gOwner's Avatar
    Use redsnow to enter pwned dfu only. Once you do that shift+restore to stock 4.3.3. Any errors after this? If so what #?

    Also how is the phone "officially" unlocked?
    2011-05-19 10:20 AM
  7. shyking_82's Avatar
    Thanks A3gowner
    I put iphone into pwned DFU only with redsn0w-rc16 and Stock iPhone2,1_4.3.3_8J2_Restore.ipsw. When I was restoring it with iTunes, it threw the same error 1601. When I was restoring my iPhone in iTunes, it got stucked in a step saying “Preparing iPhone for restore..” for 4 minutes and at the end showed 1601 error.
    As I said before, I believe that my iPhone has entered into DFU mode from which it cannot go out.
    Can discharging the battery be helpful? Is there another way to kick the iPhone out of this locked DFU mode where it cannot REBOOT?

    PLZ HELP!!!!!!!!!!!!!!

    P.S.: What I meant by “officially” was I bought it Unlocked version from O2.

    Thanks in advance, guys!!!!
    2011-05-19 12:11 PM
  8. A3gOwner's Avatar
    Can you just shift restore to stock 4.3.3?
    2011-05-19 02:08 PM
  9. shyking_82's Avatar
    Yes. I have always tried SHIFT restore Stock 4.3.3.

    I have tried it with 3 PCs and 2 cables and different USB ports. None of them worked out!

    2011-05-19 02:19 PM
  10. A3gOwner's Avatar
    Yes. I have always tried SHIFT restore Stock 4.3.3.

    I have tried it with 3 PCs and 2 cables and different USB ports. None of them worked out!

    What error you getting doing shift restore to stock ipsw? I need the number.
    2011-05-19 02:41 PM
  11. shyking_82's Avatar
    Man, I wrote it before 1601!!!
    2011-05-19 02:45 PM
  12. Littlejd123's Avatar
    My guess is ur phone is NOT in dfu mode it's stuck between DFU and normal. Go to and get iREB run it for 3GS TWICE this should kick it out of DFU but it might only be for a second then it goes back to REAL DFU then don't do shift restore just do a normal restore (no shift) incase something was wrong with ur ipsw
    2011-05-19 03:15 PM
  13. iYeow's Avatar
    Man, I wrote it before 1601!!!
    Reboot your computer and try it again.
    2011-05-19 08:57 PM
  14. shyking_82's Avatar
    Thx for your replies iYeow and Littlejd123
    but my problem has been resolved but I don’t know HOW or WHY????

    1- I have been told for many times to restore Stock 4.3.3 with SHIFT + Restore in iTunes but in iTunes always threw 1600 or 1601 error. This error should be thrown whenever CUSTOM FW is used but mine has always STOCK. That’s why I was stuck in this part and I couldn’t get out. (iREB-rc4 should be used whenever applying CUSTOM FW not STOCK FW)
    2- I tried a solution on how to get SHSH blobs when iPhone is stuck in DFU mode with “UVCView.x86.exe” but in my PC with Win 7 64 bit installed the respective USB host didn’t show “Apple Recovery (iBoot) USB Driver” instead “Apple Recovery (DFU) USB Driver” was displayed. And whenever I chose it, it stopped responding!!!!!!!!!!!!!!! (Fortunately I had save SHSH blobs before I ran this and I wanted to try it if it worked but it turned out with no result!!!!!!!!!!)
    3- With previously saved SHSH blobs, I could restore my DFU-stuck iPhone to Stock 3.1.3 and it worked completely right.
    4- Then I restored it again with Stock 4.3.3 but the same story happened! iTunes threw 1601 (I thought it might ve been a error in file while downloading but when I checked the downloaded Stock 4.3.3 in SHA1checksum, the numbers matched!!! :-S )
    5- Although the checksum showed that the download file was correct, I downloaded it again but with a little difference; I downloaded it completely without interruption (no pause/ no resume)
    6- Having downloaded the file, I tried it on my PC but the same story happened again!!!!!
    7- At last, I tried the same routine in my Notebook win XP 32bit with newly download file, and finally it was restored to Stock 4.3.3 and I unlocked it with iTunes and I jailbroked it with redsnow rc16. Now it’s completely working fine!!!!!!!!!!!
    To cut the long story short, I dunno what resolved my problem but these 2 things:
    3- Another PC with win XP 32 bit
    4- Newly downloaded Stock 4.3.3 ipsw with no pause/resume in between
    Correct me if I m missing something!
    Thanks anyway for your help, guys!!!
    2011-05-21 01:48 PM
  15. Contivity's Avatar
    Finally get out of DFU following the instruction here:
    [SOLVED] iPhone 3GS Stuck in DFU (Black/White Screen) | Life in 0 and 1
    2011-07-01 12:46 AM
  16. umair123456's Avatar
    Finally get out of DFU following the instruction here:
    [SOLVED] iPhone 3GS Stuck in DFU (Black/White Screen) | Life in 0 and 1
    how to do that i read it but cant understand can u tell me in details my mail is [email protected] [email protected] plz plz plz help me to get out of this permanent dfu in 3gs plz help i m waiting for u!!!!!!!!!!!!

    plz plz help

    contivity thx 4 ur post but can u tell me in easy and detail steps of these bcoz i m not understanding those steps written in ur link
    Last edited by umair123456; 2011-07-26 at 02:15 PM.
    2011-07-26 02:13 PM
  17. joshua0530's Avatar
    Im stuck on DFU mode and when I ran "redsnow" and select "boot tethered" after that a half yellow half white will appear on the screen I've searched on the web and nothing worked

    What should I do????
    2012-08-15 11:15 AM
  18. Chaosin's Avatar
    hey i had the same problem. i realized that when i built the jailbroken ipsw, i built it on an old bootrom. try rebuilding it on a new bootrom using snowbreeze. the before you restore, make sure you use ireb with your phone again. then restore using the newly built ipsw that has the new bootrom. if this doesn't work then let me know.
    2012-11-26 04:04 AM