1. swip51's Avatar
    is it a 3gs?
    2011-08-04 09:37 PM
  2. kashvii's Avatar
    Yes Sir
    2011-08-04 09:51 PM
  3. swip51's Avatar
    using the latest TU?

    and you're sure you've got the ECID right?
    2011-08-04 09:56 PM
  4. Simon's Avatar
    PM me the ECID if you can and I can check what SHSH you have.

    I was able to save 4.1 and 4.3.5 SHSH with the ecid you PMed me.

    You need to make sure the box under advanced in tiny umbrella that says "request SHSH from cydia" is NOT checked.
    Last edited by Simon; 2011-08-04 at 10:13 PM.
    2011-08-04 09:57 PM
  5. kashvii's Avatar
    Thanks Simon,

    Ill try that and post the details. one more thing, as swip51 mentioned, is it absoultely necessary to have the latest TU version?
    2011-08-04 11:00 PM
  6. swip51's Avatar
    Thanks Simon,

    Ill try that and post the details. one more thing, as swip51 mentioned, is it absoultely necessary to have the latest TU version?
    I'm pretty sure it's not but it's worth a try
    2011-08-04 11:01 PM
  7. Simon's Avatar
    Not absolutely necessary but it should at least be a recent version. The latest version is best to have though.
    2011-08-04 11:06 PM
  8. kashvii's Avatar
    No Luck...im pretty sure im missing some step....Here is what I just tried and phone seemed to install 4.1 and goes back into the DFU coma.

    1. Use iReb4 for DFU
    2. Start the TU server (Set hosts to cydia on exit and request shsh from cydia are both UNCHECKED)
    3. Go to itunes - Shitt+restore to custom 4.1

    The process seems to go fine till the very end...and the phone goes back to DFU loop. I tried original 4.1 FW (longshot), it gives me error 3194.

    Just in case you are wondering, here is what my host files look like at the moment, this may have somethign to do with it:


    #74.208.105.171 gs.apple.com
    #127.0.0.1 gs.apple.com
    74.208.10.249 gs.apple.com

    Any suggestions?
    2011-08-04 11:16 PM
  9. swip51's Avatar
    127.0.0.1 localhost
    #74.208.10.249 gs.apple.com
    #127.0.0.1 gs.apple.com

    That's what my host file shows. Also you will have to restore to stock 4.1 when I used custom it put it back in the loop unless I had installed stock first.
    2011-08-04 11:21 PM
  10. kashvii's Avatar
    Ok, will try that I guess...

    You think it matters if the Baseband is 615? I thought only custom fws can be accepted if if the bb is 615.
    2011-08-04 11:24 PM
  11. swip51's Avatar
    as long as TU is running and your SHSH blobs are saved it should accept it, I think haha.
    2011-08-04 11:26 PM
  12. Simon's Avatar
    You will get a error 1015 near the end of the process if you have 6.15 baseband installed. Just use tiny umbrella to exit recovery after that.

    You should also make sure your hosts are pointed to Apple for this process. Open tiny umbrella, click advanced, deselect the box that says set hosts to cydia on exit. Then close tiny umbrella and try the restore to 4.1.
    2011-08-04 11:29 PM
  13. kashvii's Avatar
    Changed my host files to match swip51:


    Ran TU server...shift-restore to stock 4.1 (finallly no 3191 error!).....the process started without issues....thought i was almost home free....then the 1015 error popped up. I immeidately went to TU to "exit recovery", but that option is grayed out (not available)..and teh phone seems to be in dfu mode (black screen).....sigh...what do you think?
    2011-08-05 12:29 AM
  14. Simon's Avatar
    If you havent saved your 4.1 SHSH with tiny umbrella and you start the TSS server then tiny umbrella has no SHSH to give itunes when it requests it. That is why you are ending up in DFU after the restore because you havent supplied the SHSH. So you either need to follow what I said above with not using tiny umbrella or you need to find a way to get tiny umbrella save the 4.1 SHSH first. There is no point in starting the TSS server if it doesnt have your SHSH saved.
    2011-08-05 12:55 AM
  15. kashvii's Avatar
    Man....cant thank you enough! Many many many thanks for your help guys. Was finally able to recover the iPhone.

    God Bless!
    2011-08-05 07:13 PM
  16. Simon's Avatar
    2011-08-05 07:40 PM
  17. pelax's Avatar
    Now we are getting somewhere

    Do the process of restoring to the custom 4.1 again. This time use tiny umbrella and start the tss server for the process.
    Hi everyone, I have the same problem, I have unlocked some iphones for a while.

    I have rigth now 2 3GS, on DFU mode.
    follow this instructions, and got the 4.1, 4.3.5 and on saved
    but when tried to restore 4.1 with itunes (having TU running), got ERROR CODE (20) ....
    any ideas ?
    thanks in advance
    Ezex
    2011-08-05 10:58 PM
  18. pelax's Avatar
    Hi Simon,
    one of the phones is UP and running!!! , using your suggestions.
    1) used USBview 1.0 to get ECID
    2) TUmbrella, to save SHSH.
    3)Started TU TSS server.
    4) Itunes to put 4.1 Firmware. (this iphone had already the 6.15 baseband)
    5) Used TU to kikout the phone from recovery .

    now i have the other 3GS, that is giving me the error 2 in itunes during this steps.

    I would like to say thank you, and also to send a FREE BEER for you, let me know to donate, if possible.

    Ezequiel
    2011-08-06 11:01 PM
38 12
LINK TO POST COPIED TO CLIPBOARD