1. yzerman2011's Avatar
    I have two issues going on right now which is making the ability to use my 3G iphone unusable and I would love any ideas no where to start to fix them. I have pretty much exhausted all the known fixes out there for them

    1st off... Let me set up where I was at when I was working.

    I had my 3G upgraded to 4.1.2 and baseband 6.15 (ipad) to allow me to use it on t-mobile.

    I didn't like the speed so I decided to downgrade to 3.1.3.

    I basically set the phone in DFU mode, installed 3.1.3 offical recovery.

    Then I ran Redsnow and installed 3.1.2 jailbreak.

    The phone came up, but wouldn't activate (of course using a t-mobile sim) so I swapped the sim for a ATT sim that wasn't tied to a active account and the phone says activated. Then I slide the slider to open to the icon menu and a pop up comes up saying "edit home screen" blah blah blah.. but here is the problem. It won't pick up that I am hitting the DISMISS button. I have tried everything out there to get around it but this.. I cant press dismiss (edit home screen) - iFans - iPad, iPhone, and iPod touch Fans forums with a 2nd sim card send a text message.. I am going to try this tonight.

    The second issue I ran into was just trying to get the phone back to 4.1.2

    SO I download a custom firmware with 4.2.1 and the baseband/jailbreak in it and do a DFU recovery and load up the firmware. Now the phone goes into a recovery loop. Tinyunbrella 5.0 or Ireb do not allow me to jump out of it. I can see them communicate to the phone and tell them to break out but they won't get me past that darn iphone/cable recovery icon that pops up.

    So I am open to suggestions. I have searched a lot of boards and tried a lot of different things but either way running 3.1.3 and 4.1.2 isn't working for me right now. Any thoughts.. the only thing I read into 4.1.2 was talk of doing a custom firmware of 4.1.2 with NO baseband in it and then restoring with that.. and that working for some guy but I haven't heard if that would be a real fix because I haven't see anyone else post it.
    2011-08-09 05:49 PM
  2. yzerman2011's Avatar
    Just a update, I was able to get past the 4.1.2 recovery loop by using a custom restore with no baseband in it. iOS 4.2.1 Custom Firmware without Baseband update – Untethered Jailbreak

    However how I am running into the same issue as I did in 3.1.3, the "edit home screen" message is still stuck and won't let me dismiss it.

    Any thoughts on how to get around this?
    2011-08-09 07:20 PM
  3. Mes's Avatar
    Have you verified it's not a hardware / digitizer problem in that small area of the dismiss window?
    2011-08-09 07:31 PM
  4. yzerman2011's Avatar
    Yes I have. I am currently referencing this post in trying to resolve the issue.

    My iPhone is stuck on the edit home screen - MacRumors Forums

    I will try to do the text/sms trick but I am also messing around with generating a new custom ISPW with snowbreeze. I just need to know where and what packages I should be pre-loading. I did enable SSH in snowbreeze so I suspect that may help. I also am going to enable ultrasnow so I can use my t-mobile sim and maybe hit it with a text message.

    I am very puzzled why I am even running into the stuck message in the first place. I wonder when I did my first Jailbreak with snowbreeze I probably turned on SSH and that changed the password but would doing the DFU and the image restores erase all those passwords and settings by formating the phone?
    2011-08-09 07:44 PM
  5. Mes's Avatar
    Any restore (normal or DFU) erases everything. Using iTunes to 'restore from backup' recovers most things.

    Edit: Sn0wbreeze (Expert mode) is 'where' you add custom packages. What to add... can't really say
    Last edited by Mes; 2011-08-09 at 07:57 PM.
    2011-08-09 07:49 PM
  6. yzerman2011's Avatar
    Thanks Mes for the follow up, So if a DFU erases everything why would the Edit Home Screen dismiss button stop working? It seems what I was reading its tied to changing a SSH password or something. There wouldn't be a area of the phone that is always saved even between versions where it could have written something could it?
    2011-08-09 08:20 PM
  7. Mes's Avatar
    ^I've changed my OpenSSH password several times, lots of restores and never seen or heard of your problem. If you can SSH into the phone it shouldn't be a problem. That's why I first thought it was hardware --- a bad area or a mis-aligned LCD / digitizer. From a software view, I've seen a couple apps where the monitored touch area does not match the pop-up window.
    2011-08-09 08:28 PM
  8. yzerman2011's Avatar
    I got it.. holy crap.. took me all day.. and I am not sure I got it figured out perfectly but I ended up going into snow breeze for 3.1.3 and doing a hacktivation and including the ultrasnow to the device, then I did a restore to 3.1.3 normal and then did a restore of 3.1.3 with my custom IPSW. For some reason after that point I never saw the message but I still couldn't type in that area of the screen. It was like there was a phantom area there.. Cydia was missing and I ended up using spirit to get it installed but at least now I have wireless and should be able to ssh and edit the stupid file.
    2011-08-09 10:15 PM
  9. Mes's Avatar
    Thanks for the update. Some of us needed to restored twice (or more) before everything was perfect. It should not be required, but sometimes it does help. Good luck
    2011-08-09 11:36 PM