1. docmagoo2's Avatar
    Hey all, wondering if anyone can help.

    I have an old 3GS (my test device) upon which I had ios5 beta (up to beta 3) running. I decided that I wanted to go back to ios 4.3.1 (all SHSH blobs saved from ios4.0 onwards) using tinyumbrella but I couldnt get this to work at all. It finally let me restore 4.0.1 and from there I upgraded to 4.3.5. which went fine from the apple servers.

    Now the problem is when I try to downgrade to 4.3.1 so I can jailbreak untethered I keep getting an itunes 2005 error (device cannot be restored), no matter what version of iOS4 I attempt to install. I have even attempted to go back to iOS 5 but then itunes gives me an error 1600. On researching error 1600 it seems to have something to do with custom FWs and believe me all mine have been vanilla apple downloads. Now I know that an 2005 error usually means hardware, I have tried different USB leads, and on three different laptops but to no avail. I have tried regular mode, restore mode, DFU mode but nothing works. I have tried different versions of tinyumbrella, different versions of itunes, but nothing will help me restore. If anyone has any ideas let me know. Im tearing my hair out. Its an o2 UK iphone 3GS now running iOS 4.3.5.

    Helllpppppp
    2011-08-28 02:43 PM
  2. Mes's Avatar
    If you're able to restore to 4.0.1 ...then your device is good.
    Do you have 4.3.3 blobs saved? 4.3.3 is the lastest jailbrakable 4.x iOS.
    Run Tiny Umbrella, start TSS server, verify no errors.
    Build and restore a custom (cfw) firmware (4.3.3) using the latest Sn0wbreeze or Pwnagetool.
    Continue w/sn0wbreeze or pwnagetool and enter Pwnd-DFU. Restore cfw w/iTunes
    If iTunes error 10xx, put device in normal DFU mode & use fixrecovery43.

    Note about error 1600:
    Error 1600

    Custom firmware can't be restored on a device with DFU Mode. The software of the iPhone isn't patched. Using iREB, Sn0wbreeze, Redsn0w or Pwnage Tool, you need to enter a pwned DFU-Mode. During that process the software gets patched and the custom firmware should run without any problems
    iTunes Errors - The iPhone Wiki
    2011-08-28 03:36 PM
  3. docmagoo2's Avatar
    Ok. Think it may be the device. Now seems to get stuck at the apple screen with an empty progress with attempting to restore even to stock iOS 4.3.5. Just sits there and doesn't do anything (ie the bar doesn't fill) then quitting the restore kicks it back into the connect to iTunes recovery mode loop. iREB and TU cant kick it out. Fix recovery doesn't do anything. Only thing I can think of is the device it screwed.
    2011-08-29 04:28 PM
  4. Mes's Avatar
    Not necessarily, because it restores to 4.0.1!
    2011-08-29 04:34 PM
  5. docmagoo2's Avatar
    ok. got it working again. now running ios 4.3 (just chose a random ipsw). so guess device is ok. phew.
    2011-08-29 11:01 PM
  6. Mes's Avatar
    Ahh good. Success with 4.3
    Congratulations.
    2011-08-29 11:20 PM
  7. docmagoo2's Avatar
    yeah, its was the oddest thing! think it may have actually been the USB port running really slowly and hence I assumed that the bar wasnt filling. got the 1015 error, but was able to kick it out of recovery with TU.
    2011-08-30 12:14 AM
  8. Mes's Avatar
    Windows causes a lot of restore problems.
    Likely 4.3.3 will load w/o issues ... best to stay put for now
    Cheers
    2011-08-30 12:18 AM
LINK TO POST COPIED TO CLIPBOARD