1. flarecatcher's Avatar
    Hi everyone.
    I'm new to this forum and I have an issue with a 3GS new bootrom that is stuck in DFU...
    I looked throught the forum and it seems I'm not the only one nevertheless I didn't find any solution yet...

    Old Iphone, Long story...:

    I bought this Iphone and jailbroke it several times. I have Cydia SHSH for 2.0.1, 2.1, 3.1.2 and 4.0.1.
    I worked well in 4.0.1 quickpwned untethered (jb where there is a colored line on apple logo) and I decided to go to the properties to remove all data to sell it to a friend.

    In the process it started to reboot again and again, stuck in jb bootscreen and loopind after 10 min or so.

    I got it in and out of recovery and DFU mode but no succes.
    So I decided to restore it.
    Tried with 4.0.1 stock firmware and 4.3.3 stock and got error 3194.
    Tried removing host line gs.apple.com but no luck so downloaded tinyumbrella and fixed 3194
    Got to error 16XX a couple of them... and deviced stuck in DFU (recovery mode not available...)
    Tried to kick it out of DFU but didnt work.
    Got iReb 4 and pwnedDFUed it.
    Restored to 4.3.3: itunes restores it ok but at the very and when its says the iPhone will reboot: stuck in some kind of DFU.

    I read somewhere it was due to 4.3.3...
    I Downloaded 3.1.2 (had the SHSH) with iReb and TU got through restore but error 1015.

    I read on forum to use "exit recovery" but it was unavailable on TU, only the fixrecovery button vas possible so I used it. Then turned it on. The iPhone screen got blank then some writings appeared:
    "unable to find gBdevList
    unable to find fs_mount
    unable to find fs_unmount
    unable to find fs_load_file
    greenpoison initialised."

    Then after a few minutes (was googling for answers) a hole bunch of text went by (like old PC booting) and iPhone shut off.

    In a nut shell:
    I want to restore it to a stock firmware 4.X.X if possible and jailbreak it.
    What should be my next move?....

    Thanks beforehand for your help!
    2011-09-06 06:49 PM
  2. Mes's Avatar
    Apple is currently signing iOS 4.1. If you don't need an unlock, 4.1 will also update the baseband.

    The following restores to 4.1, updates the modem firmware / baseband, no unlock required.
    First reset the phone. Hold power + home button for 6-8 seconds. This will force a power off.
    ... A high-low computer sound as confirmation should be heard. The iPhone may reboot, that's ok.

    Start Tiny Umbrella, advanced tab, uncheck 'set Hosts to Cydia on exit', and exit Tiny Umbrella.

    Start iTunes (if not started), hold shift and select restore, select 4.1 firmware.
    If iTunes Error 10xx, start Tiny Umbrella and select 'exit recovery' (not fix recovery).
    If any other error or exit recovery is unavailable, the restore was not successful.
    Done with restore.

    Run redsn0w 0.9.6rc8, select install Cydia to jailbreak.
    2011-09-06 07:30 PM
  3. flarecatcher's Avatar
    Thanks for the short notice!

    What does signing a firmware means?
    My iPhone is somewhere between DFU and brick. Recovery mode is not available and it doesnt "mount sound" when plugged in.
    Only iTunes seeing a restorable iphone and unable to see the details (model size...)

    I dont have 4.1 downloaded right now and my internet is crap... Do you think any of 4.0.1; 4.3.3; 4.3.4; 4.3.5 could work, knowing that I intend to jb it afterward untethered...

    Also should I pwnDFU it or not? (if not I have an error at the beggining of the restore)

    Thanks for the time spent on my issue
    2011-09-06 07:53 PM
  4. Mes's Avatar
    "Signing" means Apple is currently providing the SHSH blobs. Strange, but true.
    With your current blobs, 4.1 is the maximum version available for a restore.

    If iTunes 'sees' the phone .... that is fine. Remember to power off (Home+Power 6-8 seconds) as instructed.

    4.1 is special and should restore, maybe iTunes 10xx error. That's ok, TU exit recovery fixes that. If any other error or exit recovery is not available, start over and use redsn0w 0.9.6rc8 to enter pwnd-DFU before using iTunes.

    4.0.1 is restorable. If this is your choice, Tiny Umbrella + TSS server must be running before iTunes.
    2011-09-06 08:08 PM
  5. networkguru's Avatar
    I was almost in similar situation.
    However Simon came to my rescue.

    Try the following steps.

    1. Connect your phone to PC, iTunes will recognize it in recovery mode.

    2. Now download the latest Snowbreeze 2.7.3
    iOS 4.3.3 Ipsw

    3. Fire up snowbreeze, follow instructions and create custom firmware.

    4. After process is complete, snowbreeze fires up iREB and PwnDFU's your phone.

    5. Snowbreeze by default will save the custom firmware Ipsw on your desktop by default.

    5. Go back to ITunes, hit shift, click restore and locate the snowbreeze Ipsw and follow on screen instructions.

    I was able bring back my phone from semi DFU/brick state to working.
    2011-09-06 10:29 PM
  6. Mes's Avatar
    A custom firmware works when all other methods fail.

    However, it must be done with iOS 4.1 because you don't have 4.3.3 SHSH blobs
    Last edited by Mes; 2011-09-06 at 10:40 PM.
    2011-09-06 10:32 PM
  7. flarecatcher's Avatar
    The method using 4.1 worked!
    I got the 1015 error but TinyUmbrella could get it out of recovery mode.

    So Thanks a lot!

    Do you think that now i could update to 4.3.3 then Jailbreak or should I stay in 4.1?
    Is it safe to jb a phone with data on it(Not right after restore but after sync with iTunes). I do not fear loosing data since it's only copy from iTunes Back up.
    2011-09-07 06:24 PM
  8. Mes's Avatar
    Congratulations
    IF you have SHSH blobs for iOS 4.3.3, yes. Use Tiny Umbrella to find out.

    Jailbreak'ing can be done anytime and does not effect any iTunes installed data.

    Note: I typically jb and get basic functionality and my personal system tweaks working first (push, data, custom carrier bundle, low-level mods, etc) before adding iTunes data.
    Last edited by Mes; 2011-09-07 at 06:38 PM.
    2011-09-07 06:30 PM
LINK TO POST COPIED TO CLIPBOARD