User Tag List

  1. Flisker's Avatar
    Hi guys,

    If anybody here could solve my problem it would be miracle

    I am trying to downgrade my iPhone 3G from 4.2.1 to something ... 3.1.3/3.1.2/Whitedoor5 .

    But nothing works, I have installed libusb , recboot is working for me, but thats pretty much it .

    I tried toon of things , iReb5 , TinyUmbrella (I am not sure if I this right) and still when I try restore iphone with different firmware or customfirmware it says error : 16XX -> 1 3 4 45 46 error.... and so on . Also I tried DFU, pwned DFU (by iReb5) , restore or normal mode .

    I have no idea what else should i try.

    I am using latest iTunes x64.

    Thx in advance for any help.
    2012-01-15 09:33 PM
  2. Susty's Avatar
    Do you have shsh's? If not, you won't be able to downgrade.
    2012-01-16 03:41 PM
  3. xboxbml's Avatar
    I don't think u need shsh for a 3G..
    2012-01-16 07:53 PM
  4. Susty's Avatar
    Sorry, yeah because it's going lower than ios4. So once the phone is in DFU mode, your holding alt & pressing restore (or shift & restore on windows)? When't the error occurring?
    2012-01-16 08:27 PM
  5. Flisker's Avatar
    So pwning DFU went fine , than I started restore process -> extracting software -> preparing iphone for restore (this took a while) -> error 1601 and also I got whitescreen on phone now.
    Last edited by Flisker; 2012-01-16 at 09:32 PM.
    2012-01-16 09:21 PM
  6. Susty's Avatar
    Ok, then you use recboot to kick it out at that stage.
    2012-01-16 10:41 PM
  7. Flisker's Avatar
    Kicking it out wasn't problem, but still cant get that 3.1.3 in there : (
    2012-01-16 10:42 PM
  8. Susty's Avatar
    That'll kicks it out of DFU, then shift restore again, you'll get an error again, put it back into DFU mode, then restore the phone by selecting the custom firmware that you have. Sounds like a pain in the you know what...
    2012-01-16 10:56 PM
  9. Flisker's Avatar
    So I got custom 3.1.3 fw installing but after installation, OS got stucked on loading screen . And now I cant restore again. I am back to random errors 1600 first try , 1602 secon try , omg
    2012-01-16 11:45 PM
  10. iYeow's Avatar
    You should restore to 4.1, if you don't enable Multitask , 3G iphone should perform well. Put your iphone into recovery mode and restore to stock 4.1 and if you error at 1015, kick it out with Tiny umbrella.
    2012-01-17 05:09 AM
  11. Flisker's Avatar
    Thx. I'll give it a shot
    2012-01-17 05:02 PM
  12. iYeow's Avatar
    Did you get it going ?
    2012-01-17 06:19 PM
  13. Flisker's Avatar
    So now its doing still same thing regardless what do I try to restore -> while restoring screen goes white but just for a moment than pc makes few sounds (probably disconnecting and connecting phone) and phone restarts itself , than I get 1646 error .
    2012-01-17 06:20 PM
  14. iYeow's Avatar
    Have you tried changing USB cable or use different USB ports.
    2012-01-17 06:27 PM
  15. Flisker's Avatar
    So same thing. Sound - Black Screen - Sound - White screen - Sound Apple Logo - Sound - Old OS Loaded - Sound - 1646 Error

    Actually only thing that was working for me so far was official restoring to 4.2.1 fw

    Btw now I am always using iReb to get phone into pwned dfu before restoring to custim firmware , thats ok right ?
    Last edited by Flisker; 2012-01-17 at 06:34 PM.
    2012-01-17 06:29 PM
  16. iYeow's Avatar
    No, don't use pwned dfu mode. Trigger a normal dfu mode to downgrade to stock 4.1 .
    2012-01-17 07:14 PM
  17. Flisker's Avatar
    I tried normal dfu and stock 3.1.3 and it worked but how do I jailbreak it now?
    2012-01-17 07:16 PM
  18. iYeow's Avatar
    Good, you can use Redsn0w 0.9.4 , browse to stock 3.1.2 to jailbreak it .

    The only problem here is your cydia version is too old and may have issue when downloading or updating cydia apps. You may need to find cydia deb file of 1.1.1 , use ifile or ssh into iphone and change it.
    I would recommend go to 4.1 and use Redsn0w 0.9.6b6 to jailbreak it .

    Now you are 3.1.3, to go to 4.1, you don't use dfu mode , use Recovery mode and restore to stock 4.1, Exit recovery to kick error 1015.
    Last edited by iYeow; 2012-01-17 at 07:27 PM.
    2012-01-17 07:18 PM
  19. Flisker's Avatar
    So I used Redsn0w 0.9.4 browsed for 3.2.1 cos 3.1.3 is unrecognisible , everything went ok , last message was Done! but when phone restarted there were no custom logo no cydia nothing : (

    The rest of your process takes place on device and nothing is going on anywhere

    And whole process takes like 3minutes +-

    Same thing with blackrain .. make it wain .. blablabla .. done .. and of course nothing changed
    Last edited by Flisker; 2012-01-17 at 09:36 PM.
    2012-01-17 09:09 PM