1. xwind's Avatar
    Hi, I bought a 3GS that is stuck in recovery mode (connect to itunes). I don't know what firmware or what baseband was on it before. But I want to restore it to 4.2.1.

    After looking at countless guides and youtube vids, nothing worked so I come to you guys for help. I can make the phone go into DFU manually, or by iReb or redsn0w, but when I try to restore with itunes I get error 3194. Both the stock 4.2.1 and every custom 4.2.1 firmware out there all gives 3194. I then tried changing my hosts file like all the guides say, but still I get error 3194. From my understanding, the hosts file will only work if you have SHSH blobs saved locally or on cydia, but since this was not my phone previously, I don't have the SHSH blobs.

    I suppose the easiest way is to just restore normal to the latest 5.0.1 and try the untethered jb that's just been released. However, I hear ios 5 is very slow on the 3GS, so I prefer to go 4.2.1.

    Any other ideas? Thanks.
    2012-01-18 11:47 AM
  2. Susty's Avatar
    I run 5.0.1 on a 3GS & it seems to run fine without any problems, however you can restore to 4.1 without shsh using ITunes if you want to stay on ios4.
    2012-01-18 03:48 PM
  3. xboxbml's Avatar
    Yeah 5.0.1 does not slow down the 3GS at all...I had it on mine for a while...it's just a bit of a ram and storage hog...and eats more battery depending on how u use it and what u have turned on..but it was not at all like the 3.x to 4.x issue with 3G! I just happened to dump my shsh from working 4.2.1 phone and created a signed IPSW with them so I can restore 4.2.1....I went back cuz 4.2.1 is best on 3GS..but 5.0.1 isn't at all terrible...
    2012-01-19 01:25 AM
  4. xwind's Avatar
    Ok, I will try 5.0.1 and see how that goes. BTW does that flash a new baseband? Hopefully it doesn't update it to something I can't unlock..

    Also, any ideas for improving the speed of 5.0.1? Does the remove Launch Daemons trick still work?
    2012-01-19 01:42 AM
  5. xboxbml's Avatar
    Uh..I don't know much about unlocking, but I don't believe the native BB is unlockable...I wasn't aware u wanted to unlock...

    Perhaps someone more experienced with unlocking can help...
    Last edited by xboxbml; 2012-01-19 at 03:28 AM.
    2012-01-19 03:26 AM
  6. xwind's Avatar
    Just an update on what happened. I tried upgrading to 5.0.1 using both just the normal itunes restore and via sn0wbreeze, but both gave me an error -1 right at the end of the restore. I found out that -1 is indicative of a bad radio chip. So I used sn0wbreeze again and this time I chose the Preserve Baseband option... this time it restored ok, but then it reboots when trying to activate via itunes. Also the signal just stays on "searching..." So, most likely there is a problem with the comm board. I will relist this on ebay again. Thanks for the help guys!
    2012-01-19 11:45 AM
  7. Susty's Avatar
    Do you see a modem firmware in the settings>about page?

    Use snow breeze but select hactivate, this should get you past the activation stage.
    Last edited by Susty; 2012-01-20 at 01:51 AM.
    2012-01-20 01:49 AM
  8. xwind's Avatar
    I can't get to the settings actually. Basically right after the restore, boot up, slide to unlock, asks for current location, enable/disable location services, then shows please connect to itunes.. when i connect it to the PC and start up itunes, itunes freezes for a few seconds, then the phone reboots. About the hacktivation part, when I build a custom IPSW using sn0wbreeze, itunes won't let me restore, at about 100% progress it errors with -1. The only way I got to restore fine was by using Preserve Baseband option (which doesn't give the hacktivation option).
    2012-01-20 02:04 AM
  9. Susty's Avatar
    Can you get it onto 4.1 to start with? That'll be a good place to start, that way you can get into the settings page to see what's going on without having to try to activate it. 4.1 for the 3GS is still signed so you shouldn't have an issue with this.
    2012-01-20 07:50 AM