1. Scmed27's Avatar
    My friend has an iPhone he purchased and it has a 1015 error. I am unable to use f0recast to show me what is currently on it. It's stuck in recovery mode. TinyUmbrella is unsuccessful at kicking it out as is RecBoot... I've read a couple other websites with failed attempts. Anymore ideas before I send him on his way with a broken phone? Thanks!

    I am sure this has been addressed before and I just can't find it, if that is the case please just provide a link and I don't mind reading!
    2012-05-18 01:35 AM
  2. jhuff26's Avatar
    Use iReb and click on the fix error 1015 recovery loop and follow the instructions. The reason your friends iPhone is doing that is because you tried to restore it while the iPhone had a custom iPad baseband put on it
    2012-05-18 02:25 AM
  3. Scmed27's Avatar
    Great info, it tells me to use a custom firmware to do the restore after it went through the stages... What custom firmware do i use?

    oh I get what you mean now, sorry ... It now tells me "Recovery loops cannot be removed on Tethered-jailbroken devices." Any solution?
    Last edited by Scmed27; 2012-05-22 at 05:31 AM.
    2012-05-22 05:29 AM
  4. EVO's Avatar
    because you are on the ipad BB, it doesnt matter if you restore to a custom firmware or stock firmware, since it is stuck in the recovery mode, just go to itunes and update it to iOS 5.1.1, that should eliminate the stock recovery mode
    2012-05-22 11:04 PM
  5. Scmed27's Avatar
    I have tried doing that and when I do it gives me error 1015
    2012-05-23 08:35 PM
  6. EVO's Avatar
    Ok this is a "possible solution", heres the instructions, follow exactly:

    1. Download the iOS 4.1 ISPW from:
    Firmware - The iPhone Wiki

    2. Use redsn0w 0.9.6B5 to put your 3G in PWNED DFU MODE

    3. Open itunes and it will detect your device in Recovery Mode.

    4. SHIFT + RESTORE and point it to the 4.1 ISPW you downloaded

    5. Wait for itunes to restore and it will give you the ERROR 1015, but thats ok!

    6. Open up tinyumbrella and hit "Exit Recovery" . Your phone should reboot and take you to the emergency screen.

    7. Run redsn0w 0.9.6B5 and point the ISPW to the 4.1.

    8. Click the "Install Cydia" and "Install Ipad baseband" checkbox, and follow the instructions to jailbreak

    "HOPEFULLY" this should fix your recovery issue and have a normal operating 3g again
    2012-05-24 01:01 AM
  7. Scmed27's Avatar
    awesome thank you so much!
    2012-05-28 04:26 AM
  8. EVO's Avatar
    awesome thank you so much!
    you're welcome

    glad I was useful to u
    2012-05-28 01:10 PM
  9. Lugi's Avatar
    Hello I have a similar problem. I tried following the above instructions but Tiny Umbrella doesn't see my iPhone connected.

    I have a iPhone 3G that was jailbroken.
    I get all the signs of a bricked iPhone.
    When I try to restore (3.1 , 4.1.1 , Just hitting restore) I get the 1015 error.
    Again, Tiny Umbrella doesn't see the iPhone is connected so it can't exit recovery.
    I use iReb to get into DFU PWNED mode and do the normal DFU mode.

    I'm at a loss.

    Any advice?

    I found this on another forum that a man had a very similar problem
    "It was the battery.

    I do not understand it, as the battery was fine until being dropped. They guy I took it to said he had seen it before with a phone that had been dropped. He put in a new battery, and the phone booted up perfectly, with no lost data.

    One of the things that fooled me was the fact that it would try to boot when plugged in. I figured it could run off the power supplied by the cable. This guy says no, it must have a battery.

    Anyway, after a lot of grief and self-doubt, my phone is fully functional.

    Many thanks for the help here, it is greatly appreciated!


    The phone was dropped, I think that it could be the battery.
    Last edited by Lugi; 2012-06-07 at 05:37 AM.
    2012-06-07 05:13 AM