User Tag List

  1. mick_hale's Avatar
    My beloved Sony Ericsson W595 took an unfortunate dive into a bucket of water, completely killing the microphone. While it's otherwise fully functioning, the only way I can actually have a phone conversation is through the earpiece, a massive annoyance. Luckily, I have awesome friends, and one just happened to have an iPhone 3G 8GB lying around in a drawer. The only problem is that it was locked on Rogers (Canada), and that the LCD screen had a few burnt-out pixels. I took it to a store to get it unlocked. When I got it back, I saw that there were some programs that I didn't recognize on the phone, so I decided to reset it through the phone's Settings -> General -> Reset -> Erase All Content and Settings. The phone showed the USB-iTunes logo, and was effectively bricked. That's roughly where most of the problems started.

    I managed to unbrick the phone twice after doing god-knows-what, but have been unsuccessful in getting it back to the unlocked state.

    I've spent a good portion of the last week trying to figure out what can be done to just get it back to a state where it's clean, then jailbreak and unlock. My latest desperate google search led me to this thread: , which is how I got to here. So far, this forum has been the best source of info for most of my questions.

    I have been repeatedly unsuccessful in jailbreaking it, and each time I try I still don't get Cydia to show up on my springboard. Here's the stats right now according to the phone's Settings -> About screen:
    Version: 4.1 (8B117)
    Carrier: Rogers 8.0
    Model: MB629C
    Modem Firmware: 06.15.00

    I have a fairly detailed log of my past few attempts. I'll post that right under this.

    I'm right now at a point where the phone functions more or less as an iPod Touch (thank God for functioning wifi). In an ideal world, this is what I want:
    1. Complete factory reset, erasing any and all past jailbreak attempts, restoring the phone to as default as possible - including baseband, carrier, lock, whatever.
    2. Upgrade iOS to 4.2.1, as I believe that's the most advance update available for the iPhone 3G, and there's a lot of apps that are only supported by 4.2.1.
    3. Unlock so that I can actually use it as a phone, not just a toy.
    4. Possibly change the screen so that I don't have a few dead lines, but still have my phone function the way I want it to. (Anyone know how much this would cost?)

    Every tutorial I've come across until now has kinda been lacking. Either that or it's a really good thing that I quit the high tech field 8 years ago.

    Here's the log, that I started from my first stroke of luck. Names censored to protect the less innocent.


    TinyUmbrella stats
    Device model: MB629C/A - iPhone3G
    Installed Firmware Version: 4.2.1
    Installed Baseband Version: 06.15.00-6.2_M3S2
    ECID (Dec): 3381248437621
    ECID (Hex): 313421CAD75


    Gmail was not installed because of unknown error (0xE8000065)
    iOS: Troubleshooting applications purchased from the App Store

    TinyUmbrella stats the same

    iTunes stats
    Name: User's iPhone
    Capacity: 6.90 GB
    Software Version: 4.2.1

    My SIM not working. Inserted Rogers SIM, "SIM Failure".

    Ready to try unlock via I**n's method:
    Step 1 - Jailbreak and Baseband update
    iClarified - iPhone - How to Jailbreak and Unlock Your iPhone 3G Using RedSn0w (Windows) [4.2.1]
    Step 2 - Baseband downgrade
    iClarified - iPhone - How to Downgrade Your iPhone 3GS, 3G Baseband for Unlock (Windows)
    Step 3 - Unlock
    iClarified - iPhone - How to Unlock the iPhone 4, 3GS, 3G Using UltraSn0w

    Step 1
    A) Download needed files: already done
    B) Restore using iTunes: ERROR 1015!


    iTunes: Phone in Restore mode.
    TinyUmbrella: Same as above
    redsn0w: iPhone 3G (recovery mode)

    Trying to unbrick, method:
    1. redsn0w: load "iPhone1,2_4.2.1_8C148_Restore.ipsw" via "Extras -> Select IPSW"
    2. redsn0w: entered DFU mode, "Extra -> pwned DFU"
    3. TinyUmbrella: Fix Recovery
    4. redsn0w reports phone in WTF mode
    5. unplug (TU: "DFU device disconnected"), replug (TU: "DFU device connected", iTunes: "Phone in recovery", redsn0w: "WTF")
    6. iTunes: restore using "NO_BB_iPhone1,2_4.2.1_8C148_Restore.ipsw"

    iTunes: phone restored... then detects it in restore mode.
    TU: DFU mode detected
    redsn0w: WTF mode

    Disconnect, reconnect: same status

    TU: Fix Recovery... "Fix recovery finished, allow reboot"
    Same status.
    Disconnect, reconnect: Same status.

    iTunes: restore using "iPhone1,2_4.2.1_8C148_Restore.ipsw"
    Error 1601

    From D****l, dude I met at supermarket in local mall by cell provider stand, Friday August 17, ~noon

    1. Download IPSW 4.1, it's more stable and won't slow down the phone
    2. Put phone in DFU mode
    3. Restore, using iTunes, with 4.1
    4. Jailbreak using Redsn0w v. 93b? (he wasn't sure which version)
    5. Install Cydia
    6. From Cydia, download Ultrasn0w to unlock.

    Following his steps:
    1. Downloaded.
    2. DFU engaged.
    3. Restore to 4.1 with iTunes:
    - 1015, you bastards.
    - reboot computer, try again with phone as is: 1015.
    - if that didn't work, then DFU and iTunes install 4.1: 1015.
    - if that didn't work, then redsn0w pwnDFU and iTunes install 4.1: 1015
    - if that didn't work, then Redsn0w -> Extras -> SHSH Blobs -> Stitch -> IPSW (4.1) -> Cydia
    - Use resulting file to redsn0w pwnDFU and iTunes install: 1601
    - Apple's solution to 1601 is to completely uninstall then reinstall iTunes & side programs: done
    - retrying redsn0w pwnDFU and iTunes install with special 4.1 file: 1601. ****.

    Saturday Aug 18

    Re-examine phone stats:
    RedSn0w: iPhone 3G (Recovery mode)
    Device Model: MB629C/A - iPhone3G
    Installed Firmware Version: 4.2.1
    Installed Baseband Version: 06.15.00-6.2_M3S2
    ECID (Dec): 3381248437621
    ECID (Hex): 313421CAD75
    iTunes: Phone in recovery

    3 at mega, 80-100NIS

    Redsn0w: Select IPSW: 4.1
    Just Boot: Back to Emergency Calls Only!
    on Phone: Can't do anything but Emergency Calls.
    iTunes: Set Up Your iPhone
    Options: Set up as new phone; restore backup.
    I choose backup: Can't, because software is old. So choose New Phone...
    Name: S****l Y***h
    Sync contacts w/ Win Address Book; none for rest; sync apps
    Some items couldn't sync: Wikipedia, iBooks need newer version of iOS software
    Phone is back to iPod mode!

    Back to D****l's method, Jailbreaking with redsn0w:
    options chosen: Install Cydia, battery percentage
    redsn0w says done, screen is on, black
    Seems to have worked? But no Cydia?

    redsn0w: iPhone 3G (4.1, 06.15.00)
    TinyUmbrella: stats same, iOS 4.1
    iTunes: iOS 4.1, wants me to upgrade to 4.2.1, ignored.

    Back to I**n's method, following iClarified's downgrading baseband for unlock
    Done, but wasn't given a pwnApple screen, still no cydia
    redsn0w: still at BB 6.15

    Google: Retry jailbreak. Back to redsn0w?
    Still no cydia. Trying different redsn0w?
    Nope. Trying again, this time overnight, with .14 redsnow? And no again.
    Last edited by mick_hale; 2012-08-20 at 09:41 PM.
    2012-08-20 09:32 PM
  2. bikedog's Avatar
    Wow- you've been pretty persistent and a lot of good info. It takes a hellishly long time to upgrade the phone's iOS (like 30 min).

    I think you might need to downgrade the baseband from 6.15 to 5.13.04.
    Downgrade iPhone 3GS / 3G 06.15.00 To 05.13.04 Baseband For Unlock And Working GPS [How-To] | Redmond Pie

    SOme other unbricking sites which seem reasonable:
    Best Tips to UnBrick Your iPhone 4S/4/3GS (Guide) | Maypalo

    I haven't bricked my phone but have a 3GS that I've updated the iOS several times, with a few errors along the way. A few things I've found are that you need to save shsh blobs via tiny umbrella, keep the baseband preserved when updating iOS (used redsn0W, put the phone properly in DFU mode (otherwise errors). Seems like you've tried this in the last try but not sure which redsn0w you used. One thing you might try is to download & install tiny umbrella- then see if you can kick the phone out of DFU mode or if tiny umbrella can 'see' the phone. You also need to run the shsh feature to see just how far you can upgrade the 3G. Also, I used 14b2 version of redsn0w which was fine- the 14b1 didn't have the baseband downgrade feature- kind of a key element. I also found that getting the proper IPSW is necessary rather than downloading thru itunes (redmond pie?). You'll need to run redsn0w to create a
    2012-08-27 09:03 PM