1. casrenski's Avatar
    I'm stuck in recovery loop. I'm just looking for any way to get any firmware iOS restore completed. My 3GS new bootrom had iPad BB working but I wanted to do factory restore and downgrade BB to remove iPad BB (so I could give it away).

    I tried to update with stock ipsw (oops) then tried redSn0w baseband downgrade and jailbreak (that was probably stupid too) as it was already in recovery loop.

    Now after discovering iOS5 doesn't want Cydia's SHSH blobs and iOS6 doesn't want tinyumbrella's TSS service (gimme a break, it's been a while since JailBreakMe came out), I'm finally on the right track and patching my ipsw files but not getting anywhere.

    my iOS6.1.2 redsn0w and 6.1.3sn0wbreeze custom firmwares (preserving BB) are failing with error 160x in iTunes (they were failing with 21 but i discovered thats related to DFU/recover mode).

    I have tried recovery fixes from redsn0w iFaith iREB and tinyumbrella but no luck.

    Any help or advice greatly received.
    2013-06-11 11:46 AM
  2. EVO's Avatar
    you may have probably toasted the baseband

    3Gs that contain the new baseband are not compatible with the iPad baseband, which may probably explain the errors you are experiencing when trying to restore.

    Just to give you a little more knowledgeable information, when you are on the ipad baseband, you dont restore it to a stock firmware, you let redsn0w downgrade the ipad baseband back down to 05.13.04.

    Since iOS 6.0 was released, you cannot restore back to an older iOS 6.0.x firmware unless you saved the SHSH blobs directly from the Apple server "when" the iOS you are trying to restore to was still available to restore.

    What you need to do is use the latest iFaith to verify if the "shsh blobs", which hopefully you saved, are valid. It will tell you if they are, and if they are valid, and you encounter the itunes errors, you pretty much have a brick as a phone.

    If the blobs are not valid, then you can try searching your computer to see if you may have saved any older iOS shsh blobs and see if you can create a custom firmware via sn0wbreeze to restore back to.
    2013-06-12 06:11 AM
  3. casrenski's Avatar
    Solved! I'm just syncing everything now, with some errors on some apps, but generally going very well!
    Thanks for all the help and insights. I had done the I faith verification also, but had trying everything as I wasn't getting anywhere.
    All I ended up doing was a stock 6.1.3 restore on a vanilla (one i hadnt stuffed around in the registry and hosts files) Win7 PC with iTunes

    So as a case study, I'm useless, as I was so random in my approach and didn't follow many procedures as I was learning along the way, but key take-always:
    - 3GS with ipad bb (newer bootrom)
    - attempted stock restore to 613
    - attempted jailbreak to remove ipad baseband
    - lots more fails
    - attempted stock restore to 613 on a 'fresh' PC and am no syncing.

    Also of note, I got some water damage immediately prior to this saga and wifi status in settings.app was 'no wifi' (ie. not on/off toggle) and now the toggle is greyed out, so still no wifi. It's not possible at this stage to establish whether that was water damage, but I do know that the wifi status has not changed since before ipad baseband downgrade/removal was attempted (ie. it had no effect).
    2013-06-12 08:52 AM