1. karanbindal's Avatar

    It's been weeks i replaced my iPhone's Battery and after the repair it wasn't charging and the WiFi toggle was showing "NO WIFI" in the Settings Menu. So i decided to restore my iPhone. At that time I was on iOS 4.1 also jailbroken with the iPad Baseband. After the unsuccessful restore to iOS 5, I think so. It got stuck in the Re-Boot Loop.

    Re-Boot Loop - The iPhone boots and then it processes and then goes off and starts booting again!
    Like there is no firmware installed on the phone.

    Also my iPhone runs directly on electricity now.

    After few days, I tried again and this time I thought of restoring to iOS 6.1.2 and my iTunes showed me "iPhone could not be restored. The device isn't eligible for requested build". Then i found a fix for that to edit the hosts file and remove all the "gs.apple.com". But still it wasn't working for me.

    Also then I tried to go back to iOS 4.1 using the latest redsn0w by creating the baseband prevention and also by stitching the blobs. iTunes gave me Error (20). Then after i found the fix for this and it was to downgrade your iTunes to 10.4.1. I downgraded it and then it wasn't being able to connect to the Apple's Server.

    So finally tried again with iOS 6.1.2 and it gave me the same error.

    Now I am using:

    iPhone 3GS (Old BR)
    MacBook Pro 13 inch Mid 2010
    Mac OS X Mavericks DP 8
    iTunes 11.1 Beta

    Please help me with the reboot , also i rely on a unlock
    It's an O2 iPhone.

    Also is there anyway i could go back to iOS 3.1.3?

    Please message me for any screenshots or other details reqd.!!
    2013-09-17 12:54 PM