1. twl's Avatar

    Thought someone else may find this helpful. I have several iPhone 3GS, latest one is new bootrom xx227 and works perfectly.

    Bought it for $20 and wouldn't boot. Eventually got it on 6.1.3 but me being me, I couldn't leave well enough alone and did a Redsn0w tethered jailbreak. Hated the tethered part so attempted to put fresh copy of 6.1.3 on it. Well, took two weeks to make it usable again.

    Had baseband messed up, wouldn't go into recovery mode so Redsn0w functions kept "waiting for reboot". A disaster for sure, even took it to a trusted independent iPhone repair place that I have used before. For $40 they would unbrick it but eventually they gave up.

    Long story short, I discovered that by letting the 3GS run out completely, when I connected it to a PC, it wasn't recognized by the computer and showed the low battery screen. I eventually realized that I could still put it into DFU mode and then iTunes recognized it.

    Instead of stopping at 20% iTunes restore (or just rebooting before actually starting the restore), my $20 3GS seemed very receptive to an iTunes restore and after the 2nd attempt, is currently restoring a backup from my beatup (old bootrom) 3GS.

    I would recommend leaving it attached to the PC that you do the restore on until it boots up normally. Since it was "low battery" to enable the restore, I had to wait 20 minutes for it to boot up normally.

    I searched a million sites looking for a solution to not being able to fix this iPhone but have yet to see anyone else recommend trying a restore when in low battery mode.

    If you have a 3GS that you thought was bricked, try this and see if you can replicate my results.

    2013-09-21 08:37 PM
  2. twl's Avatar
    Update: Nothing is ever as easy as it first appears.

    Have "successfully" restore 6.1.3 onto my 3GS. All looks good. Get initial setup screen. Have tried restoring (4 hrs) once and as a new iPhone twice but inevitably, it reboots and is stuck at apple logo.

    Seems like when it is restoring that it's updating the baseband (firmware) but it's still not right.

    This 4th restore, I told it to setup as a new iPhone and when it was doing the initial backup, I got an iTunes message about a passcode. First time I have seen that message. Am running Gecko toolkit now to see if it can extract anything. I am not convinced that this is the problem.

    Any ideas or suggestions? I feel like I am very close but can't quite get it right.

    2013-09-22 09:28 PM