1. billchase2's Avatar
    Could someone come up with a simple app that will disable the "unknown device" message that pops up when you plug in some 3rd party devices? I'm sure you know the one I'm talking about. It asks if you want to put it in airplane mode. I need this disabled because that message screws up my AV cable. Everything works fine and dandy until that window pops up. After that, my iPhone no longer sends the video signal to the TV, just the audio. If I were able to get this message disabled, my AV cable would work perfectly. Besides, the message isn't really necessary anyway.

    Anyone up for it? It'd be greatly appreciated.
    21.5" iMac 3.06 GHz Intel Core i3 l 15" MacBook Pro 2.2 GHz Intel Core i7 l 17" PowerBook 1.67 GHz
    iPhone 4 32 GB l  TV 160 GB l 32 GB iPad
    2008-07-22 06:16 PM
  2. gwestend's Avatar
    Could someone come up with a simple app that will disable the "unknown device" message that pops up when you plug in some 3rd party devices? I'm sure you know the one I'm talking about. It asks if you want to put it in airplane mode. I need this disabled because that message screws up my AV cable. Everything works fine and dandy until that window pops up. After that, my iPhone no longer sends the video signal to the TV, just the audio. If I were able to get this message disabled, my AV cable would work perfectly. Besides, the message isn't really necessary anyway.

    Anyone up for it? It'd be greatly appreciated.
    I too am looking for the answer to your message. In addition, I would like to know why these 3rd party devices will not charge my iPhone 3G?
    2008-07-22 08:27 PM
  3. backlife's Avatar
    MY iphone says that stupid message when i plug it into the factory dock and my car

    disable this damn message please
    2008-07-26 02:33 AM
  4. jerry69's Avatar
    im sure many are looking for this
    i am too..

    seems simple enough but im not a coder
    2008-07-28 02:47 AM
  5. Michael-Leo's Avatar
    Hi!
    I really need somebody to make this happen, i just bought a 3rd party AV-Cable to my Iphone 3G, and well like everybody else, it doesnt work!, but is it really that simple,
    to just disable the message?, i mean the problem is in the cable, accually the Chip in the Cable, doesnt this mean that its a hardware problem and not a software problem, which in that case should make it easy for a coder to fix it?
    2008-10-02 10:11 PM
  6. billchase2's Avatar
    Any updates to this? I'm now on firmware 2.1 and am still having the exact same problem. If we could disable this message, I have a feeling the 3rd party AV cables would work again. My reasoning behind that is because my cable works perfectly (video and everything) until the message pops up. After that, no more video.
    21.5" iMac 3.06 GHz Intel Core i3 l 15" MacBook Pro 2.2 GHz Intel Core i7 l 17" PowerBook 1.67 GHz
    iPhone 4 32 GB l  TV 160 GB l 32 GB iPad
    2008-10-14 07:18 AM
  7. evolutionarymc's Avatar
    I have searched very thoroughly for a solution to this problem. I found a thread on another forum that said to erase an apd file, it totally jacked my phone up. There has to be a dev that can edit that file so that it disables that message. Mine does it randomly throghout the day without any devices even plugged in. It is constantly turning my speaker off. I even messaged saurik and was unaware of any easy solution. I am willing to cough up some dough to whoever can fix this.
    2008-10-14 03:29 PM
  8. billchase2's Avatar
    I have searched very thoroughly for a solution to this problem. I found a thread on another forum that said to erase an apd file, it totally jacked my phone up. There has to be a dev that can edit that file so that it disables that message. Mine does it randomly throghout the day without any devices even plugged in. It is constantly turning my speaker off. I even messaged saurik and was unaware of any easy solution. I am willing to cough up some dough to whoever can fix this.
    wow, yeah you'd think that it wouldn't be that hard to disable this message. where did you read about the apd file? perhaps they have some sort of update?
    21.5" iMac 3.06 GHz Intel Core i3 l 15" MacBook Pro 2.2 GHz Intel Core i7 l 17" PowerBook 1.67 GHz
    iPhone 4 32 GB l  TV 160 GB l 32 GB iPad
    2008-10-20 06:35 PM
  9. Tizocman's Avatar
    if This Is Found Please PM Me How
    2008-10-22 09:21 AM
  10. billchase2's Avatar
    any updates to this yet?

    evolutionarymc, do you remember where you read about the apd file?
    21.5" iMac 3.06 GHz Intel Core i3 l 15" MacBook Pro 2.2 GHz Intel Core i7 l 17" PowerBook 1.67 GHz
    iPhone 4 32 GB l  TV 160 GB l 32 GB iPad
    2008-11-03 05:45 PM
  11. hartphoto's Avatar
    Maybe this is what y'all are looking for?

    Note that I've not tried this. I got my phone replaced under warranty a couple of months ago for this problem. It was a bad dock connector in my case. The 'This accessory is not made to work with iPhone' error message started off 'every now and then' and progressed to almost being constant over a period of a couple of months. No amount of restores, cleaning, etc. etc. fixed it.

    Also, it's not about just deleting the file. You have to replace the file with a modified version.

    Mac Forums - View Single Post - iPhone Dock gives "This accessory is not made to work with iPhone" error

    Full version (in Italian, use Google to translate):

    .: Suondmao's World - iPhone iapd Reverse Engineering :.

    Oh....be sure to back up the original file in case you need to revert back to it!

    HTH.
    Last edited by hartphoto; 2008-11-03 at 06:23 PM. Reason: clarity
    2008-11-03 06:20 PM
  12. billchase2's Avatar
    i'll give it a try later today when i'm home and will post the results.

    thanks for the info!
    21.5" iMac 3.06 GHz Intel Core i3 l 15" MacBook Pro 2.2 GHz Intel Core i7 l 17" PowerBook 1.67 GHz
    iPhone 4 32 GB l  TV 160 GB l 32 GB iPad
    2008-11-04 06:58 PM
  13. billchase2's Avatar
    With the new apps like TVOut and ScreenSplitr coming out, I thought I'd finally try out this "fix" for the "Unknown Device" message.

    I followed the instructions and upon restart, my composite cable no longer worked at all. The iPhone didn't see it at all. So... back to the drawing board, I guess.

    Has anyone figured this out yet?
    21.5" iMac 3.06 GHz Intel Core i3 l 15" MacBook Pro 2.2 GHz Intel Core i7 l 17" PowerBook 1.67 GHz
    iPhone 4 32 GB l  TV 160 GB l 32 GB iPad
    2009-01-20 08:43 PM
  14. fekz's Avatar
    Just don't buy any 3rd party cables at this point, they will not work. I know it sucks that apples is the only option. I'd rather go without than spend 50 bucks on a damn cable..
    2009-02-01 02:59 AM
  15. Cocchiararo's Avatar
    i would love not to get this message with my a2dp adapter (since freaking apple denies me a2dp in this music phone.... )
    2009-02-24 01:44 AM
LINK TO POST COPIED TO CLIPBOARD