1. jecarr33's Avatar
    Hey All....

    Heres the issue I'm having, hopefully someone has a fix for this or knows of something thats on its way but let me get to the specifics.

    I have a Pioneer DEH-7000BT head unit in my truck. The head unit is Bluetooth capable...I use it for handsfree all the time. I have no issues with pairing my iphone to the handsfree feature of the head unit. Once it pairs, it works awesome and it holds the pair, so that everytime i get in my truck and start it up, the phone automatically pairs and I'm good to go. The head unit also is A2DP capable, here is where it gets kind of sketchy.

    When I used to have an iPhone 3G (jailbroken of course) I had an app that came from Cydia called "iBluetooth" I believe. When this app was on my phone all of my audio apps (pandora, ipod, etc...etc..) would stream to my head unit via A2DP bluetooth protocol....this would also pair everytime i got in my truck, and the pairing would lock in and hold. This all worked GREAT prior to iOS 3.0. Once I upgraded to iOS 3.0 iBluetooth wasn't supported any longer. (at least I think it was this iOS version when it stopped working....initially). This meant I could no longer stream music to my head unit any longer even though I was still able to utilize hands free....

    I figured it was just a bug and would soon be resolved, but to this day still has not been resolved. I am now on an iPhone 4 (4.3.1 jailbroken of course)and iBluetooth wasn't even supported by the iPhone 4's nor do I think it was ever updated to work....I'll have to check back in to see if it works now.

    I don't know if there are several different types of A2DP protocols, or whatever the case may be but A2DP connections now will pair to my head unit, it works fine but the problem is, the A2DP pair does not STICK. I mean, I have to erase the head unit from the phone and go back through the pairing process after everytime I turn my vehicle off. This gets very frustrating.

    Does anybody know of a way to MAKE THIS PAIR STICK? Or, does anyone know how to create an app that supports every SINGLE TYPE of A2DP protocol? It's weird that it used to work flawlessly and once i upgraded to iOS 3.0 and ever since has never worked again. Does Apple have its own proprietary version of A2DP? Please help!!!

    Best Regards and thanks in advance!

    I am on aim if anyone has additional questions or whatever: j3cdnb


    For an extremely in depth log of this issue, please read this:


    It is EXACTLY my issue....and it looks likes others as well....I know there are some extremely smart people here.....
    Last edited by jecarr33; 2011-05-07 at 04:49 AM. Reason: Automerged Doublepost
    2011-05-07 04:49 AM