1. Duff8402's Avatar
    I do "moto-vlogging" from time to time. I have a cradle setup on the handlebars of my motorcycle and use the camera on my iPhone4 to record video...and have been just using the stock iPhone ear buds for the microphone. I also have a ScalaRider G4 bluetooth headset in my motorcycle helmet. I'm looking for a way if there is one, and someone to develop if not, for the camera app to use audio input from my bluetooth headset rather than having to deal with the headphones wire flopping around in front of my face. Anybody have any ideas, whether or not this is even possible?
    2012-01-10 08:53 PM
  2. Duff8402's Avatar
    Would be happy to donate/compensate for time if someone thinks they are capable of coding this?
    2012-01-11 06:20 PM
  3. Duff8402's Avatar
    One more bump, then I'll let the thread die.
    2012-01-15 01:21 AM
  4. Gerneio's Avatar
    I believe your looking for a tweak called Bluetooth mono... It's in cydia... Just pair your BT headset with your iPhone, turn on BT mono via SB settings, then play your music and the sound should come out to through your headset, hope this helped

    Edit: I think I might have miss interpreted what you said, but nevertheless try it and see if it works
    2012-01-16 09:38 AM
  5. Duff8402's Avatar
    I found that app in a google search prior to posting this thread. Unfortunately it doesn't seem to be very stable. As soon as I enable it my phone starts running like an old first gen iPhone and the video app crashes after about a three minute attempt of opening. Once I disable the tweak, springboard crashes.
    2012-01-16 12:22 PM
  6. Gerneio's Avatar
    Hmmm weird I've never had a problem with it like that before
    2012-01-16 06:33 PM
  7. Duff8402's Avatar
    Maybe if I try reinstalling... What hardware/firmware are you using?
    2012-01-16 06:40 PM
  8. Duff8402's Avatar
    Reinstall got same results from iPhone4 on 5.0.1
    2012-01-16 09:24 PM
  9. Gerneio's Avatar
    Tried it on my 3GS 5.0.1, and it lagged the crap out of my iPhone's frame rates when I turned it on ... I guess it just doesnt support iOS 5 yet... It worked perfect for, 4.3.3
    2012-01-17 04:41 AM
  10. Duff8402's Avatar
    Thanks for the input, I'll see if I can contact the developer about this now that I know that it once worked.
    2012-01-17 05:01 AM
  11. Duff8402's Avatar
    Bluetooth Mono SBSettings Toggle- Listen to music through ANY Bluetooth Headset - MacRumors Forums

    Found the developer, but needs some "support" to continue developing!
    2012-01-26 05:41 AM
  12. Duff8402's Avatar
    This works on iOS 5 now!
    2012-03-04 01:04 AM
  13. Gerneio's Avatar
    Sweet, too bad I'm not jailbroken any more
    2012-03-04 04:37 AM
  14. Bo Troxell's Avatar
    Sweet, too bad I'm not jailbroken any more
    Plenty of tools out there now to jailbreak before Apple releases 5.1, just sayin'.
    smaller sig.png
    2012-03-04 04:47 AM
  15. Gerneio's Avatar
    Plenty of tools out there now to jailbreak before Apple releases 5.1, just sayin'.
    Lol that's not the problem, it's just that it screwed up my first 4s so Im gonna wait a bit
    2012-03-04 04:56 AM
  16. Bo Troxell's Avatar
    Not trying to talk you into it, just that their are millions of iDevices that are jailbroke. Pretty safe.
    smaller sig.png
    2012-03-04 05:05 AM
  17. CEO_Logic787's Avatar
    This works on iOS 5 now!
    Are you on 5.0 or another... 5.x... I'm curious because I am about to download this bluetooth app for iphone 4 ios 5.0.1... I was looking for the same thing and I tried it before in the past and got the same results with the slow frame rate... How is the tweak working out for you since you've had it???
    2012-03-16 11:06 PM
  18. Duff8402's Avatar
    I'm on 5.0.1 and it works great. Only trouble I've had, is if I use the "auto bluetooth on/off" option when turning BTMono on and off. It crashes springboard when I use that, so I just don't use it and it works perfectly
    2012-03-17 03:18 AM
  19. Gerneio's Avatar
    I'm on 5.0.1 and it works great. Only trouble I've had, is if I use the "auto bluetooth on/off" option when turning BTMono on and off. It crashes springboard when I use that, so I just don't use it and it works perfectly
    Never knew it had that option o.O woulda been useful lol
    2012-03-17 09:01 AM
LINK TO POST COPIED TO CLIPBOARD