View Poll Results: Has installing an app from Mobile App Store crashed your iPhone, requiring a restore?

56. You may not vote on this poll
  • Yes!!!

    39 69.64%
  • No.

    10 17.86%
  • No, but had to restore because of other 3G ~ F/W2.0 bugs!

    3 5.36%
  • No, my iPhone 3G ~ F/W2.0 has always worked perfectly!

    4 7.14%
  1. m021478's Avatar
    I cannot believe how damn oftem my freakin' iPhone the point where I have to put the thing into DFU mode and restore from an old backup...This has happened at least 5 or 6 times since I purchased the 3G iPhone about a week and a half ago...

    I've found that I have about a 50/50 chance of successfully installing a free or purchased app from the Mobile App Store...and if I happen to get the $#it end of the stick and it doesn't successfully install, it simply crashes my iPhone and then hangs on the Apple Logo of the boot screen (which is my cue that my only option is place my iPhone in DFU mode and restore from an old backup)....

    Just curious, has this happened to you too? How Often? Anyone figure out a workaround to allow use of the mobile app store while avoiding such a crash? Can you believe that there isn't already a freakin' fix out for this issue? I mean, if its happening to me, its bound to be happening to thousands and thousands of other people as well...

    Any other thoughts?
    2008-07-30 05:55 PM
  2. bbplayer5's Avatar
    Yup. Not with every app, but some.
    2008-07-30 07:52 PM
  3. m021478's Avatar
    I don't suppose you've been able to determine what app has been a troublemaker for you in the past?

    I've found that I typically won't crash-and-burn if I do absolutely nothing at all while installing an app from the mobile app store...literally nothing...I put the phone on the table and come walk away, and 20 minutes later once it's finished installing a 1MB application (ridiculous indeed), then things are typically fine and dandy...

    ...but if I do things (open program, preference, ipod, phone, etc...) while its installing an app, then I've typically had to restore because it decided it didn't like that very much and responded by dying...
    2008-07-30 10:49 PM
  4. einsteinx2's Avatar
    Hey guys, I registered just to post this. I had the same thing happen. I thought I was going to have to restore as well, but I got it to work. The first time it happened, after the pineapple logo sat there for a while, I plugged it into my computer (not in DFU mode, I just left the pineapple logo there and plugged in) and magically the main screen popped up. Then the second time it happened, I just pressed the home button a couple times and it worked. You might want to try that out the next time it happens.

    I have had some (not all for some reason) of my app store apps stop working randomly (I think after installing some cydia apps but I don't remember) and I had to reinstall those apps to get them working again. Don't know why it happened, but at least I didn't have to restore.
    2008-07-30 11:06 PM
  5. Dan0609's Avatar
    yupp lmao. I re-installed ap news app and when the app store takes you home to prepare for installation it simply restarted the iPhone 3G (white) and never started again just got stuck on the apple logo. ;P Its a wonderful 3 hour restore... But hey I have my old iPhone so I still can supress my anger with apple by playing lol

    2008-07-31 05:37 AM
  6. techyogi's Avatar
    apparently issues like this are know to apple, as after the 7th time in a week it happened to me, apple support told me to go to an apple store genius bar... of course there was a 3-day wait at the time, so i walked in and took my chances as my wife was getting an iphone the net day anyway, so i waited with her, and when i got in walked over to see what they could do. they had a super-secret special iphone 3g accelerated queue, where i skipped the line and was in in 30 minutes! they apparently are trying to get those of us with new 3g iphones accelerated support, so they know there are problems, but it's a softare problem ( my guess) as they replaced my iphone with a new out of box one and it still does the same thing twice a week - crap shoot depending on what i am doing, and i did NOT pwn this one - still crashes.... my take is the iphone 2.0 itself has bugs, but otherwise works pretty well, but they need to do a way better job blessing appstore apps. at least with the jailbreak/installer community, we know it's an "at your own risk" deal, but some of the stuff on the appstore is just pathetically unstable. still trying to figure out which.
    2008-07-31 03:16 PM
  7. Dan0609's Avatar
    yea by the way Im going to apple tomorrow as my phone crashed again and endelssly showed me apples logo for the third time. I cant take my chances with the 3G as the phone is critical to me. Im hopefully going to get it solved or Im switching to my Edge iPhone for a while as its the most stable with NO crashes.

    OK It locked up on me 2 of the 3 times when I opened up the app store on my iPhone via WiFi while nothing else was running i.e. nothing installing/loading/running and the appstore basically froze and than the whole iPhone flashes and sits on the apple logo.
    Last edited by Dan0609; 2008-08-01 at 04:45 AM. Reason: addon

    2008-08-01 03:57 AM
  8. peteo's Avatar
    My iPhone 3g has been very unstable when installing apps. I have had to restore my first 3G iphone at around 3 times. I am now on my second iPhone after a visit to the apple store. Restored this iPhone around 4 times! I've been trying to figure out whats been going on. When I first install apps directly onto the iPhone with the iPhone app store every thing flys and works great. Then after a while installs start to take longer and longer some more than 20 minutes and then soon my iPhone will just reboot and hang at the apple logo, never gets to the springboard causing me to have to restore my iPhone.

    After testing a bunch of things I think I've found the problem. I restored my iPhone, set it up as a new phone in itunes and only synced my contacts and safari book marks. On the iPhone I started to install apps. Apps installed fast, most taking about 20-30 seconds to install after the blue line reaches the end. I installed about 8 apps, then I installed Texas Hold'em . This took a while to install about 5 minutes. The size of the game 128mb is really big compared to the other apps in the store. After installing, I installed a small app an it took about a minute and half to install, seemed slow so I installed another small app took around 3 minutes to install. It seemed like the installs where slowing down. So I uninstalled those 2 apps and Texas Hold'em. I reinstalled the two apps. Each took around 20-30 seconds to install. So then I tried this with super monkey ball its size 35 mb. The install took about 4 minutes. I installed another small app took about minute and 20 seconds, next app about 3 minutes. Each app I installed after this increased in time, taking long and longer. I uninstalled super monkey ball and all the apps I installed after and reinstalled the small apps. Eeach one took no longer than 20-30 seconds.
    There seems to be something wrong when large apps are installed with the iPhone apps store.
    2008-08-01 04:08 PM
  9. zendj's Avatar
    Im having similar issues and seems to be solely caused by the apps, with 1.1.4 I always felt I could restart the phone and sort any issues out, with 2.0 its one chance then crash and restore, ive also had the same problem with some Cydia apps.

    I really hope this is software based and Apple sorts it with a update.
    2008-08-01 06:41 PM
  10. Dan0609's Avatar
    Yea update. I went to apple (International Mall). They DID replace my iPhone 3G. I asked if they had any knowledge of the next fw update... Of course they didnt lol. But they say everyone is coming in with there phones saying they lock up. So iDk apple needs to drop a new update soon because Im seriously considering switching back to my 1st gen as the 3G is too unreliable.

    2008-08-03 04:26 AM
  11. tyfly867's Avatar
    I justet it be while it's downloading/installing and I have never had of crash on me *knock on wood*

    sorry for the bad English I meant never has crashed on me.
    Last edited by tyfly867; 2008-08-03 at 05:25 AM. Reason: Automerged Doublepost
    2008-08-03 05:25 AM
  12. iphoneguy2007's Avatar
    For what it's worth, I'm going to chime in as well. I've experienced systemic crashes while installing new apps via AppStore and Cydia, though these are less frequent than they had been in the past. I'll confirm what a poster wrote above, in that installation was really sluggish if I had one of the larger apps installed. If i had super monkey ball, brain challenge and texas hold'em, (easy > 225MB combined), then the next install was a crap shoot, even though Cydia apparently moves apps out of the 500MB partition (I believe this is the case--can anyone confirm)? I've also used BossTools to move Fonts, Apps and Ringtones.
    2008-08-04 01:12 AM
  13. einsteinx2's Avatar
    even though Cydia apparently moves apps out of the 500MB partition (I believe this is the case--can anyone confirm)?
    Yes Cydia moved the App folder to the larger partition and sym-links it. I know this because when I first installed BossTool, everything but the fonts had already been moved over, so I can only assume Cydia did it. Also once when I was installing an app with Cydia I got a low space warning and then it went away. I think it moves the app folder when it runs out of space.
    2008-08-04 02:49 PM
  14. tsunami78's Avatar
    After upgrading my original first generation iphone to the 2.0 firmware, I experienced the same issue. When installing apps from the mobile appstore, my phone would reboot to the apple logo and never come back. I pressed many a button to no avail, and left it plugged into my laptop overnight just hoping that it would come back up eventually. It did not. This happened about 7 times in a week. I finally took it to the Apple store to see if they could help. They told me they had never heard of the problem, but gave me a refurbished phone assuming that it was a hardware problem. Well, the next day, the new phone did the exact same thing.

    Long story short, I got so frustrated, I went back to the apple store and spoke to a manager. They were very helpful, and spent several hours with me doing testing. I was able to reproduce the problem for them on that phone as well as another service model. They then said that it must be an unknown issue with the first generation phone, so they gave me an upgrade to the 3g model.

    Well, I'm now on my 3g phone (wishing I'd kept my original phone) and I'm still having the same issue. It does not only happen when installing applications from the appstore. I have also had it crash on my a few times when just running an appstore application.

    This has happened with 2.0 and 2.01, both pwned and stock. It MUST be a software issue, because it has followed multiple phones. I have used multiple computers to setup and sync the iphones and that did not make a difference either.

    Luckily, I rarely leave the house without my laptop. My phone has taken a dive on me several times when I was on the road, and if I had not been able to restore my phone in the field, I would have been screwed...

    Of all of the problems with the 2.0/3g release... this is by far the most problematic for me. I really feel this has made my once beloved iphone completely undependable. So far, I have been unable to keep my iphone alive for more than a week unless I simply don't install appstore applications.

    Last edited by tsunami78; 2008-08-14 at 06:16 PM.
    Happily hacking my iPhone since 1.0

    Don't forget, it is polite to say Thank you!
    2008-08-14 06:14 PM
  15. newbay's Avatar
    hey all. I found this thread from a google search and signed up for a good old rant.

    I've had an ongoing problem with my iphone crashing during apps installation and then a never ending apple logo when i reboot. This is the 4th time. on the previous 3 occasions i have been able to bypass the logo through a series of turning the phone on/off, plugging in/out the usb, starting/closing itunes and other general pandemonium over a period of 1-3 hours per crash. as my iphone has once again done it and it's 1am and i have work tomorrow, i'm thinking about putting it in the drawer for a few months until someone fixes this problem, and putting my sim back into my 6120.

    the iphone is a very fun device, but unfortunately it fails at the first hurdle of business phones - reliability. safari constantly crashes for me, the 3g drops out often and my contacts list takes up to 1 minute to load. how anyone could use this device as anything more than a novelty is perplexing.
    2008-08-23 07:51 PM
  16. Dan0609's Avatar
    honestly... from 2.0.1 and 2.0.2 I have had to do -> 0 ZERO 0 <- restores. and NO reboots or freezes at all. I think anyone not updated is only fooling yourselves. Especially windows users. We can jailbreak every firmware so far.

    2008-08-25 05:53 AM
  17. iphoneguy2007's Avatar
    Just an update and some additional thoughts. I upgraded to 2.0.1 and hadn't seen this problems in about 2 weeks. However, this weekend, this happened 2x, where I'm installing an app via the appstore (both time while connected to my laptop). Sometime during the install, the process dies and I get the endless reboot cycle where I only see the apple logo in perpetuity. I was at the point of going in via iLiberty to force it into recovery mode an do a full restore, but I've customized my phone and installed a lot of j/b apps, so i didn't want to have to recreate everything in what would have been a multiple hour process. So, I SSH'd into the iphone, went into the applications directory and deleted the app that i had been trying to install. Then, i did reset the phone again by pressing the on/off and home buttons simultaneously. Both times, the iphone came back, thankfully. I still suspect the endless reboot cycle reflects some corruption in the springboard plist during the install process ... so, i think, by deleting the offending app, it allows the iphone to boot successfully. Hope this helps others!

    Okay, another quick update. I have a new rule of thumb that seems to be working. I've installed a few apps in three separate sessions since writing the last entry, a total of over 350mb of apps, without any crashes. Seems that the trick of the day that seems to be working is to do a reboot before installing any apps. The installatino process then proceeds quite quickly.
    Last edited by iphoneguy2007; 2008-08-25 at 07:27 AM. Reason: Automerged Doublepost
    2008-08-25 07:27 AM
  18.'s Avatar
    strange i am having te same problem do u know why?
    probably the last version..
    humm such a nice device and brand for this errors ... well i hope they fix them quickly
    2008-08-31 02:45 AM
  19. tamakin's Avatar
    It's probably the apps that you guys are installing that's making your phone crash and burn. I know not to install apps like Kate because it messes up the iphone. Which apps from the app store are you guys downloading? One of those apps has to be the culprit.
    2008-09-07 11:54 AM