User Tag List

  1. MattTibby's Avatar

    I have been using Apple iPhone apps and unlocked apps from Cydia for a little while now and everything has been going great, but all of a sudden my Apple iPhone apps won't work. The main apps and Cydia apps work fine, but now the other ones won't work. I recently installed Customize 2.0, but that does not seem to be it.

    It happened after I upgraded a few apps from the App Store through my iphone. They just all open up and start to load, but then they just shut down. I have tried a few things, but nothing is working. I have tested a few apps by removing them and then reloading them, but that still does not work.

    Please help!
    2008-08-02 05:29 AM
  2. hobo's Avatar
    Same thing happened to me last night. It had happened to a friend of mine on his 1st Gen using 2.0 firmware too. I googled around for it and it seems to be a common problem.

    One thread here suggested downloading something so you have to re-enter your iTunes credentials. I did this via some updates and now 80% of my apps are working... except the two I care about, Pandora and Facebook. Haven't tried to delete and reinstall yet, but I'd rather not bother with a restore. I hope Apple addresses this sometime soon as I couldn't find an official word on it.

    EDIT: Deleted and re-installed facebook and it works correctly
    Last edited by hobo; 2008-08-02 at 08:55 PM.
    2008-08-02 12:23 PM
  3. MattTibby's Avatar
    Thanks. I got it working for a little while this morningwhen I downloaded a new app, but then later that night my apps stopped working again. Anybody know what this could be?

    Well, I think I fixed the problem. It does have something to do with iTunes Credinatials, but first I had to reset all my settings. I had to do it twice in two days. I hope this doesn't continue to happen.
    Last edited by MattTibby; 2008-08-03 at 07:01 PM. Reason: Automerged Doublepost
    2008-08-03 07:01 PM
  4. smooky's Avatar
    I have this bug-a-boo now too. I did a restore. And once I enter the AppStore it opens all my paid apps (some, not all exactly!) and starts to download them all.

    I believe this started for me when I purchased "Diamond Twister" and the iphone crashed.

    Each time it reloads and tries to re-install "Diamond Twister" my iphone crashes again.

    Is there a way to delete an app before it downloads and installs?
    I think if I can prevent Diamond Twister from downloading and installing I can get past this.
    But, I've not found a wait to delete an app before it installs, but it never installs.. it crashes... ARRRRGH.
    Last edited by smooky; 2008-08-04 at 02:43 PM.
    2008-08-04 02:40 PM
  5. MattTibby's Avatar
    First, I would recommend that not doing a total restore. All I had to do was reset my settings. That way it does not delete any of my main information or apps.

    Then you can just download a problem and it should fix your iTunes account, which for some reason gets corrupted. I found out what cause this on my iPhone. Whenever I download an update from my iPhone, my iTunes credentials (or account information) gets corrupted. So I will not be doing that many more. It's pretty stupid the so many people are having problems, but Apple hasn't done anything about it yet. Hopefully, the new updated with help.

    When you load "Diamond Twister," are you installing it from your iPhone or iTunes on your computer. I know you can stop installing the app if it is installing from iTunes (just click the little "x" near the sync screen). On the iPhone, I'm not so sure.

    Hope that helps a little.
    2008-08-04 04:05 PM
  6. fredbotton's Avatar
    After upgrading to 2.0.1, Diamond Twister seems to mess up my iphone 3G. It keep trying to download from AppStore, crashing after 15 minutes and rebooting. I can't install anything else, the queue is occupied by Diamond Twister.
    I have restored to wipe out everything on my iPhone. Even though I've deleted Diamond Twister from the library/apps and from Devices/iPhone/apps tab, it keeps coming back as soon as I get into AppStore from the iPhone to download other apps!
    Is there a way to prevent it from being restored? Or isa way to stop the process of an application being installed? It's really getting on my nerves.
    I have to add I've not pwned nor cydia'd, everything I have on the device has been paid. But I now wish I had never bought that bloody Diamond Twister
    2008-08-12 12:55 AM
  7. Roamerick's Avatar
    Thanks. I got it working for a little while this morningwhen I downloaded a new app, but then later that night my apps stopped working again. Anybody know what this could be?

    Well, I think I fixed the problem. It does have something to do with iTunes Credinatials, but first I had to reset all my settings. I had to do it twice in two days. I hope this doesn't continue to happen.
    OK I'm on my fifth restore now due to the same problem. Can you PLEASE detail exactly what you did to get your apps working again? Reset your settings, do you mean on the phone?

    2008-08-13 02:26 PM
  8. rudeviant's Avatar
    Same deal here I installed and uninstalled intelliscreen and all my apps stopped working. Even tried to reinstall them through the phone , through the computer. All my apps just start booting up,close and go back to the standard phone menu screen.
    2008-08-14 11:14 AM
  9. Roamerick's Avatar
    Reading the MacRumors forums, it seems as if it's looking more and more like an iTunes 7.0.1 problem. Apple is aware and working on it, blah blah blah... Let's hope they fix it soon because it's getting REALLY tiresome.

    For the time being, the only answer is NOT to sync with iTunes. At all. Ever.
    2008-08-14 02:36 PM
  10. ohssoccer2's Avatar
    I have same problem for Remote and simply media. On remote it keeps on trying to connect to my MacBook and it doesn't work. I get to the screen where I enter my passcode thing and after that it just keeps trying to connect. And also on Simplify Media I get stuck on Connecting to Libraries. I am on a jailbroken first gen 2.0.1 iphone.
    2008-08-15 05:27 PM
  11. organik's Avatar
    Got this problem too - any easy soultions yet?
    2008-08-16 05:31 AM
  12. MattTibby's Avatar
    I thought I had figured out the problem, but for the past week I have had to restore my iphone everyday and then it works for about a day and then my Apple Apps don't work again. I think it has something to do with iTunes 7.7.1. I have been trying to downgrade to 7.7.0, but I cannot find the mac version. Does any one know where I can download the old version. I hope apple fixes this problem soon.
    2008-08-18 01:58 PM
  13. Hyperextension's Avatar
    I think I may have a solution. So far anyways. I had the same problem. After a day or 2 all my App Store apps would stop working. Everything else would work except them.

    I went into the folder on my computer where all the app .ipa files are and noticed something strange. I have 59 apps, but there was nearly 100 files in there. I guess when you do an update, it keeps the original file and downloads a new one. For instance, if you have the Files app, you will have a file called "Files.ipa". If there is an update to this app, it will download a new file and call it "Files-1.ipa" and so on and so on.

    I deleted everything and then re-downloaded my apps and everything works fine. I am going nearly 4 days without the past problem. So now, when an update is available, I will completely delete the original file and then download the new one.

    This really sucks and the problems with the Apps stopping caused me to restore 3 times and waste a lot of time. Something Apple should look into I think, if this is in fact the cause.
    2008-08-18 02:57 PM
  14. MattTibby's Avatar
    I found a solution to my problem and it seems to happen to a lot of people. If all your iTunes Store Apps and you cannot play music on your iPhone that should be there, then it probably has something to do with authentication and something that went Apple messed up in iTunes 7.7.1. All you have to do is downgrade to iTunes 7.7.0 and delete some files. Below I have copied what I found on some other website on what to do. You just have to find iTunes 7.7.0. Let me know if you cannot find it and then I will try to find a link for it. Also, I did not restore my iphone because I had it working before I did this. But if it is not working then you will have to restore. Hope this works for you.

    One word about backups. I have learned that itunes does the backups in the user/application support/mobilesync/backups folder. So, if you get a good backup in a stable condition you can go in there and duplicate that folder. If you just leave it alone it will get corrupted by the next failed backup. Dup it and you at least have somewhere solid to go if you need to rebuild again.
    1) went into the phone and do a reset and erase
    2) deleted the following support files:

    (user)/Library/iTunes/Device Suport (the entire folder)

    3) deleted the itunes app itself.
    4) restarted computer
    5) emptied trash
    6) installed iTunes 7.7
    7) attached iphone and when prompted to set up the phone, i forced the phone into DFU mode (not recovery mode - slightly different)
    8) allowed phone to restore to 2.0.1 (this may take a loooooong time).
    9) set up phone as a new phone. down with the backups!
    10) installed some apps, and some music. the installations were a little clumsy but worked alright.
    2008-08-25 04:23 PM
  15. Roamerick's Avatar
    Your solution was posted at Ars Technica a few days ago - and it's not a fail-safe fix.

    Apple has actually started resolving their issue at their end - if you experience the problem, simply report the issue through iTunes and they'll fix your account. They did it for me, and now everything works fine, syncs and all. See my other thread on the issue.
    2008-08-25 04:58 PM
  16. alexbutterfield's Avatar
    I'm also having this problem.

    I believe the apps are crashing after i sync the iphone for the first time after a download.

    i only sync for podcasts - i wish there was an app store version of the mobilecast i used to use before updating.

    does anyone have an actual fix for this yet? something easy? i dont like going around deleting files, and i cant be doing with another restore it takes forever to transfer my music.

    just as i type, i deleted and re-downloaded facebook app using the phone and it works again. but i cant do that with 20 apps after every sync
    2008-08-27 12:52 AM
  17. spam_artist's Avatar
    hi, not sure if this was somewhere else, but i was able to revive my apps by:
    1. Plugging in my iphone to my computer
    2. in iTunes go to: Store > Deauthorize Computer... (put in credentials)
    3. Store > Authorize Computer... (put in credentials)
    4. Sync your iphone

    voila! enjoy! please remember to hit 'Thanks' if you found this helpful.
    2008-08-27 05:52 AM
  18. Roamerick's Avatar
    There is a fix. Report your issue to Apple, and they'll fix your account. There's another thread here about this.
    2008-08-27 09:23 AM
  19. n00bix's Avatar
    how do u report it to apple?
    2008-09-06 04:02 AM
  20. Eurisko's Avatar
    There is a fix. Report your issue to Apple, and they'll fix your account. There's another thread here about this.
    How? The iTunes feedback option? Or is there something more direct?
    Get "iPod & iTunes for Dummies", it'll change your life.
    2008-09-06 04:29 AM
26 12

Tags for this Thread