1. kofman13's Avatar
    Do all the new 2.0 firm ware apps in appstore, like all those new neat games... do they REQUIRE iphone 3g? do they work on first generation?
    2008-09-05 03:06 PM
  2. DoerrFan's Avatar
    They work on the first gen.
    2008-09-06 02:18 AM
  3. JazJon's Avatar
    From what I've read, both the new 3G iphone and old original iphone have the same speed processor. The screens are nearly the same as well. All the apps / games will "run" on both. The only apps that wouldnt function 100% are ones that require the GPS location ability that only the 3G iphone has build in. You would also noticed the older iphone is much slower when it comes to streaming music or downloading updates. 3G is obviously much faster then EDGE. They both have wifi though so if you're at home totally good to go for high speed action.
    2008-09-08 02:16 AM
  4. bhz1's Avatar
    just like to add that for the same apps to run on a 1st gen iPhone, it needs to be on 2.x firmware. If it's on 1.1.x firmware the newer apps and so store apps will not work.

    just like to add that for the same apps to run on a 1st gen iPhone, it needs to be on 2.x firmware. If it's on 1.1.x firmware the newer apps and app store apps will not work.
    Last edited by bhz1; 2008-09-08 at 04:31 AM. Reason: Automerged Doublepost
    2008-09-08 04:31 AM
  5. thetoothfairy's Avatar
    I have both the 1st gen iPhone and 3G here and I have the apps on both phones.... I updated the 1st to the 2.0 to be able to use the app store....

    Now just get the bugs out of itunies and I will be all set... LOL
    2008-09-08 05:45 AM
LINK TO POST COPIED TO CLIPBOARD