1. deadringer's Avatar
    I have an iPhone 2g. Two days ago my app store started acting weird. The category pages and features pages would just spin on loading and never load. Then today I started getting failed to connect to app store please connec to itunes. I connected to itunes and it asked me to review new TOU and I did that. I also synched my iphone from itunes with a new app that I downloded throgh itunes.

    Here are things I know for sure.

    1)Password for itunes/appstore is ok cause I can login on my PC
    2)Network connection is fine as I can get stocks wether and Safari among other network capable apps to load.
    3) This is a wifi only device I do not use it for any other connection type.

    Is the fact that I have not updated to 2.2.1 having any affect on my ability to use the app store through my iphone. I currently have 2.2 loaded and broke with quickpwn.

    Any ideas on how to get the app store functioning again without losing my current settings?

    The other thing I can say for sure is that I did use an active SIM in this device last Friday but I have used the appstroe since then witout issue. Now I put the SIM back in and the app store is working with the SIM but does not appear to be working on Wifi. I am going to try and take that SIM out now and startup without a SIM in at all and just try the Wifi again alone.
    Last edited by deadringer; 2009-02-18 at 04:34 PM. Reason: Automerged Doublepost
    2009-02-18 04:31 PM
  2. Simtech's Avatar
    Nothing is wrong with the app store, used it this morning and I'm on 2.2
    So, it has to be your phone / sim card / wifi issue.
    2009-02-18 04:37 PM
  3. deadringer's Avatar
    Ok so after I put the SIM back in and removed it I shutdown the iphone and brought it back up with no SIM. I then enabled WiFi again and the app store is indeed working again. Then I tried it again a few minutes later and it is stuck on loading again. Very frsutrating.

    I hope someone has an idea

    After a shutdown and startup with my original SIM with no service the appstore worked. I exit out of it and go back in and again it sits on loading. I switch to updates (says no updates) then back to top 25 and they load. Then exit try to load again and nothing. This si crazy.
    Last edited by deadringer; 2009-02-18 at 05:04 PM. Reason: Automerged Doublepost
    2009-02-18 05:04 PM
  4. musick's Avatar
    I actually started having the same exact problem today. I cannot load the app store at all. It says "loading" for about 2 minutes and then kicks back "cannot retrieve download information, please connect to itunes" dismiss, then: itunes app store could not be reached.

    I've done a hard reset, etc.

    Update: while typing this I turned off WiFi and it connected straight to the app store with 3G.

    Weird..I think my WiFi was causing it, but I was loading safari, mail.app, etc fine under WiFi...

    weird..
    2009-02-18 08:21 PM
  5. redcard's Avatar
    Can't you just act like men and restore your phones?
    To live, you have to lie
    2009-02-18 08:24 PM
  6. Miro89's Avatar
    same problem here. for 3 days now i try to open the appstore, it just either keeps ok loading and never opens or tells me cannot connect to itunes.
    2009-02-18 08:40 PM
  7. JStraitiff's Avatar
    are you on the internet?

    that seems to be one thing that people miss

    otherwise it could be a router issue
    2009-02-18 08:58 PM
  8. TheOrioles33's Avatar
    Mine wouldnt let me on when I installed and activated the UserAgentFaker. Deactivated and it worked.
    2009-02-22 03:34 AM
  9. aussiebob's Avatar
    Must be your phones.
    I use the app sniper daily and sometimes three or four times to see new apps on itunes store and download frequently.
    My signiture? Whats that...............
    2009-02-22 03:55 AM
LINK TO POST COPIED TO CLIPBOARD