1. wiltok's Avatar
    "This application requires the Iphone 3.1.2 Software Update"

    Running a jailbroken 3G on 3.0.1 and getting this error a lot on appstore apps. I'm not a developer so maybe its legit but it would seem that it would make sense to make most apps backwards compatible to cover the largest audience. The conspiracy theorist in me wonders if big brother (apple) is causing this to happen or forcing developers to code only for the latest release.
    2010-01-01 02:45 PM
  2. confucious's Avatar
    Of course they are.
    Just use Pwnage to upgrade to 3.12
    He who asks a question looks foolish for 5 minutes. He who doesn't ask a question remains foolish forever.
    2010-01-01 02:54 PM
  3. wiltok's Avatar
    Unfortunately I don't have a Mac and I prefer not to upgrade due to the reports of battery and other issues. Also, my phone is set-up exactly how I want - don't really feel like starting over. Thanks tho - none of the apps I wanted are deal breakers but just 'nice to haves...'
    2010-01-01 04:02 PM
  4. confucious's Avatar
    There is an app in cydia that allows you to change the reported FW - but I've forgotten what it's called!
    He who asks a question looks foolish for 5 minutes. He who doesn't ask a question remains foolish forever.
    2010-01-01 04:18 PM
  5. wiltok's Avatar
    Just looked - it's called FW Changer. Thanks for the lead!
    2010-01-01 05:31 PM
  6. omitted's Avatar
    let me know how that works out, i installed it but it only gives me option fot FW 2.0 and not 3.1.2
    2010-01-01 06:54 PM
  7. wiltok's Avatar
    After reading about so many people having problems with it - I decided to forget it. As this problem becomes more widespread, maybe someone will figure out another fix (besides FW changer).

    As a follow-up to my own question, why is Apple so concerned about having everyone on the latest release. This approach is costing them revenue - it really doesn't make any sense.
    Last edited by wiltok; 2010-01-02 at 02:07 PM. Reason: Automerged Doublepost
    2010-01-02 02:07 PM
  8. confucious's Avatar
    The latest FW includes all the latest security patches. Apple want people to be secure.
    2010-01-02 02:21 PM
  9. buzios's Avatar
    After reading about so many people having problems with it - I decided to forget it. As this problem becomes more widespread, maybe someone will figure out another fix (besides FW changer).

    As a follow-up to my own question, why is Apple so concerned about having everyone on the latest release. This approach is costing them revenue - it really doesn't make any sense.
    Apple is not responsible for the minimum OS version that an app is compiled for. The developer chooses the minimum OS version supported.
    With the latest SDK release for Snow Leopard Apple removed support for 2.x except 2.2.1. Developers using Snow Leopard can compile their apps for 2.2.1 or above.

    There are a few new APIs in 3.1.2 and if the app use new API the developer has no choice.

    I am a developer and have a few apps in the AppStore. Up to now all my apps have been compiled for 2.x firmware. I have now decided that new releases will be compiled for 3.x. I am just tired of having to keep a bunch of phones with different firmwares for testing.
    2010-01-05 10:28 PM
  10. soulthoughts's Avatar
    You could also download the app without your phone being connected. Find where the ipa is. To do that right click on it in iTunes and choose get info.

    Once you find the ipa,unzip it. In the unzipped files there's a plist that's called info.plist. Use a plist editor (google it) to open it.

    In this plist there's a key and string that says:

    <key>MinimumOSVersion</key>
    <string>2.2.1</string>

    In this example the string says 2.2.1. Change that to your firmware and save. Now zip all the files back up and change the extension to .ipa and you're done. That should do away with the warnings. However, as someone mentioned, this may not work well because of APIs for the newer firmwares.
    2010-01-06 08:32 PM
  11. confucious's Avatar
    ^ That really isn't a good idea
    He who asks a question looks foolish for 5 minutes. He who doesn't ask a question remains foolish forever.
    2010-01-06 09:09 PM
  12. soulthoughts's Avatar
    It may or may not be a good idea but it's worked for me in the past when I didn't want to upgrade my FW for whatever reason. It did no harm and the only time it didn't work was when there was a FW dependent API.
    2010-01-07 01:38 AM
LINK TO POST COPIED TO CLIPBOARD