1. Mes's Avatar
    This is crazy I know. Today I woke up and found the delete button (trash icon) available when viewing an email message no longer works!! The other buttons (refresh, move to folder, reply/forward, write) function like expected --- it's just the trash icon (delete button) that stopped working. I checked my other accounts (3 others 2ea POP, 2ea IMAP) and sure enough, delete doesn't work either. I can 'delete all' from the trash folder and delete individual selected messages. So everything isn't broken Reboot/respring doesn't help. I haven't added or upgraded anything in about a week or so. It definitely worked yesterday!!

    If I must, I'll delete all the mail accounts and re-enter again --- and then take the final restore plunge. But all-this seems like a huge overkill.

    Any suggestions?

    3G, FW3.1.2, 4.26.xxBB + ultrasn0w T-Mobile USA
    2010-07-08 04:43 AM
  2. Cer0's Avatar
    And it isn't a dead spot in the touch screen? Just asking.
    [CENTER][SIGPIC][/SIGPIC][/CENTER]
    2010-07-08 04:49 AM
  3. Mes's Avatar
    And it isn't a dead spot in the touch screen? Just asking.
    Didn't think about that . (Boy I must getting old (aka younger)

    But no, it's not a dead spot. The Photo and Calendar app have buttons in exactly the same place. Not sure if it matters, but the Trash icon is 'highlighted' when I press it, but nothing else happens.

    SOLUTION: I used WinSCP to check /private/var/mobile/library/Mail permissions and ownership. Ownership was set correctly (mobile:mobile) and all of the file permissions were set to 744. The directories were set to 740 (no read access for others). So I recursively set everything to 744 and it worked. Granting read access to others fixed it? Crazy Mail.app I know but it's working now.
    Last edited by Mes; 2010-07-08 at 05:27 AM. Reason: Solution (I hope)
    2010-07-08 04:57 AM
LINK TO POST COPIED TO CLIPBOARD