User Tag List

  1. Westside86's Avatar
    Every time I try to download app from app store on my iphone 4 I get a message saying unable to download application and to download using iTunes on my computer. This occurs both on 3G and on wifi and has only started happening this past week. Is there any way to fix this without deleting all my apps? Many thanks in advance.
    2010-09-08 03:22 PM
  2. soulthoughts's Avatar
    The appstore a lot of times will 'force' you to use your computer to download large apps. It won't let you do it on your phone. I'm not sure there's a way around it.
    2010-09-08 04:42 PM
  3. Westside86's Avatar
    Hi thanks for reply however it is every app I try and I have tried many with small file size. Also I have tried using wifi which I believe allows u to download the larger apps straight to device.
    2010-09-08 04:49 PM
  4. soulthoughts's Avatar
    Can you download and sync apps on your computer?
    2010-09-08 05:08 PM
  5. Westside86's Avatar
    Yes I can it is only on my device I can't download apps which is a major inconvenience as I rarely use my computer. Thanks
    2010-09-08 05:19 PM
  6. smeeshum's Avatar
    This has started happening to me, did you ever fix it? I cannot download or upgrade a single app using my iPhones Appstore any more :-(
    Last edited by smeeshum; 2010-09-23 at 01:02 AM.
    2010-09-22 11:35 PM
  7. Darien222's Avatar
    same here on my 3Gs 4.0.1 just started happening out of nowhere :-(
    2010-09-30 06:43 AM
  8. Cer0's Avatar
    download something on your desktop itunes. A change to the terms of serice came out and that may be the hold up. It should pop up on the desktop when you try to download or update an app.
    2010-09-30 07:17 AM
  9. Darien222's Avatar
    don't think that is the issue since I have downloaded from actual Itunes already and still this crap persists
    2010-09-30 05:30 PM
  10. danielgindi's Avatar
    I too have this problem!

    I can be 99% sure this happened after manually installing a .deb package with the terminal. Though uninstalling it did not help.

    No there's no way to install ANY app or upgrade on the iPhone itself.

    Anyone has found a way out?

    Does anybody know if there's a log file somewhere for the app store?
    2010-10-06 10:47 AM
  11. smeeshum's Avatar
    Still happening to me here! I refuse to restore as I'm waiting for the new jailbreak. Downloading Apps from iTunes on my PC then using a network share to get the iPA to my iPhone it will then install with **********. It's a long winded process but let's me download apps on the move until a new JB is released
    Last edited by Cer0; 2010-10-07 at 01:14 AM.
    2010-10-06 06:17 PM
  12. danielgindi's Avatar
    Actually you do not need **********. You only need to download in iTunes, then sync to your iPhone.

    I tried full backup & restore through iTunes, it did not solve the problem. Actually it did not even unjailbreak me! all cydia apps stayed where they are with their current settings.
    Last edited by Cer0; 2010-10-07 at 01:13 AM.
    2010-10-06 06:24 PM
  13. smeeshum's Avatar
    Actually you do not need Installaous. You only need to download in iTunes, then sync to your iPhone.

    I tried full backup & restore through iTunes, it did not solve the problem. Actually it did not even unjailbreak me! all cydia apps stayed where they are with their current settings.
    You need to use it if you are not at your machine.

    When I am away from my machine I use VNC to use iTunes to download.

    I then transfer the iPA to my device using a clever collection of ZumoCast and iFile.

    Then I install the signed iPA using **********.

    It's a dirty fix but stops me having to restore for now.
    Last edited by Cer0; 2010-10-07 at 01:13 AM.
    2010-10-06 07:58 PM
  14. Cer0's Avatar
    PLease don't go around our filters. They are there for a reason.
    2010-10-07 01:14 AM
  15. Macusercom's Avatar
    I have the same problem now. Can download and install on the Mac but not on the iPhone. iTunes App for music can't do it too!?

    I made a reset of the settings and deleted itunesstored in var/mobile/ I'm trying to restore an old backup :S

    @danielgindi did you install EnhancedTabs?

    Had the same problem after a restore, but I found the solution via Apple and it helped!:
    I first recommend that you review, and make any necessary corrections to your account information. To do this, follow these easy steps:

    1) Sign out of the iTunes Store by choosing Sign Out from the Store menu in iTunes.

    2) Visit the My Apple ID website at:

    3) If the site is not displayed in your preferred language, click the Change Language link in the upper-right corner, type the name of your language in the field that appears, then click the Save button.

    4) Click the "Manage your account" link.

    5) Type your iTunes Store account name (which is your Apple ID) in the Apple ID field, type your password in the password field, then click the Sign In button.

    6) Click "Addresses" in the column on the left. Look at your shipping addresses at the bottom. If you have multiple shipping addresses, remove any out-of-date or duplicate addresses by clicking Delete. Also, make sure the state or province field is filled out correctly for each address. To edit an address, click Edit.

    7) Now click "Phone Numbers" on the left. The area codes should be in the area code fields and the phone numbers should be in the phone number fields. If an area code is missing, or if it is in a phone number field, your account information may not save properly.

    8) Make any other necessary corrections, then click the Save Changes button.

    9) Click Log out in the upper-right corner.

    When you make your next iTunes Store purchase, you will be asked to review your billing information. At that point, you can change your information or simply click Done. After that, you should be able to purchase items.

    Once your account information has been verified and if necessary, updated, sync your iPhone to your computer. This will help to ensure that your iPhone is also using your updated account information. Once the sync has completed, safely remove your iPhone and try once again.
    Last edited by Macusercom; 2010-10-08 at 12:43 AM. Reason: Automerged Doublepost
    2010-10-08 12:43 AM
  16. danielgindi's Avatar
    I did not install EnhancedTabs...

    I tried all that, reconfigured my iTunes account many times, logged out and in, nada.

    What finally fixed it two days ago, was upgrading to 4.1. :-) Which by the way is much slower, but at least fixes those nasty bugs.
    2010-10-15 12:58 PM
  17. cookie181992's Avatar
    i'm having this problem on my ipod touch 4 (4.1) any known fix?
    2010-12-02 06:02 PM
  18. iavrtx's Avatar
    Same issue since about 4 days ago. iPhone 3GS at firmware 4.0.
    Popup tells me to login to the iTunes store on my computer and the app will become available. After logging into the store and pressing 'check for available downloads' in iTunes it finds the apps I tried to install and downloads them to iTunes.
    When I go back to the phone and try to install the app again, or any other app, it fails with the same message. I cannot install apps via the App store application.
    Any insight would be appreciated.
    2010-12-15 11:17 PM
  19. str8up80's Avatar
    I have the same problem on iphone 4 4.1 was working fine and just stoped working suddenly
    2010-12-22 04:52 AM
  20. iavrtx's Avatar
    Has anyone that is experiencing this problem also have the "StayOpened" tweak installed from Cydia?
    It's the only app that I recently installed that modifies the AppStore app.
    2011-01-03 04:41 AM
30 12