1. mizzgiz's Avatar
    i am trying to download the ebay app from the itunes app store. it keeps saying i need to upgrade to ios 4.0 for me to get it. but that is BS, because i just had the updated ebay app working on my iphone yesterday on my ios 3.1.3.

    what happened was my phone messed up and i had to completely wipe it clean. then i had to re-jailbreak.

    so when i went to re-download ebay, it's giving me this 4.0 ios nonsense. when clearly just yesterday i obviously did not need ios 4, since i had ios 3.1.3 and ebay worked fine. probably because i already had it downloaded before they made that "rule".

    to say ebay needs ios 4.0 now is a lie. obviously apple is trying to force people to upgrade for whatever reason and it's annoying. because when i had 4.0 it completely slowed my phone down. obviously i want to stay at ios 3.1.3.

    is there any way to get around this and have my ebay app installed without upgrading?? i tried to do it on the computer through itunes but still no luck.
    mod edit/links removed
    2011-06-12 11:43 PM
  2. Jahooba's Avatar
    Just upgrade already. Download the IPSW from the internet, NOT the iTunes auto-download (A simple Google search will find it for you). Then hold Shift and press the Restore button, then select the IPSW you just downloaded.

    It's far better to troubleshoot an updated phone than to reverse-engineer an app to work with your OS. This will just keep happening to you as developers update their apps for the latest OS. Just stop fighting it.
    2011-06-13 01:50 AM
  3. Turnamental's Avatar
    +1 Here buddy.... 3.1.3 Sucks

    It's time to go up to say like 4.2.1

    You on Tmobile or something other than AT&T?
    iPhone 4S iOS 5.0 Non JB
    ~OSx Lion 10.7.2 Hackintosh Pro Dual Boot Win7 @ 4.5GHz
    Rock River AR-15 5.56mm NATO
    ~9mm S&W Sigma
    We carry iPhones and guns here in Texas
    2011-06-13 01:54 AM
  4. Stray's Avatar
    What happens if its a 3G? iOS 4 runs horribly on it.
    2011-06-13 02:40 AM
  5. mizzgiz's Avatar
    i have at&t and i have a 3g. i clearly stated i do NOT want to upgrade. i have done it before and it was horribly slow, i experienced crashes and freeze ups constantly. ios 3.1.3 works beautifully for my phone. why ruin a good thing when clearly the most updated version of ebay worked perfectly fine yesterday. apple is just trying to force people to upgrade by limiting the downloads now to 4.0 only. i had no problem before because i had already had ebay before they started doing the "4.0 only" rule.

    all i wanted to know if there was a way around this to get the ebay app without upgrading.

    it has nothing to do with me "fighting anything". i don't want a brick for a phone. and that's pretty much what the ios 4 did to it before.
    mod edit/links removed
    2011-06-13 04:46 AM
  6. 306Designs's Avatar
    Agreed. With ios5 on the way, now is the time to do the upgrade and learn how to do it so that you can do it in the fall easily.
    2011-06-13 06:02 AM
LINK TO POST COPIED TO CLIPBOARD