1. rdfisch's Avatar
    The Optimum App (on app store -works for Optimum Cable/Internet TV Customers only) is a nice app - lets you watch live cable TV & control all cable boxes in house when on home WiFi net - woohoo.

    Worked fine two days ago, now when you try to log in, you get a message that you are running an unauthorized modified version of Apple Operating System (sic). It does let you browse TV listings anyway, but not control or watch anything.

    At first I thought it was my upgrade from v2.0 to v2.0.1, so I deleted the app on my phone, deleted the .ipa on my computer, restored the 2.0 app from the trash and synched. Still get the message. App reports v2.0 now so I am wondering if there is some kind of config file or cookie-like file I missed, or if Optimum could be doing this from their servers now regardless of version.
    Last edited by rdfisch; 2011-10-24 at 09:43 PM. Reason: Update title to reflect not neccesarly solved
    2011-09-21 04:10 PM
  2. Diddyoh's Avatar
    same thing happened to me yesterday. I love the app but i'm not willing to lose JB just to use it. is there any way around this?
    2011-09-21 07:09 PM
  3. chino54's Avatar
    Hey guys.. sorry for this but yes this is comething that CV is doing from our end its not on the devices adn it doesnt matter tyhe version you got.. i work with them and this is pissing me off too.. is tehre something one of the hackers here or developers here can do about this?? like an app that trick it into thinking your IOS is not JB??
    2011-09-21 07:24 PM
  4. RGee's Avatar
    yeah anyone?
    2011-09-22 02:12 AM
  5. rdfisch's Avatar
    According to the thread referenced below, the Time Warner app does the same thing, but an app available on Cydia bypassed the check. I did a Cydia search but couldn't find anything.

    New Optimum App not working on jailbroken Iphone 4 | iPhone and iPad Forums

    So if its happening on the cablevision side, nobody JB should be able to run it.

    How about version 1 ? I was thinking of downgrading just to get DVR control back.

    Is anyone able to run ANY version on a JB device ? (and if you can DON'T UPGRADE) !
    Last edited by rdfisch; 2011-09-22 at 03:00 PM.
    2011-09-22 02:57 PM
  6. eazstream's Avatar
    anyone thanks
    2011-09-23 12:37 AM
  7. eazstream's Avatar
    got it working.. please see below
    -------------------------------------
    I got this working on the iPad. The issue is the iPad executable is different from the iPhone executable. After installing the .deb file you have to edit /Library/MobileSubstrate/DynamicLibraries/Optimum.plist change the quoted value to Optimum.

    replace CVCrDVR with Optimum,
    2011-09-23 03:53 PM
  8. chino54's Avatar
    hi sorry but i could not find that file on my iphone 4 i find the folder but not the optimum.plist, i am using ifile to do this or are you using something else?? thank you.
    2011-09-23 07:44 PM
  9. rdfisch's Avatar
    OP here and I've got my Optimum App / JB problem solved. I found the solution description (including source for transparency) now at "foreign" thread I referenced earlier:

    New Optimum App not working on jailbroken Iphone 4 | Page 2 | iPhone and iPad Forums

    Summary: Download fixOptimum.deb and install it.

    That by itself worked for me - apparently if you are on iPad, you need to edit the .plist as detailed above by eazstream.
    Last edited by rdfisch; 2011-09-23 at 08:41 PM.
    2011-09-23 08:00 PM
  10. ZanEl's Avatar
    Is there any chance you could break down the ipad fix step by step? I downloaded ifile trial version but i cant figure out how to edit the plist from cvcdvr to optimum?
    2011-09-24 05:38 PM
  11. rdfisch's Avatar
    First you've got to find/download the fixOptimum.deb file (link in other thread mentioned above). Then install it (you can google how to install .deb to iphone, many options (including youtube instructions), I did it as follows:

    1) SSH into phone, and move fixOptimum.deb file to /var/root/Media/Cydia/AutoInstall.
    2) Power down phone.
    3) Restart phone.
    4) Power down phone AGAIN.
    5) Restart AGAIN.
    6) Possible need to respring now, but I didn't need to.

    I cannot confirm this because I do not own an iPad, but if you do apparently this additional step is needed:

    7) Edit the file /Library/MobileSubstrate/DynamicLibraries/Optimum.plist ... replace the text "CVCrDVR" with "Optimum", and save.
    (I did this by using FileZilla to SSH to /Library/MobileSubstrate/DynamicLibraries/ and right click on Optimum.plist, choose edit)
    8) I don't know if a reboot is needed now.

    That should do it. If this helped, please click Thanks !
    2011-09-24 10:20 PM
  12. RRoD420's Avatar
    using a patch for the jailbreak detection and a vpn patch, i'm able to connect to my house over vpn and watch live tv from anywhere. If anyone wants it, reply to this thread. I'll post megaupload links to my patches and instructions. Even works awesome over 3G

    instead of ssh, use ifunbox and transfer the .deb to \tmp or whatever folder. then get iFile from cydia nad use that to install it. @rdfisch is correct, you need to edit the optimum.plist file on ipad, iphone doesn't need it because it has the correct app name.
    2011-09-30 10:10 PM
  13. rdfisch's Avatar
    I'd love to see how to do this over vpn ... thanks!
    2011-09-30 10:57 PM
  14. RRoD420's Avatar
    ::edit::
    New thread with tutorial.
    Last edited by RRoD420; 2011-10-01 at 06:18 AM.
    2011-10-01 02:44 AM
  15. Nycodelay's Avatar
    I'd like to see that too
    2011-10-07 05:25 AM
  16. RRoD420's Avatar
    I'd like to see that too
    I posted a tutorial, let me know if you need help.
    http://modmyi.com/forums/apple-appst...your-home.html
    2011-10-07 06:38 AM
  17. moveandstore's Avatar
    Cablevision's move sucked. They have updated to version 2.0.2. I haven't updated. I just used the safari downloader and ifile and the .deb file worked perfectly.
    2011-10-12 05:00 PM
  18. RRoD420's Avatar
    2.0.1 stopped working and new 2.0.2 detects jb again. Where are the experts??
    2011-10-13 02:30 AM
  19. moveandstore's Avatar
    It stopped working now. It is forcing us to update to 2.0.2. I tried reinstalling but the old .deb file wouldn't work. We need a new file. Optimum sucks! Like a JB phone is going to make a difference. You are a PAYING Cablevision subscriber, so what difference does it make? It's not like you are getting it for free.
    2011-10-13 02:42 AM
  20. RGee's Avatar
    yeah someone has a working fix for 2.0.2?
    2011-10-13 04:44 AM
25 12
LINK TO POST COPIED TO CLIPBOARD