1. LilKCCeleb's Avatar
    Well I updated to 5.0.1 finally on my iPad today and enabled multitouch gestures through redsn0w. Installed Time Warner TV app and it brought up the jailbreak detection even after installing xCon. Restored and didn't enable multitouch and it works now.
    2012-02-09 05:25 AM
  2. iraqgsm's Avatar
    The repo works now got my directv again, dev you are great man almost un jailbroken mine thanks a million
    2012-02-09 05:28 AM
  3. ragermac's Avatar
    Ok I installed WAMP on my windows box (google it). Downloaded that XML file (http://asws.dtvce.com/ASWSHeadend/ws...gator/1/ipad/2) and put it here on my PC:
    C: \wamp\www\ASWSHeadend\ws\appconfig\navigator\1\ipa d I edited the file in Notepad++ and changed verMin and verCurrent to 1.3.5 (because that is the last version of the app I have that was backed up).

    In my router which runs DD-WRT I went to the Services tab and under DNSMasq which is set to Enable and also Local DNS Enable, I pasted this in Additional DNSMasq Options:
    alias=,, 0
    (Just replace the 192.168 address with the IP of YOUR local webserver) The 99.193 address is asws.dtvce.com.
    - I know this isn't the best way but it was just a quick and dirty test.

    Now on the ipad under wifi settings I changed the DNS server to the IP address of my router running DD-WRT. Now when the DirecTV iPad app logs in it is redirected to MY webserver and pulls my modified file and logs in! The guide works, however on the home tab the currently watching pane says "Searching for Receiver" Live TV Streaming pane is blank and the "What's Hot" pane is Loading... So it's not 100% but its some progress! Perhaps there are more resources on asws.dtvce.com that I need to bring in onto my server. I'd have to have an unjailbroken ipad with the app and do a wireshark traffic analysis to see what other resources it's pulling in. Unfortunately I don't have an unjailbroken ipad. Maybe I can see what it's trying to request on this version on my jailbroken ipad.

    If anyone else has a better way or other solution feel free to add on this or work on this solution. I'm sure if you don't have DD-WRT you could edit the hosts file on the ipad (/etc/hosts) to point asws.dtvce.com to your local webserver. Or heck someone could create a public webserver that is always available 24/7 on the internet. All we would need is the IP address to put in the hosts file.

    I'm sure this is just the beginning but I bet we could expand on this solution for DirecTV for iPad.

    Thank you for this, I need some help though, I installed WAMP and put the the xml in the folder and pasted the address info in DD-WRT, is that all that I have to do in WAMP? Do I need to do anything in the program itself, I have never set up a web server before.

    I also pointed the iPad to address of the pc that has WAMP installed and I tried the app and it works but I am not sure if it is pointing at the web server because everything is showing as it sure, unlike what you said with "searching for receiver being blank and all".
    2012-02-09 01:39 PM
  4. iraqgsm's Avatar
    Did you tried xcon 17 add http://n00neimp0rtant.dyndns.org/repo to ur cydia sources and download xcon if you want to bypass the jailbroken protection
    Thanks n00neimp0rtant you are awesome
    2012-02-09 09:30 PM
  5. jlluna's Avatar
    I just had a message to update my Xcode. Updated, and direct tv app now working. Thank you!
    2012-02-09 09:50 PM
  6. beavis71cox's Avatar
    Updated to xcon 17. Cox app loads, but says "video unavailable. So I restored to stock 5.0.1 and the app worked fine. Re-jailbroke with absinthe, and it still says "video unavailable". I have an iPad 2 Verizon.
    2012-02-10 05:31 PM
  7. crisbig's Avatar
    Would it be possible to have an Xcon update to fix the new "Good for enterprise" release 1.9.7 ?
    The Xcon 17 looks to be ineffective after the 1.9.7 has been released....:-(
    2012-02-11 12:51 PM
  8. amrod69's Avatar
    does anyone know if they directv app checks your ip for location?

    I pay for directv and am in Canada and cant seem to get it working... I tried to use a VPN on my ipad but the directv app blocks it
    2012-02-12 09:30 PM
  9. bobbynj81's Avatar
    Well version 17 doesn't work for optimum or good for enterprise. Instead of optimum just shutting down though, it now displays a message saying that I'm running a modified version of the apple operating system. Good for enterprise has never worked for me. It simply will not sync.
    2012-02-13 03:14 PM
  10. RRoD420's Avatar
    Xcon17 still working with optimum today, you prob dont have latest xcon. Update the repo.
    2012-02-13 04:15 PM
  11. rawmx's Avatar
    does anyone have a copy of the source code???
    2012-02-13 08:59 PM
  12. stlblufan's Avatar
    Any chance that xCon could support MobileIron?

    2012-02-14 10:19 PM
  13. cprimous's Avatar
    Ok prog84, thanks for these instructions. I am getting a bit confused about the Fiddler aspect. I have entered the URL to be redirected and the local URL of my server. However, what do I point my proxy settings to on the iPad? Fiddler is running on the same server as WAMP. WAMP is running on port 8081 so it doesn't conflict with other stuff running on this box. I have an entry in autoresponder tab to redirect the URL "http://asws.dtvce.com/ASWSHeadend/ws/appconfig/navigator/1/ipad/2" to "http://<localserver IP>:8081/ASWSHeadend/ws/appconfig/navigator/1/ipad/2". What I am not clear about is what port fiddler runs on, and what to set on the iPad proxy settings. Thanks!

    EDIT: Ok, two things, first of all, I think I found in fiddler where to modify the port - under tools -> fiddler options -> connections tab. However, I still can't get it to work. So now I need to ensure I have WAMP set up right. Does the redirect point to the full path with the .xml extension? Also, how does the iPad work with everything else if I have the proxy set up? I can't seem to get ANY internet which leads me to believe I still have something set wrong there too.
    NOTE: for those using the Fiddler method: You don't need to bother installing WAMP or any other webserver to get this to work. Fiddler can redirect the request to a directory on your computer. When setting up the Autoresponder, instead of selecting a web address, select "find a file" and just point to the downloaded 2.xml file. Mac users can do the same basic thing with a proxy app like Charles (not free, but trial).
    2012-02-15 02:34 AM
  14. cypherstream's Avatar
    cprimous, good point. I tried the fiddler method and just pointed it to my web server. I didn't realize it could host up a file itself.

    Maybe the dev would just build this into xcon so it's all self-contained into the ipad. That way he can KEEP 1.3.9 working and when DirecTV forces and update, it buys him some time without so many people emailing, PM'ing or tweeting him about DirecTV.
    2012-02-15 04:33 AM
  15. hall316's Avatar
    Wish I could get my directv app working again. It's not the end of the world as I'd much rather have my iPad jailbroken. Why is it that the app on my iPhone that's jailbroken doesn't check, but the iPad version does?

    EDIT: never mind, it's working. Thanks!
    Last edited by hall316; 2012-02-15 at 05:46 PM.
    2012-02-15 05:38 PM
  16. ccuento's Avatar
    Any updates on xcon working for Cox TV direct?
    2012-02-16 05:28 AM
  17. GolfDude's Avatar
    xcon 18 is out and directv is working on my jailbroken setup again!.. optimum as well
    2012-02-16 12:55 PM
  18. computerdude16's Avatar
    I just updated to xCon 18 and I still can't get the Flixster app to work. It does attempt to load the movie but it says I have a poor internet connection. I know that isn't true because it streamed just fine (some buffering, but not an issue) before my iPhone was jailbroken. I've tried renaming Cyida.app to Bydia.app but that didn't help at all. Any ideas?
    I know what a jailbreak is... lol
    2012-02-16 10:59 PM
  19. woolfman72's Avatar
    I added the repo and go to install xcon 18 and get a size mismatch error. Anyone else have this issue?

    Had to use ifunbox and move the deb from the temp file to the install folder in cydia and that worked.. Direct tv app is working like a charm!

    thank you thank you thank you!
    Last edited by woolfman72; 2012-02-17 at 03:04 AM.
    2012-02-17 02:41 AM
  20. BryanW's Avatar
    I added the repo and go to install xcon 18 and get a size mismatch error. Anyone else have this issue?

    Had to use ifunbox and move the deb from the temp file to the install folder in cydia and that worked.. Direct tv app is working like a charm!

    thank you thank you thank you!
    Had the same problem... xCon is at 18 in the MMi repo. Remove n00nimp0rtant repo, and refresh. Update using the MMi xCon.
    2012-02-17 08:54 PM
829 ... 5131415161725 ...