• Jailbreak for 10.2 released

    Well after loads of speculation - this morning we wake up to the newest present from Luca Todesco - a Yalu IPA Jailbreak tool for iOS 10.2 (includes 10.0.x and 10.1.x. But it's for a VERY LIMITED Phone set. ONLY the 6S, 6SPlus, SE and iPad Pro are included as of this launch.

    Unlike the buggier JB for 10.1.1 which included the above phones plus 7/7Plus this semi-tethered IPA tool, installable with Cydia Impactor, has Mobile Substrate included and fully working according to Luca and other early testers.

    I thought there may likely be some uniqueness to this JB - so I figured a new thread was warranted. Those of you who've made the jump - please tell us how it's going!

    yalu.qwertyoruiop.com

    Since I only own a 6 and a 7Plus, I won't be able to do test early. As soon as it becomes available for iPhone 6 - I'll move my 6 from 9.3.3 to help out.
    This article was originally published in forum thread: Jailbreak for 10.2 released started by NewD View original post
    Comments 641 Comments
    1. bbrks's Avatar
      bbrks -
      Quote Originally Posted by bakmie02 View Post
      Just wanna ask here, will jailbreaking disrupt our OS performance?
      Simple answer is NO.
    1. trickymicky's Avatar
      trickymicky -
      This is not working for me, when I tap mach_portal the screen goes white and no respring
    1. NewD's Avatar
      NewD -
      Quote Originally Posted by kristatos View Post

      I did notice that the respring fix from cydia only works for respring but not for reboot within cydia...you still need to hard reboot after to re-JB...but that's minor...

      Respring+ also works fine (for anemone for example)...
      Hey Kristaos. Glad you're good - but you don't really need either of those tweaks in this jailbreak. Respringing from within Cydia is fixed and working just fine without CydiaRespringFix installed. So you can probably just get rid of that and Respring+ too. 98% of the things in my tutorial for 10.1.1 are just not needed with the 10.2 JB. All fixed. Although you're right about rebooting. That still needs hard reboot..
    1. NewD's Avatar
      NewD -
      Quote Originally Posted by devlon View Post
      i installed anemone from the regular repo -- should i install the beta? i can't seem to access the beta repo (

      locationfaker9 doesn't seem to be working for me either -- not sending spoofed
      Just the regular Anemone from Cydia is the one to use. Though .car support is broken at this point. Your icons will theme if the theme is updated for IconBundles. But your clock and calendar will be messed up and some other things missing until .car support added . Beta repo not in use now. No need for the new iconsupport. That's only needed for Icon positioning tweaks like Iconoclasm Boxy, Anchor, etc.
    1. Dirty Dobb's Avatar
      Dirty Dobb -
      I'm still on 9.3.3, can someone please test the tweak "Slices" for me? It's the tweak I use the most and would hate to lose it.
    1. ottozuts's Avatar
      ottozuts -
      Can't jailbreak with yalu102, ios 10.1.1 iphone 7. If anyone have done it, a little info please..,,
    1. devlon's Avatar
      devlon -
      Quote Originally Posted by NewD View Post
      Just the regular Anemone from Cydia is the one to use. Though .car support is broken at this point. Your icons will theme if the theme is updated for IconBundles. But your clock and calendar will be messed up and some other things missing until .car support added . Beta repo not in use now. No need for the new iconsupport. That's only needed for Icon positioning tweaks like Iconoclasm Boxy, Anchor, etc.
      Cool -- thanks for the reply. Do I need to install IconBundles, or just wait for the themes are updated? I tried to install IconBundles but it was removing Anemone and themes and replacing with WinterBoard.

      Also, this may be just me, but in Cydia itself on the Home page, none of the menus are working for me. When I tap Manage Account, for example, it just grays out, but doesn't open that menu. Same with all the other menus, Featured, Themes, etc., etc.

      Just an update of a few other tweaks on my 6S+

      Eclipse 9 isn't working --
      Springtomize 3 opens/doesn't safemode, but the respring within the tweak does not work, and respringing externally doesn't apply tweak choices selected
      CCcontrols opens/doesn't safemode, but no functions are listed as available choices
    1. bliken's Avatar
      bliken -
      Quote Originally Posted by ottozuts View Post
      Can't jailbreak with yalu102, ios 10.1.1 iphone 7. If anyone have done it, a little info please..,,
      The new JB doesn't work for 7/7plus phones
    1. NewD's Avatar
      NewD -
      Quote Originally Posted by devlon View Post
      Cool -- thanks for the reply. Do I need to install IconBundles, or just wait for the themes are updated? I tried to install IconBundles but it was removing Anemone and themes and replacing with WinterBoard.
      The tweak IconBundles is only for Winterboard which is obsolete now. Anemone already has IconBundles support built it. The Anemone from Cydia itself is the one to use. That version ALSO has auto conversion of Bundles and Folders Method themes to IconBundles - in real time (future versions will not). BUT - that auto converting engine only works for themes built for iPhone 6Plus (larger screen phones with 180x180 icons). If the icons are smaller than 180x180 - they won't be auto converted - at least not all of them. Some will. So if you already own a theme.. try downloading its 6Plus icon set - if the theme creator made one. Then it should work seemlessly in Anemone even without IconBundles folder.. At least for now. Older themes.. you're sorta screwed on if there was never a version with 180x180 icons in it.

      Also, this may be just me, but in Cydia itself on the Home page, none of the menus are working for me. When I tap Manage Account, for example, it just grays out, but doesn't open that menu. Same with all the other menus, Featured, Themes, etc., etc.
      Please read my tutorial in the 10.1.1 thread carefully - on Page 18. It explains to add the repo apt.saurik.com/beta/cydia-arm64 and do the update to Cydia Installer from in there. You can also just keep swiping right a lot and that window will eventually open.

      Just an update of a few other tweaks on my 6S+

      Eclipse 9 isn't working --
      There's a new beta for this somewhere.
      Springtomize 3 opens/doesn't safemode, but the respring within the tweak does not work, and respringing externally doesn't apply tweak choices selected
      Dead in iOS 10.. There's a 'barely fixed' version for 10 from the repo: repo.iosdelisi.com - but that repo looks a little 'pirate-ey' to me.. Proceed with caution.
      CCcontrols opens/doesn't safemode, but no functions are listed as available choices
      None of the CC products are updated for 10.

      You have a lot of reading to do - to check out what's ready and what's not. Hang in there!
    1. menard_00's Avatar
      menard_00 -
      Quote Originally Posted by devlon View Post
      Cool -- thanks for the reply. Do I need to install IconBundles, or just wait for the themes are updated? I tried to install IconBundles but it was removing Anemone and themes and replacing with WinterBoard.

      Also, this may be just me, but in Cydia itself on the Home page, none of the menus are working for me. When I tap Manage Account, for example, it just grays out, but doesn't open that menu. Same with all the other menus, Featured, Themes, etc., etc.

      Just an update of a few other tweaks on my 6S+

      Eclipse 9 isn't working --
      Springtomize 3 opens/doesn't safemode, but the respring within the tweak does not work, and respringing externally doesn't apply tweak choices selected
      CCcontrols opens/doesn't safemode, but no functions are listed as available choices
      Anemone has IconBundles built in, you don't need to install it.
      To fix Cydia, install this source and then upgrade essentials.
      apt.saurik.com/beta/cydia-arm64/
      Install this source to get Eclipse4 (Beta1), for iOS 10
      gmoran.me/repo/
      Don't think there's an update yet for the other 2 you mention.
    1. sand_man's Avatar
      sand_man -
      Quote Originally Posted by NewD View Post
      You have a lot of reading to do - to check out what's ready and what's not. Hang in there!
      I lot of what I use isn't compatible yet. Springtomize, Boxy, Anchor, Folder Enhancer, Speed intensifier, CCSettings, Byta Fonts. The benefits of iOS10 with non functional core tweaks vs 9.3.3 with fully functional tweaks, negates the benefit of upgrading for me!! Sadly...

      And by the time all is updated the signing window will have closed and one will be required to do the Prometheus dance to get on 10.2.

      Man, it's tough being an iFan these days! Vanilla iOS just doesn't titillate and JB is becoming challenging for both end user and developer alike.

      Hate to say it but for the first time in about 2 years I'm considering droid as an option again... Last droid was a S4! Hated the phone, loved the ability to play though!!
    1. modesto83's Avatar
      modesto83 -
      so can we jailbreak iphone 7?
    1. bliken's Avatar
      bliken -
      Quote Originally Posted by modesto83 View Post
      so can we jailbreak iphone 7?
      Not on 10.2

      Yes on 10.1.1
    1. devlon's Avatar
      devlon -
      Quote Originally Posted by NewD View Post
      The tweak IconBundles is only for Winterboard which is obsolete now. Anemone already has IconBundles support built it. The Anemone from Cydia itself is the one to use. That version ALSO has auto conversion of Bundles and Folders Method themes to IconBundles - in real time (future versions will not). BUT - that auto converting engine only works for themes built for iPhone 6Plus (larger screen phones with 180x180 icons). If the icons are smaller than 180x180 - they won't be auto converted - at least not all of them. Some will. So if you already own a theme.. try downloading its 6Plus icon set - if the theme creator made one. Then it should work seemlessly in Anemone even without IconBundles folder.. At least for now. Older themes.. you're sorta screwed on if there was never a version with 180x180 icons in it.
      Awesome, thanks for the advice. All the themes I use have a 6+ icon set, but after installing the updated cydia, Anemone is theming fine for me now for some reason, haha!

      Is there anything similar to Iconoclasm that will position icons as of yet?

      Please read my tutorial in the 10.1.1 thread carefully - on Page 18. It explains to add the repo apt.saurik.com/beta/cydia-arm64 and do the update to Cydia Installer from in there. You can also just keep swiping right a lot and that window will eventually open.

      You have a lot of reading to do - to check out what's ready and what's not. Hang in there!
      Yes, I do, haha. Thanks for the tip. That repo install solved the Cydia issue for me.

      Install this source to get Eclipse4 (Beta1), for iOS 10
      gmoran.me/repo/
      Awesome, thanks for the beta repo. Eclispse4 is working for me now.

      PS
      HideMe9 and Dock&Roll aren't working for me as of yet.

      Yikes, sorry for the continuous updates.
      I'm trying to SSH in to fix my LTE issues, per the tutorial. I'm using Cyberduck and [email protected][ip address entered] and am using alpine, but it just stalls on "connecting"
    1. NewD's Avatar
      NewD -
      Quote Originally Posted by sand_man View Post
      I lot of what I use isn't compatible yet. Springtomize, Boxy, Anchor, Folder Enhancer, Speed intensifier, CCSettings, Byta Fonts. The benefits of iOS10 with non functional core tweaks vs 9.3.3 with fully functional tweaks, negates the benefit of upgrading for me!! Sadly...

      And by the time all is updated the signing window will have closed and one will be required to do the Prometheus dance to get on 10.2.

      Man, it's tough being an iFan these days! Vanilla iOS just doesn't titillate and JB is becoming challenging for both end user and developer alike.

      Hate to say it but for the first time in about 2 years I'm considering droid as an option again... Last droid was a S4! Hated the phone, loved the ability to play though!!
      Yes. If you're a "must have all my tweaks done now" kind of person before making a change then now is definitely not the time for you to upgrade. Things will move quickly though once iPhone 6 and iPhone 5s support is added to the newest 10.2. So it may not be as long as you think. But most of the devs are on iPhone 6 and therefore they just can't work to update their stuff yet.

      You don't want to go back to android yet either. The phones are quite amazing looking but the OS still needs firmware updates every 2 to 3 days. Still a pretty wonky system compared to the iWorld. You'd be driven nuts within a month.
    1. NewD's Avatar
      NewD -
      Quote Originally Posted by devlon View Post

      Is there anything similar to Iconoclasm that will position icons as of yet?
      Only iconoclasm itself is working for icon positioning.
      Yikes, sorry for the continuous updates.
      I'm trying to SSH in to fix my LTE issues, per the tutorial. I'm using Cyberduck and [email protected][ip address entered] and am using alpine, but it just stalls on "connecting"
      SSH has also been wonky with these JB's. Try installing OpenSSH first.
    1. 0Milk0's Avatar
      0Milk0 -
      My 6s iOS10.2, is working pretty solid so far, I only use xCon, Phantom Lite and Pandora Downloader. I have always noticed the more tweaks i had in the past the more buggy my phone got.
    1. devlon's Avatar
      devlon -
      Quote Originally Posted by NewD View Post
      Only iconoclasm itself is working for icon positioning.

      I'm not able to install iconoclasm, as it says I need IconSupport?
    1. ottozuts's Avatar
      ottozuts -
      Quote Originally Posted by bliken View Post
      The new JB doesn't work for 7/7plus phones
      oh thanks, i thought if you are on ios 10.1.1 you can use the yalu102 on an ip7....
    1. kelcel's Avatar
      kelcel -
      After Reading all this what do you Smart people think i have iPhone 7 jailbroke on 10.1 but not using it for my daily phone yet should i update to 10.2 and wait for Jailbreak I'm sure there are lots of people in my situation Thanks in Advance for the advice
  • Connect With Us

  • Twitter Box

  • Facebook