• Dec. 28 Cydia Crashing Problem. DO NOT Restore Your Device FIX Inside!

    Today around 12:05 EST there was a Packages file distributed via macciti/zodttd's source that causes cydia to not launch properly. The issue is well known and a solution is being worked out. Please do not panic/overreact and restore. Again, DO NOT restore your device.

    More Information:
    The issue was caused by a unicode character used in zodttd's packages file. This character brought out a bug in cydia which caused it to not launch. (a similar problem was created in the past when another community source missed a line break between entries.) This is not the fault of anyone at macciti or zodttd this is simply a bug in cydia.
    This is a simple fix really.
    • Connect to your iphone/ipod via either ssh, mobile terminal, ifile, diskaid or some other type of usb file system browser. Browse to /var/lib/apt/lists/
    • Delete cydia.zodttd-1.com_repo_cydia_dists_stable_main_binary-iphoneos-arm_Packages.
    • Install the new update to cydia to fix this.

    IF you have apt7 installed you should be able to just run the following:
    apt-get update
    You can also follow the direction in this .pdf to fix using diskaid for mac or windows
    This article was originally published in forum thread: Dec. 28 Cydia Crashing Problem. DO NOT Restore Your Device FIX Inside! started by JStraitiff View original post
    Comments 2 Comments
    1. katastrophic's Avatar
      katastrophic -
      Help! Cydia isn't working for me. It just keeps loading on forever. I tried deleting files except Partial and deleting all repos. Rebooted and It still doesn't work. Any suggestions on what to do besides doing the dreadful RESTORE ?
    1. Jahooba's Avatar
      Jahooba -
      Good thing I deleted that horrible repo a long time ago. There's nothing but a bunch of crap on there. Modmyi is the way to go, or BigBoss.
  • Connect With Us

  • Twitter Box

  • Facebook