• Corona Untethered iOS 5.0.1 Jailbreak: Updated to Version 1.0-3

    The Corona untether for iOS 5.0.1 gets its first and second updates tonight.

    Corona was the name given to the iOS 5.0.1 untethered jailbreak package that was released into Cydia this morning as we covered during its initial release. The untethered jailbreak was possible either through the use of Corona or by the new redsn0w 0.9.10b1. That's just to clarify if you didn't know what Corona was.

    Apparently, as found by planetbeing, Corona broke 'launchctl' which is a dependency for a handful of applications and tweaks that you download in Cydia. This basically means that installing Corona would make launchctl stop working even though it worked perfectly fine prior to installing Corona. Launchctl is a program that manages daemons, scripts, applications, and things of that sort (yeah it's kind of important). To fix this issue, Saurik issued an update (Corona version 1.0-2) that would keep Corona from breaking launchctl so that the dependent applications and tweaks will function correctly on your device.

    Additionally just a few minutes ago, Saurik pushed a second update (Corona version 1.0-3) which fixes another problem - using redsn0w 0.9.10b1 to install the untethered jailbreak (when you were already tethered) actually caused the same problem as above with launchctl breaking after the untether install. This means that redsn0w users were facing the same problem as the lazier people who simply installed the Corona untether from Cydia and left it at that. Just go into Cydia and download that update and you should be good to go.

    The new version should patch the problem and make it so that launchctl dependent applications and tweaks work properly even after you install the untethered jailbreak for iOS 5.0.1. A couple of applications that require it include OpenSSH and IntelliScreenX. Corona is still in its early stages and we expect that there will still be more problems in the future - but with a dedicated jailbreak team monitoring problems, we should see those wounds mended quickly and efficiently. Keep your eyes on that changes tab for the next couple of days or weeks.

    Sources: Saurik
    This article was originally published in forum thread: Corona Untethered iOS 5.0.1 Jailbreak: Updated to Version 1.0-3 started by Anthony Bouchard View original post
    Comments 68 Comments
    1. Habusho's Avatar
      Habusho -
      Quick question:

      If we used Pwnage tool instead of Redsnow, do we still need to apply this fix? I haven't really noticed any problems yet but I'd like to get everything set up perfectly as long as Apple is signing this 5.0.1 firmware.

    1. da_bomb3's Avatar
      da_bomb3 -
      Quote Originally Posted by jwil736 View Post
      5.0.1 update now while you can.
      If I ota update and boot tethered will that work because i heard other people saying it works

      Also, which redsn0w would I use to boot tethered
    1. celeron's Avatar
      celeron -
      You can't OTA update if you're jailbroken. And I don't think booting tethered will work
    1. da_bomb3's Avatar
      da_bomb3 -
      I need to backup everything now on iexplorer. Great. I specifically didnt update for this reason and now I have to update.
    1. tonman23's Avatar
      tonman23 -
      Quote Originally Posted by Dean-Spiff View Post
      I was jailbroken 5.0.1 tethered and used the new redsn0W 0.9.10b1 and now half my apps won't work. iBooks, Flipboard, ModMyi (ironic, i know), and more all crash upon starting. WTH?? How do we fix this?
      do you have spire installed? if so remove it, reboot and see if that fixes the issue.
    1. christoforo's Avatar
      christoforo -
      So he fixes it yesterday and breaks it again with mobile substrate update.
    1. Goodbye's Avatar
      Goodbye -
      Quote Originally Posted by Kevin8677 View Post
      I have a 3GS iOS 5.0.1 jb tethered with redsnow. I ran corona yesterday & am now untethered. It was as simple as installing any app. No restore needed. Everything still works & I did the corona update this morning without issue. No problems of any kind. If you're already jailbroken tethered then there's no reason to restore & jailbreak again if you're already on 5.0.1. Just run corona, reboot with a pc & u should be good.

      Correction - reboot without a pc after u install corona & u should be good
      I concur. I have an iphone 4 w tethered 5.0.1 and bb 4.10.01. I just installed Corona and rebooted without a hitch, and still have my unlock. This is the next best thing after jailbreakme. i also did the same thing with my iPad.
    1. Tylus's Avatar
      Tylus -
      Quote Originally Posted by christoforo View Post
      So he fixes it yesterday and breaks it again with mobile substrate update.
      yeah, got my stuff working

      saw the Mobile Substrate update

      did it, and now my stuff won't work again. WTF is going on?
  • Connect With Us

  • Twitter Box

  • Facebook