1. lighter's Avatar
    Ok I think I just figured out a temp fix for this issue with the wrong timestamp!!!

    I just tested this and it works ... it has to do with the DST.. for some reason anyone that is in the EST. time zone from what I can gather gets this issue...(Or it maybe any timezone) ..now I've tried turning of the network time.. but for some reason the iphone still continues to display 4 hours behind.. so I got thinking .. If I changed my time zone to something that was GMT+5 would this fix the issue with the 1 hour for DST and nope... no go.. it just added 4 more hours... so I figured it out... we need a timezone that doesn't have DST and is GMT+0

    so here you go.. try this... chose any of these time zones or cities i should say:

    I used Rabat, Morocco and tested with my G/F who also uses an iphone and we are both on Rogers in Canada.

    Ok so turn off automatic update... chose Morocco as the time zone and manually set the correct time and this should solve the in correct timestamp until a better solution is put together...

    Set Automatically = OFF
    Time Zone = Rabat, Morocco
    Set Date & Time = Manually

    Calendar Time Zone Support = OFF


    Let me know if this works and here is the list of places with no DST and GMT +0.

    here is the link to wiki:


    Burkina Faso
    Bouvet Island
    Côte d'Ivoire
    The Gambia
    Danmarkshavn and surrounding area
    Saint Helena (including Ascension Island and Tristan da Cunha)
    São Tomé and Príncipe
    Sierra Leone
    Western Sahara
    2007-10-16 07:41 AM
  2. geol's Avatar
    it doesnt!!! still the same problem
    2007-12-02 05:57 PM
  3. gunzla's Avatar
    dosent work for me either
    2007-12-06 04:38 AM
  4. Ridge's Avatar
    or u could follow this thread to fix ur problem if your on 1.1.1 or 1.0.2. Woudn't be an issue in 1.1.2


    If I helped you in anyway, show some love! hit the thanks button!
    2007-12-06 07:08 AM
  5. paulclo's Avatar
    or u could follow this thread to fix ur problem if your on 1.1.1 or 1.0.2. Woudn't be an issue in 1.1.2

    1.1.2 does fix the voice mail notification issue, but the time stamp is still 4 to 5 hours off for me sending and receiving SMS in the EST. Very frustrating.

    Any one have any idea how to fix this probelm !?

    2007-12-14 11:51 PM
  6. killahov's Avatar
    yea would like a fix to this aswell
    2007-12-19 10:13 AM
  7. choto's Avatar
    This does work... just try different cities in different time zones till you find the correct one for you (for example: Dublin for argentina). To check if it's correct go to your carriers web page and SMS yourself.
    2007-12-28 08:14 AM
  8. Hagge10's Avatar
    hi everybody try this

    connect using ssh then issue the command

    chmod 777 /var/db/timezone

    then restart the iphone and hopefully the "timezone freeze" lets go and you can edit your timezone again

    crossing my fingers for you guys
    2008-01-29 10:57 PM
  9. chillypbear's Avatar
    2008-03-17 07:55 PM
  10. chillypbear's Avatar
    I did work for me but I found the any SMS i got that were less than the standard 10 digits (with Fido in Canada) wouldn't show up in the SMS menu, just thought I'd disclose a problem I was having just incase anyone else wanted to install the fix. I had to restore and reupgrade up to 1.1.3 and I would hate that someone else had to go through that because of advice I had posted.
    2008-03-28 03:35 PM
  11. sunny416's Avatar
    it WORKED. im so happyy. thank u so muchhh
    2008-10-26 06:20 AM