1. Destructo's Avatar
    How to remove "Call Forwarding Active" pop-up message when you make a call?

    There is a way to remove it by editing one of the .plist, but I can't remember which. I saw it on hackint0sh.org but I can't find it again.

    Any help?

    Nevermind, found it:

    Get the file com.apple.carrier.plist found at /var/root/Library/Preferences/ and edit the key ShowCallForwarding to be <false/>. Reboot! There you go, your Mailbox works and you don't get that annoying message anymore :-)

    Update:

    There are two settings in com.apple.carrier.plist:

    ShowCallForwarding: Message shown on outgoing calls, if your number is beeing forwarded.
    ShowCallForwarded: Message shown on incoming calls, if caller has been forwarded to you.

    Source: http://hackint0sh.org/forum/showthread.php?t=11641
    Last edited by Destructo; 2007-10-31 at 10:14 PM. Reason: Automerged Doublepost
    2007-10-31 10:14 PM
  2. predator13's Avatar
    Wrong info!!!!
    Download UnknownCarrier.plist from /System/Library/Frameworks/CoreTelephony.framework/Support/ and edit ShowCallForwarding to false...

    That´s it!
    2007-11-02 07:11 AM
  3. Destructo's Avatar
    The other method worked for me.
    2007-11-02 04:57 PM
  4. mkurasz's Avatar
    the real issue is when ur on the phone and u get like 8954895895 sms messages, its like impossible to hang up till u ignore them all...

    any tweaks for that?
    2007-11-02 05:24 PM
  5. predator13's Avatar
    Destructo:

    Be careful because there is a small error in this information …
    The file that you say that it is necessary to change is not a file, it is a symbolic linkage (link in linux) to other.
    On having modified it, you are changing the system of files of the iphone, which in this case and right now it is not a problem (since it seems that there you works every ok) but the correct thing would be to modify the file to the one that aims at the linkage.
    2007-11-02 06:21 PM
  6. TheHK's Avatar
    Wrong info!!!!
    Download UnknownCarrier.plist from /System/Library/Frameworks/CoreTelephony.framework/Support/ and edit ShowCallForwarding to false...

    That&#180;s it!
    I do not have this .plist all I have are:

    PDPContext_0.plist
    and
    PDPContext_1.plist

    Any ideas?

    UPDATE

    Apparently this only works for 1.1.1
    Last edited by TheHK; 2007-11-07 at 03:34 PM. Reason: UPDATE
    2007-11-07 03:31 PM
  7. predator13's Avatar
    Yes... only works for 1.1.1
    2007-11-08 05:14 AM
  8. dane.pablecheque's Avatar
    SO any solutions for 1.0.2??
    2007-11-08 08:09 AM
  9. mrtn's Avatar
    hey guys

    i'm having a problem with both of the files ie they haven't got anything inside - 0kb

    UnknownCarrier.plist

    com.apple.carrier.plist

    i get this annoying pop up box all the time... firmware 1.1.1

    anyone can help
    2007-11-13 05:42 PM
  10. bona's Avatar
    yes for 1.0.2 type ##002# call then when you get the screen come up hit Dismiss
    2007-11-14 10:49 PM
  11. NuWeb's Avatar
    type ##002# call
    Thanks for this, It worked 100&#37; no problems. Thanks!
    2007-11-16 08:14 PM
  12. soulboy's Avatar
    This also works for 1.1.2

    Sorry no it doesn't ;-(
    Last edited by soulboy; 2007-11-19 at 06:34 PM.
    2007-11-19 06:25 PM
  13. huyazo's Avatar
    worked on 1.1.1

    thx
    2007-11-20 11:41 PM
  14. Rusty's Avatar
    the ##002# doesn't work on my 1.0.2... It gives me the message, hit dismiss but still the same even after rebooting...
    2007-11-23 05:31 PM
  15. innovaciones's Avatar
    the ##002# doesn't work on my 1.0.2... It gives me the message, hit dismiss but still the same even after rebooting...
    I think it only works with 1.1.1 because i tried with both versions and the 1.0.2 version doesnt work!
    2007-11-23 07:07 PM
  16. Rusty's Avatar
    Any other way to do it with 1.0.2??
    2007-11-23 08:21 PM
  17. scowler's Avatar
    Yep , spot on.

    Always edit the real file , never replace the symbolic link.

    I just edited the real file and this is now working for me on 1.1.2.
    Never knowingly understood.
    2007-11-23 08:47 PM
  18. TheHK's Avatar
    yes for 1.0.2 type ##002# call then when you get the screen come up hit Dismiss
    Apparently what this does is erase all your call forward settings so I suggest if you use this function (e.g. if you hit decline, the phone goes to voicemail) then do NOT use this method.
    2007-11-23 11:04 PM
  19. tutmeister22's Avatar
    I did this back when I started using 1.1.1 and it worked like a charm, by editing the UnknownCarrier.plist file.
    Now I tried it with 1.1.2 and it doesn't work, even though the plist is almost exactly the same (it now has ShowTTY set to true). Has anyone really got rid of the messages on 1.1.2 without sacrificing the voicemail service??

    UPDATE:
    Yes, it does work on 1.1.2 too, stupid me. I had already set up a new plist file for my carrier, so of course I had to edit that file instead of the UnknownCarrier one.
    Last edited by tutmeister22; 2007-11-26 at 01:27 AM. Reason: Realized my mistake
    2007-11-25 09:51 PM
  20. hostelo's Avatar
    any new info for removing this on the 1.0.2??

    thanks in advance
    It's Good to be Dominican
    2007-11-27 06:15 PM
49 123
LINK TO POST COPIED TO CLIPBOARD