1. bebellm's Avatar
    Hi! Do you mean with iOS4 it will never work? So any chance I can do it? Or downgrade to a lower version of iOS will help?
    Thanks for the reply!
    Hello oups i forgot the link in my previous Post : Ubuntu Linux OpenSSH Server installation and configuration

    I think there is a chance, but for now i didn't find it. Because extract the data as an Img is useless if we don't decrypt the data after (since IOS4). And now i don't know exactly how to decrypt it. There is several tools live Idecrypt /vfdecrypt but i have some question about it, see my post above.

    So i can advise you to extract the data, it's better than nothing, but you have to find a way to open it !!!

    2011-08-22 11:40 AM
  2. iphone323's Avatar
    Hello everyone, I have this little problem here... Whoever will help me to go through step by step (since I'm a loser with Iphones/hacking etc...) I would really appreciate that with $$$. I will pay!
    I had some pictures and videos on my Iphone. A lot of them were deleted by my friend about a week ago. I really need those pictures and videos back.
    I have Iphone 4 with 4.0 version. (I bought this Iphone since day 1 it came out and I have never updated it). It's jailbroken etc...
    I'm running Windows Vista... Whoever wants to make some money please email me at [email protected]... it would be great if whoever is going to email me would have aim or skype.. If you do please send it to me that I could contact you... PLEASE PLEASE PLEASE PLEASE!!!

    Hi, have you figured everything out? Do you think you could help me to go through everything step by step please? I could pay you for your help
    Last edited by iphone323; 2011-09-08 at 05:33 AM.
    2011-09-08 05:26 AM
  3. iphone323's Avatar
    You not the expert, casually?
    No, I'm not
    2011-09-08 07:54 AM
  4. Lebk's Avatar
    Is it confirmed that it doesn't work with iphone 4?
    Please anyone??

    2011-09-23 09:47 PM
  5. albrekht's Avatar

    I have permanently disabled iPhone 4. it is my wife`s phone who passed away.
    i need to get photos and videos from the phone. The original computer which i synced it with doesn't help. i have 2 computer and don't remember which one was that i synced it with,on one of them i had hard drive which crashed so i installed new one, so basicly when i am connecting to itunes on both computer it says "enter your passcode before connecting to itunes" but on the phone there is no keypad to enter passcode, it says only "iphone is disabled connect to intunes"

    So far nothing works.

    1. I tried iFaith to dump SHSH blobs, but later found out that building IPSW is only for restoring, that it will not retrieve my data.

    2. I tried iPhone Browser but it doesn't see my device

    3. i did not try this yet,as you suggested, not sure how to do this

    any suggestion, do you know anybody who have gotten data back from disabled iPhone?
    i will pay if anybody can do that for me , please help me, i will really appreciate it
    [email protected]

    Last edited by albrekht; 2011-09-26 at 02:11 AM. Reason: edit
    2011-09-25 11:25 PM
  6. wsxmax's Avatar
    I emailed the author of photorec and he told me that iphone4's data is encypted which is not able to be recovered. Is there anyone who is able to success on an iphone4?
    2011-09-29 04:39 AM
  7. rhbandit's Avatar
    I'm completely new to all this "openssh", "DD", "terminal". I jailbroke my 3gs and that was pretty easy. I got "openssh" installed on my pc AND iPhone. HOW THE HECK DO I OPEN THE "openssh" PROGRAM?!?!?! I've been reading this forum for hours and others as well and I'm not stupid at all but it seems like there are MANY things that posters here are taking for granted when they are trying to help others. Can someone PLEASE do a step by step on all this? I'm fully aware thats asking a LOT from someone but it wont just benefit me it will benefit MANY others out there that lost EVERYTHING when their phone crashed.
    2011-10-16 05:20 AM
  8. ItsJono's Avatar
    Okay, i've finally got to the part where i've got a 'dump.img' on my Slave on my Windows/PC machine.

    I just want to thank everyone who had the courtesy of posting step-by-step instructions. If you noobs who keep asking for the instructions, they're here in this thread. If your pictures aren't worth glossing over a 12 page forum thread, then clearly they're not worth it to begin with.

    Anyway, i'm at the part where I need to use photorec. Do I use photorec to scan the entire (whole) harddrive of where the .img is placed?

    Because i've read somewhere in this thread about a mountable image, giving me the impression I need to use a program like Daemon Tools or Alcohol 120% to mount the iPhone volume/img and then point photorec to it. I feel like i'm doing something wrong by just scanning the hard drive where the 'dump.img' is simply stored (my Slave drive, volume label E).

    Can someone post instructions or help me out with this part? It would be much appreciated.
    2011-10-23 10:08 PM
  9. rxnelson's Avatar
    I followed all the steps by building an ubuntu machine and actually got data for a friends iphone 3g. However, there are few full size pictures but tons and tons of thumbnails. Is there something I have done wrong or another method that can be used? His phone was in a boot loop where it would go to the apple then shut off. I installed 4.2 on it then followed the directions in this thread but feel like I am missing something since many of the pictures were not actual size. It recovered literally 35,000+ jpg files. Of those about 20 were of actual size. The rest were smaller and many were thumbnails. Any insight?
    2011-10-31 02:02 AM
  10. GustavoB's Avatar
    Will it be possible to recover other files that are not images? Like audio files or videos?
    2011-11-05 06:57 AM
  11. MazZafar's Avatar
    anyone know how I can restore my text messages and contacts from a backup in iTunes. i know it is there cos when I tried to re jailbreak my iPhone iTunes asked me which backup i wanted to use and on selecting the older one all my messages and contacts miraculasly appeared but phone was still locked to o2 when i am on Orange so ofter numerous tries I managed to unlock it but lost the above.
    How do i get that list up again asking me which backup i want to use?
    2011-11-17 07:46 PM
  12. dmbech's Avatar
    Any suggestions? Everything seems to work yet I always end up with a 0 byte file and the write process never seems to end. I let it run for a couple days and nothing seems to happen.
    2011-11-25 07:35 AM
  13. hotoru's Avatar
    I have mobile Terminal installed on my 3GS with OS4.2.1 When I try to run terminal, it briefly shows keyboard, then crashes back to springboard. I have tried reinstalling terminal through cydia and device reboot with same effect. Any suggestions would be appreciated. :-)
    2011-11-27 05:18 AM
  14. hotoru's Avatar
    I appreciate the help on this forum. I have been able to ssh into my iphone from imac terminal. But, when I try to run mobileterminal on iphone it just crashes immediately to springboard. Is there any way to accomplish same from imac terminal? Can I remote mount drive?
    Help appreciated,

    I have mobile Terminal installed on my 3GS with OS4.2.1 When I try to run terminal, it briefly shows keyboard, then crashes back to springboard. I have tried reinstalling terminal through cydia and device reboot with same effect. Any suggestions would be appreciated. :-)
    2011-12-09 07:23 PM
  15. hotoru's Avatar
    I appreciate the help on this forum. I have been able to ssh into my iphone from imac terminal. But, when I try to run mobileterminal on iphone it just crashes immediately to springboard. Is there any way to accomplish same from imac terminal? Can I remote mount drive?
    Help appreciated,
    Well, Finally figured out getting mobileterminal to work. It seems the version of mobileterminal in cydia does not work well with ?3GS. To install the newest version of mobile termial I downloaded the DEB file from google. Then I copied this file into cydia's autoinstall directory using DiskAid program for mac. I had to create the Cydia and Autoinstall folders on the iphone (again using diskaid)

    I hope this saves someone the hours I spent.
    2011-12-12 01:00 AM
  16. amzy2010's Avatar
    I have iphone 3GS.I am trying to recover contacts.I have capture the image of rdisk0s1 and rdisk0s2s1 ,but could not take image of the whole disk,it keep restarting the iphone at exact 767mb.I remove the ikee virus.Also I do not know why my iphone now keeps lossing signal at random,which is temporary solved by restarting the iphone.

    I have change the ssh password.

    I used scalpel,foremost and photorec but could not recover sqlite file.

    Is there any difference of recoverying data from partition image and disk image?

    How can I check for virue,will ifuse and ubunutu clamav work.

    Please help
    2012-01-13 05:01 PM
  17. YoungDragun's Avatar
    Ok, wanted to return something to the community here.

    I helped my gf grab files off her iphone. I didn't do this process myself, but I did the research for her, so I'm familiar with most of the issues.


    We tried doing everything using Windows, but there were so many problems we gave up.

    Major credit to spoonsslick and the original poster. I used spoonsslick's instructions for doing everything using a ubunto livecd. Here are my modified instructions with more details:

    Linux experts or whoever, unless you believe I'm suggesting something that is VERY wrong, please don't critique as you'll just add more spam to the thread with ineffectual suggestions.

    Ok, here are instructions that I know work (using WiFi):

    Move your computer/laptop and iphone close to your router to maximize transfer speeds.

    Download and burn ubuntu to a CD or DVD:


    * I write a lot of comments in parentheses (), so don't actually type stuff in brackets.

    On your computer/laptop:

    Boot from liveCD (you may need to go into your BIOS and re-arrange the boot order such that your CD-ROM loads before your hard disk containing windows. google for help if you need.)

    - Open a terminal window, install sshd by typing:
    sudo apt-get install openssh-server

    - Update root password (I know the 2 commands below probably do the same thing, but no harm doing both):
    sudo passwd
    sudo passwd root

    sudo -s (this should change you to the root user so that you have full control over your system)

    fdisk -l (this should list all your hard drive partitions)

    you'll see an output like the following:

    Device Boot Start End Blocks Id System
    /dev/hdb1 * 1 2432 19535008+ 86 NTFS
    /dev/hdb2 2433 2554 979965 82 Linux swap / Solaris
    /dev/hdb3 2555 6202 29302560 83 Linux

    look on the right end of each line to find something that matches your local hard disk drive (it'll most likely say ntfs)
    find the device (line) you want, and note the /dev/XXX in the front of the line. the XXX represents your partition

    mkdir /media/windows (creates a folder to link your drive)
    mount /dev/XXX /media/windows/ -t ntfs -o nls=utf8,umask=0222 (link your drive)

    replace the XXX with your partition from the fdisk command

    for example, on my laptop, it was this (sda2 was my partition identifier):

    mount /dev/sda2 /media/windows/ -t ntfs -o nls=utf8,umask=0222

    cd /media/windows2
    ls -l

    the above 2 lines should display the contents of your drive. look and see if you recognize files from your HD. if you do, you're good to go. i'm not sure why spoonsslick didn't provide instructions for this because ubuntu creates a 1gb ram disk, and your iphone image will be minimum 8 gb... so you'd be stuck after transferring 1gb. if someone has better instructions on mounting a HD in ubuntu, feel free to comment.

    find your ip address, look at inet addr:
    ifconfig (or is it ipconfig? my gf didn't comment, so i guess one of these commands will give it to you)

    Your computer/laptop at this stage should be ready to receive and write the dd dump file.


    Ok, now to iphone:

    You'll need a jailbroken iphone. Google if it's not to get instructions.

    Our home network uses the standard 192.168.1.### ip range standard on most routers. If you use something else, then change the first 3 octets to match yours in the instructions below.

    In cydia, install terminal, mobileterminal, and openssh. Reboot iphone. I remember one of the terminals didn't actually create an icon to run the terminal program, so just install both to save time.

    set phone to auto dim and set phone to a lower brightness to use less battery (in case phone runs out of power sending over wifi before the file gets transferred; someone earlier had this problem, but we didn't)

    start terminal on your phone by clicking the icon:

    type the following commands:

    ssh [email protected] (xxx is IPHONE ip - password alpine)
    rm .ssh/known_hosts (this removes the saved host keys so you don't get permission denied error if you boot from the live cd more than once since each new boot creates an unique key that will mess everything up)

    ssh [email protected] (xxx is computer ip, we run this so it will ask you if you want to save the key, type "yes")

    exit (you ssh'd into the computer, "exit" gets you out since you don't want to actually be in the computer directly)

    dd if=/dev/disk0 | ssh [email protected]<computer ip> 'dd of=/media/windows/dump.img'

    replace the <computer ip> with your computer ip. hopefully it'll ask you for the root password and then write to your mounted HD

    if your network is fast and you can get 500k+, it'll take a few hours. make sure your phone is plugged into the wall to get maximum power recharge so your phone doesn't run out of battery partway through.


    You have a dump image file. Don't try to mount using poweriso/ultraiso/magiciso as that's not what you want to do.

    Google photorec and learn to use that. The first few links will give you decent instructions, or you can fool around a bit yourself. If you didn't overwrite your phone flash, you should be able to recover quite a bit.

    Good luck.
    I have an iPhone 3g that is updated to 4.2.1 and this information helped me to obtain a disk image that I was able to recover photos from. The phone had no previous backups of the photos and there were roughly 3,000 + photos that were lost after an update to 4.2.1 FW. I followed the instructions to the "T" and all went well without a hitch. Thanks to everyone that made this possible.

    FYI: I used an Ubuntu Live CD, V10.10 and Windows 7 with the Windows version of Photorec.
    Last edited by YoungDragun; 2012-01-27 at 03:12 AM.
    2012-01-27 03:07 AM
  18. Lizardi12's Avatar
    Is there really a way to recover your stuff??
    2012-01-31 08:34 PM
  19. YoungDragun's Avatar
    Is there really a way to recover your stuff??

    I was able to recover deleted photos and .sqlite files. I just need to find out how to recover contacts now and I'll be set.

    Anyone out there able to give direction on how to recover contacts from the .sqlite files?
    2012-02-02 03:06 AM
  20. ma777's Avatar
    I have successfully dumped and recovered off a 3g and 3gs. I have an .img from a 4th gen itouch. I don't understand how to decrypt it. Also I can't get an iphone 4 on ios 5 to even start dumping. I get no such directory for dev/disk0.
    2012-02-03 07:43 AM
270 ... 21011121314
We have updated our Privacy Policy and Terms & Conditions. Please check them out.