1. pwkelley7's Avatar
    same here, does anyone know how to pull the image off? I can't umount or dd?
    who knows how to do this?

    I'm trying to recover deleted photos but I cant umount or dd. i get not a directory or special device when I umount. and if i try to dd without umount and mount -o ro i get zero copied......... How did you get an image, I'm on Iphone 4 with IOS 5.0.1
    Last edited by pwkelley7; 2012-02-05 at 10:24 PM.
    2012-02-05 10:19 PM
  2. Harjus's Avatar
    Hi, I have finally been able to do a dump of my iPhone 3gs 16 gb 5.01 cfw with the command rdisk0 bs=8192 but this is as far as I get, When I try to use Photorec it stops after about 30 seconds and all I get out from that are about 200 .png files that are all black and in diffrent shapes in the thumbnail and som .plist files.
    Any idea what to do?
    2012-02-14 03:36 PM
  3. ma777's Avatar
    Anyone have success with getting files of a 3gs on 5.0.1?
    2012-03-01 05:57 AM
  4. Buritotaco's Avatar
    dd: opening `/dev/disk0`: Permission denied cant pass this error (also if i dont shsh to my mac the error is dd: reading /dev/disk0': invalid argument) IOS 5.1
    2012-05-08 01:41 AM
  5. Auesing's Avatar
    Dear all, I am actually seeking the reverse.
    Hi, recently I saw this post of regarding Data Recovery. I am not vert tech savvy and would like to seek your help. I am trying to sell my iphone 4 and want whatever data and photo/video to be deleted permanently. I know it is still possible with the current technology, but is there a way to minimised the recovery?
    2012-05-08 04:18 AM
  6. hardikp's Avatar
    First of all, thanks for posting this guide. I got through all the steps and photorec has been able to recover all the images, videos and mp3 files that I wanted. However, it did not recover any voice memos from the iphone image. From searching around online, the voice memos are stored in .m4a format. I also created a new voice memo on the iphone (after copying the image) and used iphoneFolders to verify that it is indeed saved as a .m4a.

    I had recorded several voice memos during my recent vacation and would REALLY like to recover those. Does anyone know if photorec has a limitation in recovering .m4a files? Is there any other software I can use to analyze/recover from the image file?

    2012-05-24 12:11 AM
  7. jsp3000k's Avatar
    Ok, wanted to return something to the community here.

    I helped my gf grab files off her iphone. I didn't do this process myself, but I did the research for her, so I'm familiar with most of the issues.


    We tried doing everything using Windows, but there were so many problems we gave up.

    Major credit to spoonsslick and the original poster. I used spoonsslick's instructions for doing everything using a ubunto livecd. Here are my modified instructions with more details:

    Linux experts or whoever, unless you believe I'm suggesting something that is VERY wrong, please don't critique as you'll just add more spam to the thread with ineffectual suggestions.

    Ok, here are instructions that I know work (using WiFi):

    Move your computer/laptop and iphone close to your router to maximize transfer speeds.

    Download and burn ubuntu to a CD or DVD:


    * I write a lot of comments in parentheses (), so don't actually type stuff in brackets.

    On your computer/laptop:

    Boot from liveCD (you may need to go into your BIOS and re-arrange the boot order such that your CD-ROM loads before your hard disk containing windows. google for help if you need.)

    - Open a terminal window, install sshd by typing:
    sudo apt-get install openssh-server

    - Update root password (I know the 2 commands below probably do the same thing, but no harm doing both):
    sudo passwd
    sudo passwd root

    sudo -s (this should change you to the root user so that you have full control over your system)

    fdisk -l (this should list all your hard drive partitions)

    you'll see an output like the following:

    Device Boot Start End Blocks Id System
    /dev/hdb1 * 1 2432 19535008+ 86 NTFS
    /dev/hdb2 2433 2554 979965 82 Linux swap / Solaris
    /dev/hdb3 2555 6202 29302560 83 Linux

    look on the right end of each line to find something that matches your local hard disk drive (it'll most likely say ntfs)
    find the device (line) you want, and note the /dev/XXX in the front of the line. the XXX represents your partition

    mkdir /media/windows (creates a folder to link your drive)
    mount /dev/XXX /media/windows/ -t ntfs -o nls=utf8,umask=0222 (link your drive)

    replace the XXX with your partition from the fdisk command

    for example, on my laptop, it was this (sda2 was my partition identifier):

    mount /dev/sda2 /media/windows/ -t ntfs -o nls=utf8,umask=0222

    cd /media/windows2
    ls -l

    the above 2 lines should display the contents of your drive. look and see if you recognize files from your HD. if you do, you're good to go. i'm not sure why spoonsslick didn't provide instructions for this because ubuntu creates a 1gb ram disk, and your iphone image will be minimum 8 gb... so you'd be stuck after transferring 1gb. if someone has better instructions on mounting a HD in ubuntu, feel free to comment.

    find your ip address, look at inet addr:
    ifconfig (or is it ipconfig? my gf didn't comment, so i guess one of these commands will give it to you)

    Your computer/laptop at this stage should be ready to receive and write the dd dump file.


    Ok, now to iphone:

    You'll need a jailbroken iphone. Google if it's not to get instructions.

    Our home network uses the standard 192.168.1.### ip range standard on most routers. If you use something else, then change the first 3 octets to match yours in the instructions below.

    In cydia, install terminal, mobileterminal, and openssh. Reboot iphone. I remember one of the terminals didn't actually create an icon to run the terminal program, so just install both to save time.

    set phone to auto dim and set phone to a lower brightness to use less battery (in case phone runs out of power sending over wifi before the file gets transferred; someone earlier had this problem, but we didn't)

    start terminal on your phone by clicking the icon:

    type the following commands:

    ssh [email protected] (xxx is IPHONE ip - password alpine)
    rm .ssh/known_hosts (this removes the saved host keys so you don't get permission denied error if you boot from the live cd more than once since each new boot creates an unique key that will mess everything up)

    ssh [email protected] (xxx is computer ip, we run this so it will ask you if you want to save the key, type "yes")

    exit (you ssh'd into the computer, "exit" gets you out since you don't want to actually be in the computer directly)

    dd if=/dev/disk0 | ssh [email protected]<computer ip> 'dd of=/media/windows/dump.img'

    replace the <computer ip> with your computer ip. hopefully it'll ask you for the root password and then write to your mounted HD

    if your network is fast and you can get 500k+, it'll take a few hours. make sure your phone is plugged into the wall to get maximum power recharge so your phone doesn't run out of battery partway through.


    You have a dump image file. Don't try to mount using poweriso/ultraiso/magiciso as that's not what you want to do.

    Google photorec and learn to use that. The first few links will give you decent instructions, or you can fool around a bit yourself. If you didn't overwrite your phone flash, you should be able to recover quite a bit.

    Good luck.
    this also worked for me (to save the image) from my iPhone 4s with iOS 5.1.1 but i had to do some adjustments. To mount my drive i needed to enter:

    sudo mount -t ntfs -o umask=0222,nls=utf8 /dev/sda2 /media/windows

    and to dd the iphone i entered:

    ssh [email protected] dd if=/dev/rdisk0 bs=1M | dd of=/media/windows/dump.img
    (i got this form here ∞ iJulien - iPhone 3GS data recovery)

    (I did not managed to get the photos, only to get the image)
    Last edited by jsp3000k; 2012-10-24 at 09:19 PM.
    2012-05-30 09:50 AM
  8. luv2run's Avatar
    this also worked for me on my iPhone 4s with iOS 5.1.1 but i had to do some adjustments. To mount my drive i needed to enter:

    sudo mount -t ntfs -o umask=0222,nls=utf8 /dev/sda2 /media/windows

    and to dd the iphone i entered:

    ssh [email protected] dd if=/dev/rdisk0 bs=1M | dd of=/media/windows/dump.img
    (i got this form here ∞ iJulien - iPhone 3GS data recovery)

    I have an iPhone 4s - I just got it a couple of weeks ago. When I got it, I turned in my old iPhone 3G, and all of my photos were successfully transferred to my new iPhone. Then a couple of days ago, I connected my new phone to iTunes, and when it asked me if I wanted to regester my phone as a new phone or restore it from my old phone, I clicked 'restore'. The problem is that the last time I synced with iTunes was over a year ago (I know that is bad ), so I lost all of my photos that I have taken since then! Is there ANY way to recover these photos? I'm concerned, because this message says to never restore to backup, or data will be lost. But the restore to backup is what caused my photos to be deleted. And the original poster sounds like did exactly what I did and recovered the lost photos (but that was like 4 years ago). Anyway, if there is any chance of at least some of the photos to be recovered I would like to do anything that I can.

    2012-06-07 11:06 PM
  9. bricken's Avatar
    Just out of curiosity, why do you need to mount the image? If you're using PhotoRec for your recovery, you can just point it directly at the image file by using the file's name as a parameter at the command line. For example, run: "photorec iphone-dump.img"
    Hi Imarr, it's been 4 years since you posted this, but who knows...
    I've made the iphone-dump.img as you described, but photorec is only recovering .png files instead of the lost .jpg photos. Could you maybe elaborate on how to use photorec? The .img is not mountable any other way (that I know)...
    Thanks in any case!
    2012-07-04 12:23 PM
  10. Dreamcube017's Avatar
    has anyone tried doing this through iFunBox? It has a USB tunneling feature that lets you do everything (including SSH stuff) through USB. You also don't get those stupid "can't start iPhone Listener) errors like you do with the other programs.

    The only problem I'm having is that it won't accept the password I give it for my computer's account. it keeps saying permission denied. Any thoughts? Thanks.
    2012-07-07 05:27 AM
  11. Daveski3's Avatar
    this also worked for me on my iPhone 4s with iOS 5.1.1 but i had to do some adjustments. To mount my drive i needed to enter:

    sudo mount -t ntfs -o umask=0222,nls=utf8 /dev/sda2 /media/windows

    and to dd the iphone i entered:

    ssh [email protected] dd if=/dev/rdisk0 bs=1M | dd of=/media/windows/dump.img
    (i got this form here ˆž iJulien - iPhone 3GS data recovery)
    I have an iPhone 4 on iOS 5.1.1 and my son just deleted a video I need. You say you were successful with a 4s on 5.1.1 but I thought I read that the dump would be encrypted. There is a lot of info in these 13 pages to digest. Did you follow those exact steps with your additions and photorec? I have a Mac and a PC to try this. The directions sound like they are for a PC, is that correct? Sorry for all of the questions but I really need to retrieve this one video as it is very important to me.
    2012-07-15 04:49 PM
  12. Dreamcube017's Avatar
    The directions actually seem like they're more for Linux than anything else... Maybe Mac. I was able to get somewhat far with iFunBox, but I keep getting Access Denied and I'm not sure why. I get Access denied when I try to have the phone get to my computer... not when I want to do stuff in the phone from the computer.
    2012-07-17 05:40 PM
  13. Ghost_Rider's Avatar
    this also worked for me on my iPhone 4s with iOS 5.1.1 but i had to do some adjustments. To mount my drive i needed to enter:

    sudo mount -t ntfs -o umask=0222,nls=utf8 /dev/sda2 /media/windows

    and to dd the iphone i entered:

    ssh [email protected] dd if=/dev/rdisk0 bs=1M | dd of=/media/windows/dump.img
    (i got this form here ∞ iJulien - iPhone 3GS data recovery)
    What program did you use to pull out stuff from the .img file.
    photorec isn't able to recover anything in my case.
    i also have 4S, i have read somewhere that photorec doesnt support 4s encryptions.
    what were you recovering? i am trying to recover pictures.
    2012-07-28 06:00 PM
  14. jimmysmith's Avatar
    Thanks for such a brief guide of how to recover deleted files from iPhone. Before reading this guide I also have read a thread in another forum. They tells me a very short and easy way to recover deleted files with iPhone data recovery software.

    Can any one please check the above solution really works or not.
    2012-09-23 05:03 PM
  15. highmastdon's Avatar
    iOS 5.1.1, jailbroken, iPhone 4, using https://github.com/msftguy/ssh-rd/downloads (latest 4a)

    Is it in any way possible to use dd because I lost my WhatsApp data. If i can at least get an image on my desktop i can apply some forensics on it.

    I tried the following command, but everytime i get some errors (on Mac OS X Mountain Lion btw):
    First i mount with mount.sh. Then i umount /mnt2. Then i try this but it doesn't work:

    ssh -p 2022 [email protected] "dd if=/dev/disk0s2s1 bs=4096KB" | dd of=/Users/[user]/Desktop/iphone-image.img
    getting reading `/dev/disk0s1s2': Invalid argument

    what can i do?
    2012-11-03 03:31 AM
  16. seebeach009's Avatar
    it's actually quite common. You lost a bunch of photos from my Camera Roll that hadn't been saved to my computer yet.
    Sometimes you need to synced your files,treasured photos and contacts whatever to itune and do regular backup.
    You can recover deleted photos,contacts and sms from iPhone.
    Last edited by Bo Troxell; 2014-07-01 at 08:26 PM.
    2013-03-15 02:32 PM
  17. seebeach009's Avatar
    Sometimes you need to synced your files,treasured photos and contacts whatever to itune and do regular backup.
    You can recover deleted photos,contacts and sms from iPhone with Wondershare Dr.fone.
    2013-03-15 02:34 PM
  18. Gwythinn's Avatar
    hope someone is still reading this thread.
    I ve tried the data recovery like it ist explained on Page 1...just using a windows pc with cygwin and no Mac.
    Everythings fine until i use the "DD" Command. The i need to enter a password for my PC.
    But i dont have a password for it. Has anyone an idea how i can tell the programm, that my PC is without a password and it starts with creating the image file? Even if I set up a password for my Users-Profile in Windows, cygwinterminal sill says it is wrong...
    please help!!!
    2013-04-09 03:42 PM
  19. Jabocs's Avatar
    Hey, dont worry. It is possible to recover your deleted text message, doesnt waste time on common hard drive data recovery, since it wont works for iPhone as iPhone use NAND flash drive, not SSD, therefore, it wont recognize iOS devices.

    I collected two methods to recover lost data from iOS devices:

    Method 1: Restore from your iCloud backup
    Restore from your iCloud backup, if you used iCloud to backup your phone, see iCloud: Backup and restore overview, or estore from a backup you made with iTunes on your mac or PC.

    Method 2: recover with iPhone data recovery software
    Even the data was deleted from iPhone, but it is still stored in the NAND flash drive, with iPhone data recovery, uses can easily restore deleted data from iPhone, read this article: how to restore deleted photos from iPhone 4s/4s/5 without backup.

    Suggestion: It is highly recommended to have a regular backup for your iPhone in order to minimize youre lost of iPhone.
    Last edited by Jabocs; 2013-07-11 at 06:35 PM.
    2013-07-11 04:27 PM
  20. Gashster's Avatar
    Hi! i know this post is really old but i need help!
    I been following the steps above, I've opened the port 22 through terminal in my ubuntu SSH-server. I rooted the phone after connecting to ubuntu, typed in my password and then when that was finished i entered the code:

    dd if=/dev/disk0 | ssh <username>@<computer-ip> 'dd of=iphone-dump.img'

    I entered the ubuntu's password.
    typed yes then I got this message:

    0+0 records in
    0+0 records out
    0 bytes (0 B) copied, 3,4499e-05 s, 0,0 kB/s

    What does this mean, can't find it by only googling please if someone's still active in this thread can you please please help me?!?!
    2013-08-24 07:36 PM
270 ... 311121314