1. Noelh2003's Avatar
    Here is how to fixed the problem pictures not saving to iPhone\Camera Roll:
    SSH into your iPhone
    At the command line type the following:
    1. CD /var/mobile/Media (Execute)
    2. chown –R mobile DCIM (Execute)
    Exit SSH and take a picture with your phone and check the Camera Roll this should fixed the problem. Pictures not saving to iPhone…
    2010-09-20 08:26 AM
  2. climenti's Avatar
    Hello, I lost some pictures from my iphone too, and I will follow all your steps, I have everything but the BDE subsystem, cause I can not get the installer. Anyone can help me. How or from where can I get the installer with a IOS 4.0 or where to get the BDE subsystem. THanks in advance!

    Hello. I have install everything I need to try to recover my pictures, but I can not get the BDE subsystem since I am not able to get installer on my iphone 3gs IOS 4.0 Can you help me? Regards
    Last edited by climenti; 2010-09-23 at 11:08 PM. Reason: Automerged Doublepost
    2010-09-23 11:08 PM
  3. climenti's Avatar
    Hello, I have been trying to get the BSD Subsystem, since I have all the rest ready, but I can not get the BSD Subsystem cause I dont have installer on my iphone. How can I get it?? I have a Iphone 32gb 3gs IOS 4.0 ANYONE?? PLEASE HELP
    2010-09-25 02:17 AM
  4. dasleeper's Avatar
    Why do I get this error:

    iPhone:~ root# dd if=/dev/disk0 | ssh <laptop>@<> 'dd of=iphone-dump.img'
    dd: reading `/dev/disk0': Invalid argument
    0+0 records in
    0+0 records out
    0 bytes (0 B) copied, 0.000502 s, 0.0 kB/s
    -sh: laptop: No such file or directory
    iPhone:~ root#
    2010-09-26 03:48 AM
  5. kmarker's Avatar
    it should be rdisk, not disk.
    2010-09-28 06:00 PM
  6. adding's Avatar
    Hi all - i've been trying to follow the usb connected guide posted by Assoor for over 5 hours now - im totally new to ubuntu, and to ssh - so it's been slow. I'm sure now that i am stuck at this line:

    now open ./itunnel from a terminal , from another terminal enter :
    cd ~
    cat .ssh/id_rsa.pub | ssh -p 3023 [email protected] 'cat >> .ssh /authorized_keys'
    then enter alpine for the last time
    close itunnel
    I ALWAYS get an error saying that the authorized_keys does not exist. I have tried to create it, but i really do not know enough about ssh to solve the problem.

    Please can anyone help

    I'm using an iphone 3g with ios4.1

    Just in case it helps, here is the error message:

    [email protected]:~# cat .ssh/id_rsa.pub | ssh -p 3023 [email protected] 'cat >> .ssh /authorized_keys'
    The authenticity of host '[]:3023 ([]:3023)' can't be established.
    RSA key fingerprint is 2e:f3:1n:cv:f3:6h:3n:1n:en:nn:1n:nn:nn:nn:ne:nn.
    Are you sure you want to continue connecting (yes/no)? yes
    Warning: Permanently added '[]:3023' (RSA) to the list of known hosts.
    [email protected]'s password:
    cat: /authorized_keys: No such file or directory

    Thank you!
    Last edited by adding; 2010-10-13 at 02:13 AM.
    2010-10-13 12:50 AM
  7. nezura's Avatar
    I was successful in extracting my iphone 4 img onto my macbook. I ran photorec on the image but was unable to pull out any jpgs. It said after a few minutes of scanning that one of my sectors is corrupt? Is there another extraction software i could try?
    2010-10-14 01:46 AM
  8. kliobip's Avatar
    err... I have tried and came up with a few problems.. I solved some but not all.
    The phone I was doing this was a 16GB 3G which had been upgraded to 4.1 and lost its data in the process.
    It has a cracked screen so after recovering the data it will go to apple heaven.
    Now mobile terminal isn't compatible with 4.1, but there a package from an alternative source that has a patched version. They are called zombie something and I am not sur if it was a good idea but I added them as a source and installed it. If you have cydia installed you don't need BSD subsystem as cydia is apparently more or less the same thing.
    The wireless after Jailbraking was very flickery, but a reset in settings fixed it.
    The image I got out was nearly 11gb... so I think I'll have to do it again.
    I have a mac, I popped the image in fileJuicer and it fished a whole load of images out with the names :-)
    contacts I am working on.
    Photorec works also for me.

    2010-10-20 12:25 AM
  9. Sanady361's Avatar
    Found this great piece of software some might find useful

    iPhone Back-Up Extractor
    My latest theme - -
    2010-10-20 06:21 PM
  10. macdonald's Avatar
    You will need an iPhone Data Recovery Software to recover all the data of your iPhone if the sizes of the data files are too much.To cope up with these unwanted, uncertain situations iphone backup software comes into use.
    2010-10-22 08:57 AM
  11. OofCZer0's Avatar
    im running windows 7, and have tried multiple ssh server utilities including - WinSCP - Putty - Cygwin, i can SSH into my phone, but i cant get my phone to communicate to my computer. I have searched and searched and have come up with nothing. Is there something im missing? PLEASE HELP!
    2010-10-25 01:34 AM
  12. Fuzzy Barbarian's Avatar
    Another victim of the 4.1 update here.. stupidly didn't make a backup but I've learnt my lesson.. Anyway, After many many days of trying to solve this on my own I've decided I need help with it.
    The command:
    ssh [email protected]'iphone-ip' dd if=/dev/disk0 bs=1M | dd of=iphone.img
    pulls a 748MB image, which photorec recognised and was able to pull ~10 000 files, which using grep to sort through turned out to be a portion of the system partition.

    While the command:
    ssh [email protected]'iphone-ip' dd if=/dev/rdisk0s2s1 bs=1M | dd of=iphone.img
    pulls a 29.3GB image which testdisk nor photorec would recognise as having any partitions, further action with either program is fruitless.

    So, I'm relatively sure that the 29.3GB file is the user partition, I cant figure how to access it though.. Any help would be greatly appreciated.

    2010-10-29 03:49 PM
  13. shalomii's Avatar
    Hey guys, ive managed to get a full size image using the wifi ssh method, but what do i do with it now? Any help is appreciated, thanks.
    Last edited by shalomii; 2010-10-30 at 08:57 PM.
    2010-10-30 08:36 PM
  14. johndrem's Avatar
    Nice post!!....I am really so proud to see such an wonderful post....Its really very awesome....The information you provided on data recovery is very useful.Thanking you....
    2010-11-02 01:33 PM
  15. joseraniero's Avatar
    My wife iphone (3GS 32GB) got stolen, luckily the police was able to found it and returned it back to us.
    Unfortunately, the robbers had deleted plenty of pictures and videos.
    I jailbreaked the phone (blackra1n) and I tried the method here above. I couldn't unmount (command not found) the disk but anyway I was able to produce the disk image.
    But I couldn't find any of the missing pictures or videos. What is even more strange is that a single picture is repeated all over again (7000+ times) from half the disk image to the end.
    I have tried three different disk image extractions, over wifi and over USB. I have tried three different tools: photorec, scalpel and diskdigger and the result is the same with the three, with the disk image being filled with the same picture all over again from half the disk image.
    Could the fact that I was not able to set the partiton 'ro' explain this strange disk image?
    2010-11-04 02:32 PM
  16. domfactor's Avatar
    Hi everyone, I have been trying to recover data from my 4.1 3gs 32gb /private/var for the last few days and have been unsuccessful just like you. I have tried *everything* I could find on the net. I even bought the iPhone Forensics book by Jonathan Zdziarski but he only covers up to 3.1.3. I sent him an email to ask him if he's figured out how to do it in 4.1 and will post his reply if he gets back to me.

    Has anyone had success in recovering data from a 4.1 3gs (or iPhone 4)?

    P.S. I also had the problem of not being able to unmount /private/var and remount read-only. I was able to pull a 31.4 GB image off of rdisk0s2s1 - it seems that the 'bs' doesn't really matter above 1M as long as it works because I pulled off images via USB+SSH with 2M, 4M and they were all the same number of bits.
    2010-11-26 01:37 AM
  17. msft.guy's Avatar
    Hi everyone, I have been trying to recover data from my 4.1 3gs 32gb /private/var for the last few days
    If you restored the phone, the data is _gone_. Otherwise, just use the SSH ramdisk..
    2010-11-26 01:41 AM
  18. domfactor's Avatar
    Thankfully this isn't a restore situation. I am trying to recover a voice memo I deleted. Following all the processes on the internet and in the iphone forensics book I haven't been successful in recovering *any* files from the dd image pulled from /private/var. There are definitely mp3's, images, movies, etc on that image...but photorec isn't able to pull any of them. Any ideas?
    2010-11-26 02:07 AM
  19. Maxhasadhd's Avatar
    Wait...how r the photos still om the phone?
    2010-11-26 05:08 AM
  20. naani1's Avatar
    has anyone with a Iphone 3GS managed to recover actual pictures using any of the methods in this thread? If so, what iOS version and which method worked for you?

    Thanks for this, did anyone find a workaround to newer hardware? is there a way to recover 3gs photo's?
    Last edited by naani1; 2010-11-26 at 04:17 PM. Reason: Automerged Doublepost
    2010-11-26 04:17 PM
270 ... 678910 ...